Zigbee mesh in house with thick concrete walls and stairways

Eventually I found myself with a couple of dozens of zigbee “things” and few other smart thing but with a persistent issue of expansion between the floors/storey.

I’m living in a compound of houses with thick concrete walls which is reinforced with a lot of steel bars due to regulations concerning protection against earthquakes. Each house has a basement with parking lot and store room, main floor with living room, kitchen etc, upper floor with bedrooms and a little roof loft. Each floor is connected with other floors with a curved stairway with build in lights.

Few years back I had similar issues with the wifi access but solved when replaced the old telephone cables (passing through the concrete walls) with UTP cables and established stable home lan, with AP in every floor, console management etc. Home lab is located in the upper floor.

In these days, I have tried to expand my zigbeee mesh with usb routers (cc2531), with wall plugs (tuya) as routers, with ZBMINI in same role, with bigger antenna with CC2652P coordinator, with extension of its usb cable but always there is a barrier, the ultimate frontier, the stairway!
There are not wall sockets near the stairways or in the stairways for using routers. No junction boxes for inserting anything as router.

After various relocations of coordinator, I have conclude 100% that zigbee stuff is reaching each other in the same floor but not in other floor. No matter the separation in WiFi channels, elimination of emission from other RF equipment.
Idea of hanging antennas beside the stairway is a good reason for divorce, there is a verbal statement for this, since the day one of my “smart home adventure”.

So, I wondering what solutions do I have for this issue?

Fitting few zigbee lamps in the build in lights of stairways is a good idea but it is creating a weak point. At any time a kid could switch off manually that light and mesh is gone.

I’m thinking for multiple zigbee coordinators or routers, that will communicate with the HA through LAN but I have no idea if it is possible or how to do it.

I’m running HA in a thin client Futro S720 and I have few raspberry zero laying around…
Any idea or clue how to do it?

Sorry for my English, I’m not native speaker but I hope that you can get the point.


Hey. I had the same problem when I moved to a new house, with a basement. My solution - which might not be ideal for you - was to place a couple of IKEA power plugs (Trådfri) strategically. They are excellent Zigbee routers in my experience, and can be quite useful in their capacity of being a smart switch too :grin:

Any AC powered Zigbee device *should’ be able to act as a router too, though.

Yeap, I have try this way with this wall plug, similar to IKEA plugs. The matter is the distance of the wall sockets (where the power plugs will be plugged) to the nearest wall socket of the other floor.
Due to the distance, height difference and construction of the concrete stairway the area becoming like a black hole. As mentioned earlier, it was the same situation with WiFi coverage few years earlier.

If you have Wifi connectivity (or LAN) across the floors then you could run Zigbee2MQTT on a pi (even a pi zero?) on each level. As long as they all talk back to the same MQTT server with different base topics it will work perfectly.

I have done this in my own home to get over similar issues (it was built in 1662 and the walls are between 3ft and 10ft thick - solid granite/sandstone/whatever mix :slight_smile:


One option might be to replace the in-wall light switch for the stairway with a Zigbee switch. Those would remain powered and act as a repeater even when switched off. And you’d gain control over the lights in the stairway. If you already have a Zigbee wall plug you could test it before purchase by plugging it into an extension cord and temporarily placing it close to the existing light switch.


Not all light switches are repeaters, especially if it is a “no-neutral” switch.

1 Like

In the critical area of stairway(s) there is no any junction box for fitting in it the zigbee switch. Negative of this option
1)The place with switches, both ends, are away from the stairway it self therefore no distance gain
2) need for changing the wiring for bringing L+N to the switch box.

Could you direct me to any URL with such tutorial? If I’ll do it, what should be installed in the raspberries?

Hi, normal raspian should do. Here’s a link.


1 Like

This article is talking for configuration.yaml !!
Do I need to install complete HA in raspberries? In such case, Im not sure for the capacity of the zero or 3B that I have in my hands.

Nope, there is no requirement for HA on the pi. Zigbee2Mqtt is standalone (and also an add-on for your main HA install).

My second pi is running Raspian with no HA. The configuration.yaml mentioned is purely for Zigbee2MQTT :slight_smile:

All you will need are some extra zigbee dongles (which can found quite cheaply)

Thanks Neil, I’ll try it ASAP.
Just broke a pin of CC2531 while trying to bend it for soldering cables (again).
I have to buy a debug cable at least…
It should have coordinator firmware in it, eh?

if you still use a CC2531 as coordinator, move to a CC2652. It makes a lot of difference in your mesh.

No coordinator is a sonoff cc2652P, cc2531 is surplus from the upgrade

If you mean for the “remote” z2m instance, yes, coordinator firmware. You basically have two separate zigbee networks at that point.

An alternative to using a Pi if too hard to find (but pretty much any SBC could work), would be an ethernet connected coordinator like CC2652P2 based Zigbee to Ethernet/USB Serial Coordinator 2023 – TubesZB. Then run the extra instance of z2m on the HA machine.

1 Like

Be sure to also read and follow the tips here → Guide for Zigbee interference avoidance and network range/coverage optimization

1 Like

Guys, I have received cables, pins etc everything is available.

For the time being I have one cc251 in router mode which is not pairing with zigbee2mqtt of HA with cc2652P as coordinator. It is working and pairing perfect with ZHA!! I did some trials with its location and found that only with it in proper operation, in the middle of upper stairway I can reach a lot of remote places.

The other two cc2531 flashed with the standard coordinator firmware and I have spent a lot of time for installing the zigbee2mqttt in raspberry zero. Main problem was the node.js installation.

Presently I’m fixing the first of the two raspberries and this time I’m doing troubleshooting of the startup in the first one. Revering with a request of help or results.
I’m not sure if I have to make a new mqtt user in HA or I should put in raspberry’s yaml the credentials of the single user of mqtt in HA

Here we are stacked,
when checking running services I cant see anything there.
When starting with “npm start” I have this
Local ip is the ip of Home assistant, is this ok?

Use the same credentials for mqtt as the one installed on the HA server. Also make sure the base topic is different (i.e. zigbee2mqtt_pi or something similar).

Guys, I have use these instructions for getting there

  1. for installing node.js in rasperry pi zero this
  2. for installing the zigbee2mqtt this

checking in running services with " service --status-all" I have thisrasp-z-zigbee-services

when running manually “npm start” then this

I dont know what is going on, obviously nothing is stating up and nothing is running.
Any clue?