Zigbee2mqtt bad gateway with conbee 2

I cannot install the zigbee2mqtt with my conbee2 key while all my zigbee devices are working.

I still have the message:

Blockquote

Zigbee2MQTT:error 2021-07-29 16:54:13: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2021-07-29 16:54:13: Failed to start zigbee
Zigbee2MQTT:error 2021-07-29 16:54:13: Check Frequently asked questions | zigbee2mqtt.io for possible solutions
Zigbee2MQTT:error 2021-07-29 16:54:13: Exiting…
Zigbee2MQTT:error 2021-07-29 16:54:13: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
at ZStackAdapter. (/app/node_modules/zigbee-herdsman/dist/adapter/z-stack/adapter/zStackAdapter.js:93:31)
at Generator.throw ()
at rejected (/app/node_modules/zigbee-herdsman/dist/adapter/z-stack/adapter/zStackAdapter.js:25:65)

Blockquote

my configuration:

data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
mqtt:

  • base_topic: zigbee2mqtt*
  • server: mqtt://core-mosquitto*
  • user: mqtt_user*
  • password: xxxxx*
    serial:
  • port: /dev/ttyACM0*
    advanced:
  • log_level: warn*
  • pan_id: 6754*
  • channel: 11*
  • network_key:*
    • 1*
    • 3*
    • 5*
    • 7*
    • 9*
    • 11*
    • 13*
    • 15*
    • 0*
    • 2*
    • 4*
    • 6*
    • 8*
    • 10*
    • 12*
    • 13*
  • availability_blocklist: []*
  • availability_passlist: []*
    device_options: {}
    blocklist: []
    passlist: []
    queue: {}
    frontend:
  • port: 8099*
    experimental: {}
    socat:
  • enabled: false*
  • master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777*
  • slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5*
  • options: ‘-d -d’*
  • log: false*

Thanks

When using a Conbee II and you get: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms) when starting Zigbee2MQTT set the following in your configuration.yaml

serial:
  adapter: deconz

Bottom of page

3 Likes

error message:

CREATED DECONZ ADAPTER
Zigbee2MQTT:error 2021-07-29 17:24:11: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2021-07-29 17:24:11: Failed to start zigbee
Zigbee2MQTT:error 2021-07-29 17:24:11: Check Frequently asked questions | zigbee2mqtt.io for possible solutions
Zigbee2MQTT:error 2021-07-29 17:24:11: Exiting…
Zigbee2MQTT:error 2021-07-29 17:24:11: undefined

strange while my zigbee devices are recognized ??

Are you running ZHA and trying to run Zigbee2mqtt also?

1 Like

You can only run one zigbee stack at the time with the same stick… If your zigbee devices are still recognized, you are running either deconz or zha at the same time. That will not work.

1 Like

yes i 'm running zha and trying zigbee2mqtt is it the problem?

how can i resolve it ? thanks

YES
Read the post from francisp

effectively, i have deconz in my integrations(supervisor) …
so i have to uninstall it but how can i do that ? thanks

ok i have seen it…

if i understood correctly, it is not possible to use zha and zigbee2mqtt together …

if you uninstall deconz, the zigbee devices in zha no longer work

so how to use zigbee2mqtt? thanks

sorry but i am a beginner in ha

confronted with the identical issue I added the 'serial" entry in configuration.yaml, which leads to the following error:

2021-09-14 12:41:25 ERROR (MainThread) [homeassistant.setup] Setup failed for serial: No setup or config entry setup function defined.

… how to proceed please? only connected the Deconz stick, no other add-on configured

would I need a port forward maybe (since I am not on the default ports with my HA instance )?

The part of configuration.yaml containing serial should at least contain the port the adapter is attached to.

serial:
  port: /dev/ttyACM0
  adapter: deconz

And we are talking about the configuation.yaml of zigbee2mqtt, not about the configuration.yaml of home assistant.

8 Likes

thank you! I completely missed that, (probably because there is no configuration.yaml for the zigbee2mqtt add-on, but a configuration panel). Duh. But there is… in the zigbee2mqtt folder. no wonder it is all so confusing. Never use an identical name for different files ;-(

it was immediately successful, how cool is that!

now how to get it to not show under ‘homeassistant’ in mqtt explorer, but under its own login name?

1 Like

by default it uses mqtt discovery (which imo is also enabled by default in HA). So the entity should appear immediately (check developer HA page).

If you don’t have discovery enabled or don’t want to use it, you can add entities on your own. usually you can find needed yaml code on zigbee2mqtt portal on page dedicated to particular device.

I suggest however to change the name of device to something more friendly first (use blue edit icon shown on your screenshot)

thanks, and yes, ive changed the friendly name.
Also I set homeassistant: false ( have 3 HA instances, which makes the moniker somewhat useless :wink: )

it now is found under:

with as you can see all relevant values in the 1 payload. Before with the homeassisant: true it shows like this:

why I dont get that now is still bit unclear to me. shouldn’t I see that, but under the zigbee2mqtt base topic?

I have 3 HA instances too, but still homeassistant: true :slight_smile:

This is the actual payload, independent if homeassistant true or false

image

These are the mqtt auto-discovery messages, only when homeassistant: true :

image

yeah, figured as much :wink: so we cant rename the homeassistant there?

maybe more importantly: we dont need those discovery messages for eg creating an mqtt switch? seems a bit of a hassle, where I would have hoped the sensors and switches on the device to be available in the HA entities…

off-topic:
maybe I should explore the ZHA integration too, and see if that does create the entities. Wonder if we can configure that to use the Conbee on another HA instance, just like we can do with the zwaveJS server and integration.

No. That is the topic HA listens on for auto-discovery messages

If not using discovery, you have to enter everything manual in .yaml (and you won’t have devices, since devices are only created through discovery)