Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)

Does this configuration still work for you, assuming you fixed the typo in configuration.yaml?

It depends on what Zigbee USB device you got. Not all work with zha. I’m using zigbee2mqtt myself, and it works just fine.

Are there a list of sticks that work with Zigbee2mqtt? I’m planning on using a HUSBZB-1

Please first read the documentation: https://www.zigbee2mqtt.io. I don’t think a HUSBZB-1 will work.

So basically I need a CC2531 stick and all the accouterments to flash it?

This is basically a zigbee radio? Will this also work with the zha component?

The CC2531 will work with Zigbee2mqtt (not with ZHA).

Yes, you will need the Stick and the hardware to flash it (CC Debugger).

Alternatively you can buy a stick that is ready to use.

I have a C2531 running as a coordinator for a few weeks now and it’s working perfectly. To increase the range I have gotten the parts and followed the guide on building the CC2530+CC2591 router, however I’m currently facing a problem with flashing it. I have connected the 6 female jumpers between the CC debugger and the module as explained in the guide. But when I plug the debugger into my pc the led on the debugger won’t turn on. After I unplug either the GND or the VCC from the CC2530+CC2591 module the led on the debugger turns red.

I have used the debugger to flash the C2531 successfully so I’m not sure why it’s not working.

Module I got:

Debugger I use:

It’s working, restarting the machine changes the name of the device between ACM0 and ACM1. I need to put some udev-rules in place.

I’m trying to get the Xiaomi temperature sensors to sync up with my zigbee USB stick, however I keep getting

zigbee2mqtt:info 4/27/2019, 7:20:09 PM MQTT publish: topic 'zigbee2mqtt/bridge/networkmap/graphviz', payload 'digraph G {
  "0x00124b0018ed2abd" [style="bold", label="{0x00124b0018ed2abd|Coordinator|No model information available|online}"];

I’ve replaced the battery in both of the sensors, however neither one links up and I can’t for the life of me figure out what I’m doing wrong.

When I have troubles pairing devices that I know are compatible this is what works for me.
Stop the Z2M server.
Unplug the dongle for a min. or two, then plug it back. Make sure it’s still on the same ACM*.
Then restart the Z2M server. And pair.

This has worked for me everytime. That said I only have Zigbee bulbs and switchs and no Xiaomi devices.

Hope it helps.

I’m having some issues and I’ve lost all morning trying to make it work… so I need some help on your side.

I have the router plugged in on the Pi, and several Xiaomi sensors connected to it. Mainly temp/humid sensors that are no more than 2 meters away.

I had Aqara movement and water leak sensors further away, but the link quality was very poor and they were always disconnected.

I bought a couple Ikea repeaters to solve the problem for my lower floor. I have paired the first repeater with the Pi CC2351 and it shows up fine (although no signal info, but I think is normal behaviour). I deleted the Aqara sensors and tried to pair them again with the Ikea extender and not the CC2351.

I’m having no luck at all doing it. I believe I only have to press reset button next to the extender, right? (Z2M is in allow mode).

As a side note I’m trying to connect them back to the CC2351 as well with the same result; LED blinks but they do not connect to it no matter what.

How is the correct procedure and why I can’t make it work? Do I have to pair the sensors back to the CC2351 or am I right in trying to pair them close to the extender?



After reseting the dongle I seem to be able to add devices as before, but they are adding to the main router and not the extender so… how to work with the extender?


I also pair them next to the coordinator (currently you use the terms wrong, if you come from wifi a wifirouter would be a zigbee-coordinator.
Extenders are called routers in zigbee.
After pairing and placing then on there right place they connect to the best “parent”.

About your range issue you might be interested in a device with a antenna mod.

Ready2use Stick with Antenna

Also see this kind review:

Hi Eduardo,

I’m a bit confused about your configuration. I assume you have a coordinator connected to your Home Assistant Pi and not a router. Correct? Use a USB extender cable for better a range.

I also have a couple of Ikea Zigbee extenders connected to my configuration. If I were you I would first connect both Ikea Zigbee extenders to the coordinator and place them where you want them in your house. Next, I would wait a couple of days so that the Zigbee network can settle.

Eventually, after a couple of days, you could try to disconnect the Xiaomi sensors ( zigbee2mqtt/bridge/config/remove) and add them again near the Ikea Zigbee extenders.

Keep on trying. My Zigbee network is working fine with these components.

Thanks to both. Yes, I’ve used the wrong terms.

As I’ve read in this thread, Xiaomi sensors will not connect to the nearest router, but to the one it was originally paired to. That’s why I want to connect them to the router.

I’ve moded the CC2351 to add an external antenna, but it seems it’s not enough.

I’m trying to get this working, but I can’t figure it out. I have done the following.
I’m running everything on a HASSOS VM (Hass.io)

  1. Setup Z2M
  2. Install Mosquitto
  3. Setup MQTT integration in HA with discovery enabled

If I look at the logs of Z2M I see that I have added 2 devices, and they are reporting changes.
I see that Z2M connect to Mosquitto on startup, and when looking at Mosquitto log I see 2 connections, one is labeled homeassistant, the other mqttjs_77d37628 (I’m guessing this is Z2M)

But no devices show up on integrations panel of MQTT

What am I missing ?

EDIT I got it working as far as I could tell Z2M connected as a guest or readonly or something, it didn’t write anything, when I got proper login setup it was working.

Have you looked in unused entities (3 vertical dots on upper l̶e̶f̶t̶ Right on Hass frontend) for the auto discovered items?

I’m having problems like those above. One of my Ikea lights showed after many tries, but not the other. Here is the log:

zigbee2mqtt:info 5/5/2019, 5:38:12 PM New device ‘undefined’ with address 0xd0cf5efffe2ed70f connected!
zigbee2mqtt:info 5/5/2019, 5:38:12 PM MQTT publish: topic ‘zigbee2mqtt/bridge/log’, payload ‘{“type”:“device_connected”,“message”:“0xd0cf5efffe2ed70f”,“meta”:{}}’
zigbee2mqtt:warn 5/5/2019, 5:38:12 PM Device with modelID ‘undefined’ is not supported.
zigbee2mqtt:warn 5/5/2019, 5:38:12 PM Please see: https://www.zigbee2mqtt.io/how_tos/how_to_support_new_devices.html
zigbee2mqtt:info 5/5/2019, 5:38:12 PM MQTT publish: topic ‘homeassistant/light/0xd0cf5efffe2ed70f/light/config’, payload ‘{“brightness”:true,“schema”:“json”,“command_topic”:“zigbee2mqtt/0xd0cf5efffe2ed70f/set”,“state_topic”:“zigbee2mqtt/0xd0cf5efffe2ed70f”,“name”:“0xd0cf5efffe2ed70f_light”,“unique_id”:“0xd0cf5efffe2ed70f_light_zigbee2mqtt”,“device”:{“identifiers”:“zigbee2mqtt_0xd0cf5efffe2ed70f”,“name”:“0xd0cf5efffe2ed70f”,“sw_version”:“Zigbee2mqtt 1.3.1”,“model”:“TRADFRI LED bulb E27 1000 lumen, dimmable, opal white (LED1623G12)”,“manufacturer”:“IKEA”},“availability_topic”:“zigbee2mqtt/bridge/state”}’
zigbee2mqtt:info 5/5/2019, 5:38:12 PM MQTT publish: topic ‘homeassistant/sensor/0xd0cf5efffe2ed70f/linkquality/config’, payload ‘{“unit_of_measurement”:"-",“value_template”:"{{ value_json.linkquality }}",“state_topic”:“zigbee2mqtt/0xd0cf5efffe2ed70f”,“json_attributes_topic”:“zigbee2mqtt/0xd0cf5efffe2ed70f”,“name”:“0xd0cf5efffe2ed70f_linkquality”,“unique_id”:“0xd0cf5efffe2ed70f_linkquality_zigbee2mqtt”,“device”:{“identifiers”:“zigbee2mqtt_0xd0cf5efffe2ed70f”,“name”:“0xd0cf5efffe2ed70f”,“sw_version”:“Zigbee2mqtt 1.3.1”,“model”:“TRADFRI LED bulb E27 1000 lumen, dimmable, opal white (LED1623G12)”,“manufacturer”:“IKEA”},“availability_topic”:“zigbee2mqtt/bridge/state”}’
zigbee2mqtt:info 5/5/2019, 5:38:13 PM Device incoming…
zigbee2mqtt:info 5/5/2019, 5:38:13 PM MQTT publish: topic ‘zigbee2mqtt/bridge/log’, payload ‘{“type”:“pairing”,“message”:“device incoming”}’

I’ll just quote myself because it may be of help to antonholmstedt

1 Like

Turned out that my problem was solved by not using Anonymous login to mosquitto, like @yrune a few posts above.

I have another problem though. I’ve paired some light bulbs and controller socket, but the remote included with that remote isn’t showing up at all when I try to pair it. I press the button inside four times and it starts to blink read, but nothing happens. Since nothing shows up in the log, I think that I’m not in pairing mode on the remote at all? Have you guys successfully paired it?

I made a factory reset by pressing 4 times, but I read now in the manual and it makes me confused:

1 Hold the ON/OFF switch close to the
control outlet you want to add (no more
than 5 cm away).
2 Press and hold the pairing button for
at least 10 seconds , you can find the
pairing button under the rear cover.

For wireless ON/OFF switch:
Press the pairing button 4 times within 5

Anyone know if this dimmer from xiaomi/yeelight works with zigbee2mqtt? It’s new on the market and not listed in the supported devices!