Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)

How can I disable the built-in UI?

  port: 8080
  new_api: true

I have recently installed Zigbee2MQTT Assistant. Very nice.

One thing puzzles me though, why is my co-ordinator reported as having Link quality is 111/255.? Surely this is the Link quality between the coordinator and itself, and should be perfect?

Is there a way to manually define a network route from an endpoint to the coordinator?
I have some Xiaomi movement sensors that have 0 signal. I placed and Ikea Tradfri expander in between the sensors and coordinator but the sensors do not connect to the Tradfri, they are still connecting to the coordinator. Can I force them to do so?
Thank you.

You have to remove them and then re-pair them. The Xiaomi devices won’t re-route.

Ok. I’ll try that tonight. Thank you

Hello everyone,

I opened a new thread seeking some help with Zigbee2Mqtt installation but not much luck there… so I decided to come here as there so much awareness in this thread, sorry if its not suitable though.

I am struggling to get this addon to work and I really would appreciate some help if possible. So, I have Hass OS 4.13 installed in a VM in Unraid. Zigbee2Mqtt addon was installed using supervisor addon manager, and everything is updated.
The issue is when I try to start the addon, HassOs prompts me a window with the message “Unknown error, see logs”, No logs within Zigbee2Mqtt addon log, but when I have a look at supervisors logs I get the following error:

The thread I opened, I was suggested that could be due to a permission issue or missing folder/file as printed in the log. I have created the folder and files and adjusted the permission using FTP as follows:

Even though I have created the folder/file with different combinations to ensure the address matches Zigbee2Mqtt doesn’t start still. Am I missing anything? Any idea?

Thanks guys.

Hi, recently I have flat battery for few end devices. After changing the battery, the device doesn’t seem to communicate with the zigbee2mqtt and I have to force removed and re-pair it.

Do we really need to re-pair every time we changed the battery?

Thanks in advance.

Idid not have to re-pair after changing the batteries in my ikea motion sensor and ikea on/off switch.

Did you change the battery till the device doesn’t respond? Or you change it before the battery is completely dead and does not reporting anymore?

For my case, my battery is seems completely dead and it has stopped responding to the zigbee2mqtt before changing the battery.

Yeah I think taking the batteries out for as short a time as possible would be wise.

I changed the batteries because I wanted to update the firmware :slight_smile: I did not succeed with the old batteries.

Anyone know how should I connect the external antenna to the CC26X2R1?

Do I need to “solder” the antena to the board?
Do I have to do anything else?

I’ve looked information about it, but I have found little information.
Basically this:
https://e2e.ti.com/support/wireless-connectivity/other-wireless/f/667/t/872834?LAUNCHXL-CC26X2R1-Resistor-change-for-external-antenna- and this: https://e2e.ti.com/support/wireless-connectivity/zigbee-and-thread/f/158/t/880219

But I don’t see those C24 and C14.

Anyone more experienced with this boards that could help me?
How do I connect the external antenna?
How do I “select” it?

Here a picture of the board with the “unattached” antenna.

Thank you!

I looked at this (and found those posts in ti.com) but couldn’t figure it out either, Mine has enough range for now anyway, but it would be good to know the answer!

1 Like

Before heading down this path, you may care to check Problems when ozwdaemon is on a different machine

I know it’s referring to ZWave rather than Zigbee, but the same principle applies: it may be more reliable - long term - to stick with a dedicated hub.

I have not found any such mqtt issue with z2m.

If you can guarantee that the connection will never dfrop, then you will not hit this. However, the fact is that it fails to cope with flaky connections: which many networks will have occasionally.

You’ve tried this on zigbee2mqtt?

Hi, I just built a second zigbee router with CC2530+CC2591 and paired with my CC2531 coordinator. It’s working fine with the second router with LQI ~130. I have a first working router with the same hardware and before the second router installed, the first router LQI is always 70+.

After installing the second router, the first router LQI starts to vary from 130 - 70 and I believe when it shoot up to 130, it is actually routing to my second router, but it is not consistent. The physical distance of the router and coordinator are like this: coordinator --> second router --> first router, where the first router is the most far from my coordinator.

May I know is there anyway I can force the first router to route its signal to the second router? This is because there are few devices are still connected to my first router and its LQI is only ~70+.

Here is LQI over time for my first router. It vary from 130-70. I tried to do a hard reset and after that, it always stay at 70+.


Did you give it a go? I am now thinking about connecting the same to HA.