Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)


#977

I don’t see it here https://github.com/Koenkk/zigbee2mqtt/wiki/Supported-devices


#978

Could you please advise what type of card are you using in Lovelace to show the map.png I used type: picture it shows map, but never updating the new map…
Thank you!


#979
  - type: picture
    image: /local/map.png

Are you sure the daemon is doing his job?
Sometimes it hangs, and a restart is needed…


#980

Mesh is happening but map function is buggy and doesn’t show it.


#981

How do you guys handle bulbs losing power?

My hue lights if they lose power and then turn back on when its back (someone has manually hit the switches), home assistant doesnt get notified that the light is now powered on and the states are all wrong, previous when using the hue hub it seemed to poll every so often to see if the light was on


#982

Interesting. Are you 100% confident the map function doesn’t work properly? I’ve pulled a lot of hair out trying to get routers to work based upon that map function.


#983

#984

Thanks. I wish there was a way to troubleshoot mesh communication issues. Sounds like the generated map is currently useless.


#985

the map works for some people. even though i can’t see the mesh, the devices in my house must be meshing to be able to work, i just can’t examine the mesh.


#986

I had been trying different brands of power plugs to try and determine whether they could be used to extend the range of the network. I used the map to try and determine if any of the plugs worked successfully as routers. When none showed up with sensors connected to these plugs on the map, I assumed my Xiaomi sensors would not connect to these plug routers. Now I’m wondering if I should revisit their usefulness while I wait for my Xiaomi plugs to arrive from China.


#987

How to make this work on hassio, hassos?
It says that the folder /lib/systemd/system does not exist.

is it possible to run this script in node-red so i dont have multiple places to run scripts from?

Thx in advance


#988

Sorry, I am on hassbian, no idea.


#989

I’ve upgraded to the latest version (1.0.0) of Zigbee2mqtt and I seem to have a device stuck in limbo (IKEA control socket). It’s seen in Zigbee2mqtt and was previously joined ok but I’m not getting a response in HA (I have a feeling HA is seeing a version prior to update). I want to try and remove it entirely from both Zigbee2mqtt and HA and add it again but I have a feeling it’s stuck in the Zigbee2mqtt database and HA entity storage files and therefore not allowing me to start again.

Had a quick look in both files and I can see it listed but there doesn’t seem to be an easy way to remove the entities without potentially causing issues with the formatting.

Has anyone else come across such an issue and can help out?

EDIT: I took the plunge and manually removed the offending entities from: .storage/core.entity_registry and all working again now.


#990

Have moved all my xiaomi-aqara devices to zigbee2mqtt and it is working great. Also use 2 xiaomi zigbee power sockets and I’m 100% sure they work as routers because they are concatenated to reach some far away sensors (which have no connection without these power sockets working as routers).

But I don’t see a correct network map with these sensors connected to the power sockets.The network map is showing something, but it isn’t correct or complete and can’t be trusted. Like Koenk said several times, it’s not correct and need some work but it’s not high on his priority list.
Also the zigbee mesh network is dynamic so real maps will probably be full of lines representing many connections.


#991

Hey guys, been using Zigbee2mqtt for a while now and it’s working great. I’m currently using a CC2531 on my Pi 3 and it works great, but range is limited. I’m looking to add a router to my zigbee network, though not sure what to add. I’ve tried a philips hue light bulb but had so many issues with it and randomly turning on/off I moved it back to my hue hub.

I’m thinking of adding a CC2530 but not sure the best way to implement it. How can I power it? Ideally I’d like to plug it into a phone charger and power it that way, but I can’t find out how to do that if it’s at all possible.

Does anyone have any pointers or a guide?

The other option is the use the Xiaomi Mi power plug ZNCZ02LM, but as it’s not approved for use in Australia I’d rather stay away from that for now.


#992

Hi.
I used a simple 1 plug usb charger from Ikea, worth 5€ here.
Consider that powered devices (such as Ikea lamps) work themselves as zigbee repeaters.
I set-up 3 CC2531 repeaters, to find later that they are not needed.


#993

What USB charger are you referring to?

But yeah, the IKEA Trådfri line will work fine as routers and are easy to integrate with Zigbee2mqtt.
I use some control outlets for this purpose.


#994

https://www.ikea.com/us/en/catalog/products/90412285/


#995

For some reason my Zigbee2mqtt home assistant package integration has stopped working as expected. it no longer gives me a 2 min countdown or enable/disable the main join. I added it again from https://koenkk.github.io/zigbee2mqtt/integration/home_assistant.html as I thought there may have been some changes but its still not working. Anyone else come across this?


#996

Ooooh, I completely misread the context of your post and though you used the charger itself as a router and wondered what magic device you had found!
I get it now. :smile: