Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)


#997

Suddenly I have the old unique id’s as entity’s and not the friendly names anymore. Anyone else have this problem? they still publish to the friendly names topics but the entity id’s are not changed.


#998

I think you will find that this is part of the v 1.0 zigbee2mqtt upgrade. If you look at the release notes there’s a bit in there about integration with the HA device registry. In the HA web interface, if you look at the “Configuration” panel and then “Integrations”, you should see your zigbee2mqtt devices listed under the MQTT integration.


#999

Thank you Patrick!


#1000

I have a few xiaomi power plugs ZNCZ02LM and they work great as zigbee router in zigbee2mqtt to reach some far away sensors. I don’t use smart led bulbs as I do all the light switching with Sonoff’s with Tasmota.
Also have a few cc2531’s flashed as zigbee routers and plugged in a simple usb adapter in my house. Work also great. The cc2531 draws about 50mA current so you can use the most simple small usb adapter.


#1001

Good to know. Think I might just end up getting one or two of these.

I was thinking of the cc2230’s with the antenna, but not sure how to power them around the house.


#1002

Yes, probably a better range with cc2530 (I suppose you mean these) + antenna, but I find them more difficult to connect and to case.


#1003

Yes, typo on my part. I haven’t seen these with a USB plug, so I’m not sure how to deploy them around the house.

Maybe I’ll just go with the cc2531 and make in or 2 a router. Just need a case for them.


#1004

Hi all,

I need some help with this. I flashed my CC2531 usb dongle, installed the zigbee2mqtt hassio add-on, but I get timeout errors when I tried to permit to join on:

Configuration file found. Will overwrite configurable               fields with values from add-on configuration
[Info] Configuration written to /share/zigbee2mqtt/configuration.yaml
2018-12-20T12:47:03: PM2 log: Launching in no daemon mode
2018-12-20T12:47:04: PM2 log: App [npm:0] starting in -fork mode-
2018-12-20T12:47:04: PM2 log: App [npm:0] online
> [email protected] start /app
> node index.js
  zigbee2mqtt:info 2018-12-20 12:47:16 Logging to directory: '/share/zigbee2mqtt/log/2018-12-20.12-47-16'
  zigbee2mqtt:info 2018-12-20 12:47:19 Starting zigbee2mqtt version 0.2.0 (commit #cf9a5b7)
  zigbee2mqtt:info 2018-12-20 12:47:19 Starting zigbee-shepherd
  zigbee2mqtt:info 2018-12-20 12:47:21 zigbee-shepherd started
  zigbee2mqtt:info 2018-12-20 12:47:21 Coordinator firmware version: '20181024'
  zigbee2mqtt:info 2018-12-20 12:47:21 Currently 0 devices are joined:
  zigbee2mqtt:info 2018-12-20 12:47:21 Zigbee: disabling joining new devices.
  zigbee2mqtt:info 2018-12-20 12:47:21 Connecting to MQTT server at mqtt://192.168.0.11:1883
  zigbee2mqtt:info 2018-12-20 12:47:21 zigbee-shepherd ready
  zigbee2mqtt:info 2018-12-20 12:47:21 Connected to MQTT server
  zigbee2mqtt:info 2018-12-20 12:47:21 MQTT publish: topic 'zigbee2mqtt/bridge/state', payload 'online'
  zigbee2mqtt:info 2018-12-20 13:11:29 Zigbee: allowing new devices to join.
  zigbee2mqtt:info 2018-12-20 13:11:32 
	{"message":"request timeout","stack":"Error: request timeout\n    at CcZnp.<anonymous> (/app/node_modules/cc-znp/lib/ccznp.js:255:22)\n    at Object.onceWrapper (events.js:315:30)\n    at emitOne (events.js:116:13)\n    at CcZnp.emit (events.js:211:7)\n    at Timeout.<anonymous> (/app/node_modules/cc-znp/lib/ccznp.js:234:18)\n    at ontimeout (timers.js:498:11)\n    at tryOnTimeout (timers.js:323:5)\n    at Timer.listOnTimeout (timers.js:290:5)"}
  zigbee2mqtt:info 2018-12-20 13:11:32 MQTT publish: topic 'zigbee2mqtt/bridge/config', payload '{"log_level":"info","permit_join":true}'

My add-on config is:

{
  "data_path": "/share/zigbee2mqtt",
  "homeassistant": true,
  "permit_join": false,
  "mqtt_base_topic": "zigbee2mqtt",
  "mqtt_server": "mqtt://192.168.0.11:1883",
  "serial_port": "/dev/ttyACM0",
  "mqtt_user": "XXXXX",
  "mqtt_pass": "XXXXX"
}

Someone know why I get this errors? Please help!! :sweat:


#1005

[quote=“dojf, post:1000, topic:52108, full:true”]
I don’t use smart led bulbs as I do all the light switching with Sonoff’s with Tasmota. [/quote]
Please, could you kindly elaborate a bit more on your scenario? I’m considering using Fibaro zwave modules, but would love to take your scenario into account.

Thanks!


#1006

In short: I’m using xiaomi-aqara (Zigbee based) sensors (door, motion, vibration, temperature, etc) and also wireless wall switches (also zigbee) connected to HA via zigbee2mqtt using mqtt as protocol.
I’m using (Wifi based) Sonoff Basic, Pow, S20, flashed with Tasmota software for switching dumb led lamps, and also using mqtt as protocol. And further the usual automation so excellently provided by Home Assistant :grinning:
Probably Fibaro zwave modules will do more or less the same, but probably at a price difference.


#1007

Most log lines look fine.

After 13:11:29 you started the pairing process.

The one line with :

zigbee2mqtt:info 2018-12-20 13:11:32
{“message”:“request timeout”,“stack”:“Error: request timeout\n at CcZnp. (/app/node_modules/cc-znp/lib/ccznp.js:255:22)\n at Object.onceWrapper (events.js:315:30)\n at emitOne (events.js:116:13)\n at CcZnp.emit (events.js:211:7)\n at Timeout. (/app/node_modules/cc-znp/lib/ccznp.js:234:18)\n at ontimeout (timers.js:498:11)\n at tryOnTimeout (timers.js:323:5)\n at Timer.listOnTimeout (timers.js:290:5)”}

has clearly the problem.

Its not clear to me what you try to pair, but to me it looks like you did not finish the pairing process, or something else.

Often it takes some effort to pair and you have to do it more than once. It also helps (with a battery device) to take out the battery, put in in again, do the pairing process and take care the device stays in contact with the zigbee2mqtt device. Often by pushing on the pairing butten every few seconds till you see feedback in the zigbee2mqtt log.


#1008

So, your dumb led lamps are plugged into a wall outlet right? I’m interested in keeping my existing wall switches yet making them integrated into HA, but from your answer above it would appear you did opt for mixing your original wall switches with aqara wireless switches (WAF challenge), and used Sonoff for outlet plugged lamps. Is my understanding correct?


#1009

Hi @dojf, thanks for answering. This message appears at the same time than I’m turning on the “allow to pair devices” switch, so, I don’t have chance to try paring any device.
It is very strange… When I turn off this switch, I get the same error message. Do you understand what I mean?


#1010

Hmm, if that is the case then I would try to remove everything zigbee2mqtt related and reinstall it again. The faulty log line points to certain code fragments. If it happens again then maybe try to find help at Koenk’s github website.


#1011

Yes, mostly. What you wish is understandable but more difficult to implement. For now I take the more easy route to automate the lamps which are connected to wall outlets. Every room still has some original lights with existing wall switches and I leave them for the moment intact. My wife demands that there is light in the house whatever happens to the home automation. I’m not able to guarantee 100% uptime with all the automation which is constantly changing and in need of updating :yum:


#1012

Can you please explain how you did this? I have an Xiaomi occupancy sensor that is too far from the Coordinator to work. I can pair and it works fine close to the coordinator. I purchased a few Xiaomi power plugs, but cannot get the Xiaomi Occupancy sensor to connect using the Xiaomi power plug as a router.

When you paired your “far away” sensors, did you pair it with it close to the ZNCZ02LM or did you first pair it to the coordinator and then it automatically started using the ZNCZ02LM when you moved away from the coordinator but close to the ZNCZ02LM?

I’m kind of at the end of my rope as I’ve tried 3 other brands of power plugs. I thought for sure once I bought the Xiaomi plugs the problem would be solved. I must be doing something very fundamentally wrong? I know I can flash my own zigbee routers, but it seems like such a waste to be unable to use the power plugs as routers because I already have the plugs throughout the house.

Also should have mentioned none of the Xiaomi door sensors that are far away from the Coordinator seem to use the much closer Xiaomi power plug.

Please impart some wisdom on me :slight_smile:


#1013

Hope you have the Zigbee Powerplug ZNCZ02LM and not the wifi powerplug ZNCZ02CM as they are almost the same (I bought a few by mistake before buying the correct zigbee ones).

Pair all the devices (sensors and ZNCZ02LM’s) near the zigbee2mqtt (zigbee coordinator) stick as they cannot be paired through zigbee routers. All devices must be paired directly to the concentrator.

Then place the ZNCZ02LM’s (zigbee routers) between the sensors (zigbee end devices) and zigbee2mqtt stick (zigbee coordinator).

In a Zigbee mesh network the devices find their way to the coordinator dynamically and on their own. You cannot influence that .

A zigbee2mqtt networkmap (in my case) doesn’t give a correct representation of the network.

Hope this helps :smile:


#1014

Yeah I’m definitely using the ZNCZ02LM. I paired the sensor with the coordinator. Verified it works well with HA within range of the coordinator. Verified the ZNCZ02LM is working with the coordinator and HA. Moved the sensor 5 feet on the other side of the ZNCZ02LM. The ZNCZ02LM is between the sensor and the coordinator. The sensor no longer responds in HA. So frustrating. Not only have I been unable to extend the range of the Zigbee network with the Xiaomi plug, but I’ve also tried:

Sylvania 72922-A
Iris 3210-L
GE 45852GE

I’m kind of desperate here so if anyone can think of any troubleshooting tips, please reply.


#1015

Hmm, don’t have a clue after this. Ideas to try:

The zigbee2mqtt log doesn’t give any clues?

The sensor isn’t still trying to connect to the concentrator? (maybe still to nearby?)

Remove the sensor ( with mqtt command with “zigbee2mqtt/bridge/config/remove” ) and pair it again?

I’m sorry, no more ideas at the moment.


#1016

How long are you waiting?