Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)


#1057

May be the only way as I cannot find the elusive topic to publish a null to. I’m on Hassio. Mosquito Broker addon config says there is a mosquitto folder. Mosquitto log says: 1545933123: Saving in-memory database to /data/mosquitto.db.

I can’t seem to find this database so I can delete it. I ssh using root credentials, and browsed through the folders looking using “ls” Doesn’t seem to be anything in the /data folder unless it’s hidden somehow. Also browsed the Samba share looking. Any tips on finding this database so I can delete it? Obviously I’m a little over my head.

Edit:
Tried find . -name "mosquitto.db" and it found nothing.


#1058

This is how I do it.

1 Copy the mqtt configuration in the web gui of hass.io
2 Uninstall mqtt add-on
3 Reinstal mqtt add-on
4 Paste back the config info into the web gui
5 Click save config changes
6 Restart the mqtt plugin

This will kill all the old retained topics and sensors.

Zigbee2mqtt will repopulate all the existing sensors when you restart the zigbee2mqtt add-on


#1059

Jesus that is a bit steep, destroying your database to get rid of one entry.


#1060

Database ain’t important for mqtt all my sonoffs don’t use retained tag so it’s only zigbee2mqtt and that repopulates on restart.


#1061

From start to finish, took less than 2 minutes. Finally got rid of the damned thing. Thanks. All the other sensors came back in quickly.

@nickrout Yeah I tried every topic that was suggested to publish a null to without success. Would still love to find that topic for future reference.


#1062

Discovery topics (unless you have changed the default) are under homeaasistant. My Ailight for example publishes to

homeassistant/light/Foyerlight1/config

#1063

Glad to see this is resolved!

This is tad puzzling: earlier, stopping the gateway had not been enough to get rid of the entity. This latest bit of information would seem to point to the entity disappearing because it is not in the gateway’s database anymore. But if we deleted its database, it wouldn’t even know how to compute a delta and publish a “remove” message, or am I missing something?


#1064

The entity is created by mqtt auto discovery and exists in the mqtt brokers database as a retained message.


#1065

I’m using Hassio and I have my Xiaomi aqara sensors paired and I can see mqtt messages as the temperature changes. However I can’t seem to get these sensors displaying in Home Assistant, I’ve tried so many different configurations and I can’t see anything (even in dev-state). Could you share your mqtt sensor config, or are you using some other method for reporting (graphing) temperature?
Thanks


#1066

I’m using the built-in MQTT broker, so all I’m using as MQTT configuration is:

mqtt:
  discovery: true

As my live system is still running on V0.75.3 I don’t use an MQTT password yet.

The sensors just show up in the /dev-state tab as:
sensor.friendly name_temperature
sensor.friendly name_pressure
sensor.friendly name_humidity

Still waiting for V0.82+ version that doesn’t break my Ecovacs integration and other things before I upgrade.


#1067

Many thanks for this, I had forgotten to add appropriate authentication configuration for mqtt discovery.


#1068

I have the same problem, can anyone help or suggest me what to do?
A bit of context, I am using the ConBee (deCONZ) zigbee usb dongle in a RPI 3B+ and hassio. I wanted to setup zigbee2mqtt addon to avoid using proprietary gateways.

The zigbee2mqtt config:
{
“data_path”: “/share/zigbee2mqtt”,
“homeassistant”: true,
“permit_join”: false,
“mqtt_base_topic”: “zigbee2mqtt”,
“mqtt_server”: “mqtt://homeassistant:8883”,
“serial_port”: “/dev/ttyUSB0”
}

I have the following problem when starting the add-on:
zigbee2mqtt:error 2019-1-1 18:14:03 Error while starting zigbee-shepherd!
zigbee2mqtt:error 2019-1-1 18:14:03 Press the reset button on the stick (the one closest to the USB) and start again
zigbee2mqtt:error 2019-1-1 18:14:03 Failed to start
{“message”:“request timeout”,“stack”:“Error: request timeout\n at CcZnp. (/zigbee2mqtt-1.0.1/node_modules/cc-znp/lib/ccznp.js:255:22)\n at Object.onceWrapper (events.js:315:30)\n at emitOne (events.js:116:13)\n at CcZnp.emit (events.js:211:7)\n at Timeout. (/zigbee2mqtt-1.0.1/node_modules/cc-znp/lib/ccznp.js:234:18)\n at ontimeout (timers.js:498:11)\n at tryOnTimeout (timers.js:323:5)\n at Timer.listOnTimeout (timers.js:290:5)”}


#1069

I wasn’t aware you could use deCONZ with this zigbee2mqtt project.


#1070

That’s right this project only works with the TI cc253x chips, no deconz or zigate


#1071

You are right. I start reading from top the thread and i saw someone had a similar error but apparently due to something else.
Pity that it is not possible to use the deCONZ dongle. Therefore, the only way would be to buy the CC253X chip? Is it enough to buy the chip or do I need to buy any supporting hardware to use it?
Thank you a lot, I am very new in hassio, but I am eager to automate my appliances.

My next challenge will be the roller-shades with Somfy motors where I have only the connexxon bridge and not the Tahoma gateway. I hope to find some support on that :slight_smile:

update: http://zteo.com/posts/zigbee2mqtt-step-by-step/ thanks @Fusion


#1072

For heaven’s sake read the documentation, hardware needed is detailed there.


#1073

Is this a good cc debugger for programming? https://www.ebay.com/itm/3-3V-Zigbee-Emulator-Debugger-Programmer-Support-CC2430-CC2530-CC2531-CC2540/292046830222?hash=item43ff58fa8e:g:HUkAAOSwhlZYvN6w:rk:1:pf:1&LH_BIN=1

It is much cheaper than the boxed version.


#1074

I’m on the fence of buying a Xiaomi Gateway vs putting together a Zigbee2Mqtt and wondered if it’s possible to use a Xiaomi gateway to add non Xiaomi things to e.g. TRADFI bulbs? or is that the advantage of Zigbee2MQTT that it’s vendor agnostic?


#1075

You rarely can use another vendor’s gateway (philips hue seems to be compatible with ikea bulbs though). That’s exactly what this project addresses. You can’t use Xiaomi’s gateway with, say, Osram led stripes.


#1076

Honestly I would stick to the known hardware. So many variables already…