Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)


#1243

Thanks yes, i can do it that way. thank you. I do seem to get the original copy of the sensor as well though (because of mqtt discovery being enabled).

Edit: actually that might be retained discovery topics maybe?


#1244

I can’t find the location of devices.js.

node_modules/zigbee-shepherd-converters/devices.js

Can you tell me how to find this?

I need your help!


#1245

context please? what OS for a start.


#1246

Oh, sorry.

I am using Hass.io and installed zigbee2mqt through addon.


#1247

Please ask the addon author. This thread is not about the addon.


#1248

I am not sure about that I don’t use discovery I just add mine in manually.


#1249

Hi, here is the info you need: https://koenkk.github.io/zigbee2mqtt/how_tos/how_to_support_new_devices_on_hassio.html


#1250

Thank you, your answer was helpful.


#1251

Hi,

I flashed my CC2531 with router firmware linked on the docu page:


router-cc253x-std.hex.

Router is connecting to my network, but end-device doesn’t seem to be using it?


#1252

The map isn’t accurate and shouldn’t be relied upon to draw any conclusions.


#1253

Is there any other way to check if it’s working properly?


#1254

Is the device working in home assistant? If so, be happy and stop worrying abut the mesh.


#1255

It is working fine now:

One more question:

Can you show me an example for DJT11LM vibration sensor to how I can use in an automation (action: tilt or vibration)?


#1256

I’m having trouble.

I successfully flashed cc231 with this file as instructions
all good so far.

node --version  # Should output v10.X
npm --version  # Should output 6.X

these req. also ok.

# Install dependencies
cd /opt/zigbee2mqtt
npm install

when I run npm install I got error on zcl-id integrity

npm WARN tarball tarball data for [email protected]://github.com/koenkk/zcl-id/tarball/master (sha512-VzHMq1JqhdCVVLWBmCECLrkQMEY6DYL/0gp4GrsJbyQuBE4wcMGs0zAHhF9DxlWZ4eT6zkiH0e5z6hEhUSRLRA==) seems to be corrupted. Trying one more time.
npm WARN tar ENOENT: no such file or directory, open '/opt/zigbee2mqtt/node_modules/.staging/zcl-id-67ebab72/definitions/common.json'
npm ERR! code EINTEGRITY
npm ERR! sha512-VzHMq1JqhdCVVLWBmCECLrkQMEY6DYL/0gp4GrsJbyQuBE4wcMGs0zAHhF9DxlWZ4eT6zkiH0e5z6hEhUSRLRA== integrity checksum failed when using sha512: wanted sha512-VzHMq1JqhdCVVLWBmCECLrkQMEY6DYL/0gp4GrsJbyQuBE4wcMGs0zAHhF9DxlWZ4eT6zkiH0e5z6hEhUSRLRA== but got sha512-lfVS1kAuuiSs0laGpaOX9tpn3r/hZvNZLCSr1ZxZNaUz9a4xDRdGkvbdEox4x3Xkg8PTFF2Au1S5cFRUmbA/cA==. (22425 bytes)

any help much appreciated! thanks.


#1257

solved using DEV branch.

https://github.com/Koenkk/zigbee2mqtt/issues/1026


#1258

Hi I got zigbee2mqtT version 1.1.1 with a couple of aqara door/window and water leak sensors, a tradfri light bulb and a dimmer.
All worked very well!
After updating CC2531 USB stick with CC2531ZNP-Prod_20190109.zip firmware, I resynced all my aqara sensors by single clicking on sync button and they worked great again.
But how can I resync the tradfry light bulb and the dimmer?
Thanks!


#1259

Are you suggesting that reflashing keeps all the pairings in the stick and devices don’t need to be repaired?


#1260

I don’t know.
This is my first reflash of the stick.
As I experienced with aqara sensors I only clicked ones the pairing button on the sensors without resetting them as the first time and without set zigbee2mqtt to accept new devices icoming.
For tradfri I wasn’t able to repair.
I do not test yet removing them from configuration e repete the first pairnig.


#1261

Interesting! Thanks for the info.


#1262

Just as a point of reference, I’m having GREAT results with a CC2530+RFX2401 board (XCore2530 from Waveshare), plugged into a Waveshare ZB502 motherboard, which handles the USB-UART duties. It plugs into USB and hooks right up to a standard & cheap CC Debugger (via the ZB502 board).

It’s a bit of an ugly contraption and maybe a bit of overkill, but I put a hilariously large 9dBi antenna on it – and the range and reliabilty are phenomenal so far. I just need an enclosure for the boards to reduce the eyesore factor.