Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)


#1223

If you mean the new Zigbee Groups, you have to flash the newest firmware and set the groups up in your zigbe2mqtt configuration.yaml:

after that you can add devices via mqtt to the group. as far as i seen, you can only turn them on/off and set the brightness (if the devices are lights). unfortunately i didn’t get the state reporting to work :frowning:

- platform: mqtt
  schema: json
  name: "Office"
  state_topic: "zigbee2mqtt/[Group Name]/set"
  command_topic: "zigbee2mqtt/[Group Name]/set"
  availability_topic: "zigbee2mqtt/bridge/state"
  brightness: true

#1224

I see all that. I think I’m messing something up in the addon config due to the syntax. The hass.io addon adds " to the formatting so I’m missing something easy but I can’t get this to format correct:

groups:
‘1’:
friendly_name: group_1


#1225

Your yaml lacks indentation, or you haven’t formatted it correctly in the forum. The procedure to format it correctly is at the top of every forum page.


#1226

should be something like:

groups:
  '1':
    friendly_name: office
  '2':
    friendly_name: bathroom

#1227

Hi all

I’ve a CC2531 flashed as described https://koenkk.github.io/zigbee2mqtt/getting_started/flashing_the_cc2531.html and it’s working.
Now I’ve got a CC2530, like this one
schermata 2019-02-03 alle 12 20 04
and flashed with the firmware found here https://github.com/Koenkk/Z-Stack-firmware/tree/master/router/CC2530/bin, the file router-cc2530-std.hex.
In Hassio, I’ve loaded the addon Zigbee Map, but I don’t see any “router” that is not a device that I already have and that have specific name, like “OSRAM LIGHTIFY LED” that work as router.

The CC2530 is connected to a CP2102 (I’ve tried also with a CH340G) connected to 3.3V and GND.

I don’t see any led turning on, don’t know if there is one.

Any suggestion on how I can check if all is working?
The CC2530 should automatically become part of my zigbee network ?

Thanks


#1228

Mileage may vary - I tried this method but it didn’t work for me unfortunately (even though the PAN ID was the same after isolating the coordinator)


#1229

No, you’ll have to pair it into your network as if it were any other device.


#1230

Thanks @Silicon_Avatar

There is no button to press on the CC2530, how can I pair it? :open_mouth:


#1231

That’s a good question! Lol, it looks like I spoke too soon.

Reading some other threads on it, it looks like you might not need to press anything. The instructions I found say:

    1. Download and flash the firmware.
  • 2.Power off/on (restart) the router.
  • 3.Permit joining to a network on your coordinator.

So it looks like you might just have to put the coordinator into pairing mode when the CC2530 is powered on.

The two threads I was looking at are Source 1 and Source 2.


#1232

I reflashed it and positioned near the coordinator, 1mt, and now I can see it from Zigbee Map,
Thanks!

Now I will try to position on another floor to see if it will extend properly the network!!


#1233

I also have bought such a 2530 because my device is to far from the cc2531. Can you tell me how far you can put the cc2530 away frome the cc2531.


#1234

This is my current config file for the hass.io addon. I’m trying to add the group syntax but there is something I’m missing because once I stat adding a group my formatting becomes incorrect.

What is the proper syntax/formatting to get it into this? I have the groups section set up but I can’t seem to populate it correctly.

{
  "data_path": "/share/zigbee2mqtt",
  "homeassistant": true,
  "permit_join": true,
  "mqtt_base_topic": "zigbee2mqtt",
  "mqtt_server": "mqtt://xxx.xxx.xxx.xxx:1883",
  "serial_port": "/dev/ttyACM0",
  "devices": [
    {
      "id": "0x000d6f000aa9a3fe",
      "friendly_name": "Kitchen1",
      "retain": true,
      "occupancy_timeout": 20,
      "qos": 1
    },
    {
      "id": "0x000d6f000aa9d1de",
      "friendly_name": "Kitchen2",
      "retain": true,
      "occupancy_timeout": 20,
      "qos": 1
    },
    {
      "id": "0x000d6f000aa85d11",
      "friendly_name": "Kitchen3",
      "retain": true,
      "occupancy_timeout": 20,
      "qos": 1
    },
    {
      "id": "0x000d6f000aa82762",
      "friendly_name": "Kitchen4",
      "retain": true,
      "occupancy_timeout": 20,
      "qos": 1
    }
  ],
"groups": [
    ],
  "network_key": [],
  "mqtt_user": "mqttuser",
  "mqtt_pass": "mqttpass"
}

#1235

I would have thought it goes between [ and ]


#1236

@nickrout It does but it’s the syntax between the brackets where I’m missing something.


#1237

Now I placed on another floor, vertically positioned from the CC2531 and the signal is very bad and it’s offline probably because of that.

The value that you see as 8, moves from 0 to 8-9, but always as Offline.

Sigh!


#1238

I’m not sure the ‘online’ / ‘offline’ attribute has any useful meaning in zigbee-shepherd. My devices are all ‘offline’ and operate fine. Do you know the meaning of this attribute?


#1239

Don’t make the mistake of drawing too many conclusions from the map like I did when first starting out. The map is not very accurate.


#1240

it’s the dummy state of the router. it doesn’t actually do anything.


#1241

Is there a way to change the entity names for the zigbee2mqtt devices within a yaml file.

I know i can change the friendly name by editing the zigbee2mqtt configuration.yaml file and I can change the entity names through the home assistant GUI by going configuration -> integrations -> mqtt. I’d quite like to specify the entity names in a yaml file so if i redo my home assistant I don’t have to individually rename them in the GUI.


#1242

Do you mean like this?

  • platform: “mqtt”
    name: “Office 2”
    state_topic: “zigbee2mqtt/0xd0cf5efffec80fde”
    availability_topic: “zigbee2mqtt/bridge/state”
    brightness: true
    color_temp: true
    schema: “json”
    command_topic: “zigbee2mqtt/0xd0cf5efffec80fde/set”