Zigbee2MQTT make me crazy please help

I’ve searched and is not present in other log file.
I have now rebooted for the umpteenth time by totally disconnecting the power supply. Everything seems to be working properly for a few minutes, but I am sure within an hour it will stop again. What can I check further to understand at the source of the problems?

Could be the nvram of your dongle is corrupt (would explain the disconnects). I would flash the latest firmware again.

It worked for 9 hours smoothly then suddenly stopped. Rebooted and started to work again. I really do not manage to figure out the reason why this is happening.

Now it wont start anymore… It’s a total headache this situation.

Have you tried what @francisp suggested?

I do not know how can I do it. Can you please explain?
Will I use the configuration of my zigbee network?

Could the power supply be underpowered? Are also you running a ssd of it, or are you using an sd card?

The setup, how is this? Any other hardware?
Dongle attached and on long USB extender
The sonoff dongle, which firmware version?
Z2M version?
Log right after startup to see errors?

You still haven’t said what dongle your are using (there’s different Sonoff dongles) but there’s plenty of guides on the subject update firmware sonoff zigbee - Google-søk

You will not lose your zigbee network by flashing your dongle, look at the FAQ FAQ | Zigbee2MQTT

I don’t think this is the issue because HA is working properly only z2m stops. Moreover I’m using the same power supply from the beginning. (i sue sd card)

There is not any other hardware and the dongle is directly in the usb port od the pi. I’m running the last stable release of HA and Z2M.

  • Core2024.2.5
  • Supervisor2024.02.1
  • Operating System12.0
  • Frontend20240207.1

Mosquitto broker Current version: 6.4.0
Zigbee2MQTT Current version: 1.36.0-1

The Sonoff is a ZBDongle-E 3.0 and i can see these infos from HA:

DEVNAME: /dev/ttyACM0
DEVPATH: /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/tty/ttyACM0
ID_BUS: usb
ID_MODEL: SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2
ID_MODEL_ENC: SONOFF\x20Zigbee\x203.0\x20USB\x20Dongle\x20Plus\x20V2
ID_PATH: platform-3f980000.usb-usb-0:1.3:1.0
ID_PATH_TAG: platform-3f980000_usb-usb-0_1_3_1_0
ID_SERIAL: ITEAD_SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2_20230220190958
ID_SERIAL_SHORT: '20230220190958'
ID_TYPE: generic
ID_USB_DRIVER: cdc_acm
ID_USB_INTERFACES: ':020201:0a0000:'
ID_USB_MODEL: SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2
ID_USB_MODEL_ENC: SONOFF\x20Zigbee\x203.0\x20USB\x20Dongle\x20Plus\x20V2
ID_USB_SERIAL: ITEAD_SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2_20230220190958
ID_USB_SERIAL_SHORT: '20230220190958'
ID_USB_TYPE: generic
MAJOR: '166'
MINOR: '0'
TAGS: ':systemd:'

What FW version is the dongle using. You can easily see it in Z2M, settings, about.

A number of people have the issue that Pi boxes does not leave room enough for the Sonoff dongle, resulting in bad connection. Might be you have touched it and it sits differently? Tried to change the USB port? There is 2 USB2 ports.

Anyway, if you have a USB extender cable, use it. Solves a lot of other problems with connectivity.

Further, as mentioned by fleskefjes above. Change the serial to the full path. Accouding to you log you use “port”: “/dev/ttyACM0”

This is what is reported:
Versione Zigbee2MQTT
1.36.0 commit: unknown

Tipo Coordinator

Revisione Coordinator build 297

Indirizzo IEEE Coordinatore

Versione frontend



As said before i do not think that it is related to the usb port or the dongle itself. The USB port is the same from day one (almost one year) and when I restart HA everything works properly for a variable amount of time (10 minutes to 10 hourse on average)

I will try to add ad extension cable and change port.

OK, latest FW as I read it. Try the USB port/USB extender.

Any other things changed, like getting some “cheap chinese new no-name bulb” or alike. Some time ago I got 2 new AWOS bulbs, they were almost for free on Aliexpress:-). They report once every second, overfloading my zigbee network. Something alike. Any change?

These are my connected zigbee devices:

lumi.sensor_magnet.aq2: 8
lumi.motion.ac02: 4
lumi.weather: 4
TS011F: 3
RWL021: 2
lumi.sensor_switch.aq2: 2
LTW012: 2
LTA009: 2
TS004F: 2
LWE007: 1
LWA017: 1
TRADFRI on/off switch: 1
ROM001: 1
929003052501_01: 1
929003052501_02: 1
LWA009: 1
lumi.sensor_wleak.aq1: 1
lumi.sensor_cube.aqgl01: 1
TS0601: 1
TS0203: 1
lumi.sensor_motion.aq2: 1

It is not the list itself, It is changes around the timing of when your problem started.

You mention restarts, you have tried full power cycle of the pi, connect/reconnect the coordinator, power cycle mains zigbee devices (non battery)?

Try to flash a 7.4 firmware

Flash the latest firmware on your adapter:

I’ve already tried, even to turn off totally energy in the house .

You have been arround. Have you got the USB extender cable and tried the second USB port? The problem is the “Adapter disconnected, stopping” error you show us above.
Might also be a never FW. Have not tried my self as I have the Sonoff Dongle P

Right now is more than one day that is running without any stop or issue without any change. As it stops I’ll try to change port (and also addressing with serial id) and with extension cable. Then as last option I’ll change the firmware.