Zigbee2MQTT replaced adaptor, worked for some time and just not starting anymore

Good day, i have replaced one cheap adaptor which was connected via USB to a network one, and it worked without any problems, today i have unplugged old adaptor (which was connected to usb but not used) and starting getting this error on start of the Zigbee2MQTT, which is really strange as i have used ezsp driver (this aliexpress device https://fr.aliexpress.com/item/1005005271016330.html?spm=a2g0o.order_list.order_list_main.99.39065e5b2uZlbe&gatewayAdapt=glo2fra) and then switched to a network coordinator SLZB-06P7
However right now i got this permanent failed errors on Zigbee2MQTT start

[00:35:11] INFO: Preparing to start...
[00:35:11] INFO: Socat not enabled
[00:35:11] INFO: Starting Zigbee2MQTT...
Zigbee2MQTT:info  2024-03-01 00:35:12: Logging to console and directory: '/config/zigbee2mqtt/log/2024-03-01.00-35-12' filename: log.txt
Zigbee2MQTT:info  2024-03-01 00:35:12: Starting Zigbee2MQTT version 1.35.3 (commit #unknown)
Zigbee2MQTT:info  2024-03-01 00:35:12: Starting zigbee-herdsman (0.33.8)
Zigbee2MQTT:error 2024-03-01 00:35:12: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2024-03-01 00:35:12: Failed to start zigbee
Zigbee2MQTT:error 2024-03-01 00:35:12: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2024-03-01 00:35:12: Exiting...
Zigbee2MQTT:error 2024-03-01 00:35:12: Error: spawn udevadm ENOENT
    at Process.ChildProcess._handle.onexit (node:internal/child_process:284:19)
    at onErrorNT (node:internal/child_process:477:16)
    at processTicksAndRejections (node:internal/process/task_queues:82:21)

My configuration is simple:

data_path: /config/zigbee2mqtt
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: "-d -d"
  log: false
mqtt: {}
    port: tcp://
    baudrate: 115200
    adapter: zstack
    disable_led: false
    transmit_power: 20

To test i have completely removed the Zigbee2MQTT directory and reinstalled the plugings, but without any luck.
Can someone advice me please ?
Thank you

Forgot to add i am using a vm from the official image.

Never seen a configuration like that, why 2 times serial


  port: tcp://
  baudrate: 115200
  disable_led: false
  transmit_power: 20

DARN it was just a copy paste typo, omg thank you ))

After some time, it was not a typo, two serials are required the configuration in my example was in yaml format, so there is two serials there.
I have finished to completely wiping my home assistant, and started with fresh image, Zigbee2MQTT is not starting with the same error.

I have found the reason, the problem was in spaces in config:
port: tcp://
baudrate: 115200
adapter: zstack
disable_led: false
transmit_power: 20

Somehow I doubt the solution was to remove all spaces. :wink:

For the benefit of others, please post a properly formatted version of the configuration.

1 Like

Well, the problem was from the fact that i have copied pasted the configuration from SLZB-06P7, there is a section for Zigbee2MQTT, with fresh empty config i was not able to start the Zigbee2MQTT, but when i edited the text i saw a strange formatting problem so before i had:

    port: tcp://
    baudrate: 115200
    adapter: zstack
    disable_led: false
    transmit_power: 20

And after i just removed the spaces and alligned the parametres i had this:

serial: null
port: tcp://
baudrate: 115200
adapter: zstack
disable_led: false
advanced: null
transmit_power: 20

Note the “null” here which i have not typed, my gues is that some formatting made Zigbee2MQTT to fail, i have enabled the herman debug, but it was not helping.
I am not sure what was that, i have used a notepad++ to work with configs.

That’s quite wrong. YAML indenting matters and there shouldn’t be a duplicate serial line.

That’s the correct solution up there.

I had an error saing that i lack “serial” in my config if i had only one,i think something is wrong with parser or input text

If you use the add-on, start with this:

baudrate is default 115200, adapter is default zstack

Minimal configuration is working, but maybe i have half broken arms but facing some strange problems i think i am on the edge here, i am not exacly sure what do to next, here is the list:

1: Mosquito do not publish entities, tried to leave it alone, or set password, no effect, no devices under developer tools >States

2: I have two zigbee adapters SLZB-06P (M) and a cheapish usb adapter

SURPRISE cheap USB adaptor works better than this network device, for whatever reason SLZB-06P (M) is not able to pair my devices:

But usb one, no problem at all (whatever the distance)

The only good news i have is that my Aeotec repeater solved the range problem, so i can use my devices, however without MQTT it is impossible to use home assistant, any ideas what i am missing ?

MQTT log:

Ok so i have connected to MQTT and i see following data:

I see messages from to when i turn my knob 0x54ef441000a054a4
MQTT publish: topic 'zigbee2mqtt/0x54ef441000a054a4
However they are published in zigbee2mqtt topic, and not replicated in home assistant.
I am not sure if the zigbee2mqtt is a correct value for the MQTT topic and there should be 2 of them

homeassistant and zigbee2mqtt.

I continue digging why i dont have any entity in home assistant from zigbee2mqtt integration.

After reading the MQTT i think it is normal that it is not updating as it’s the automation action publishing, but still they should be visible as a entities in home assistant.

Ok so i have found why, but its really strange and i have not touched this part.
So the default credentials created by MQTT integration were wrong and not working

I have found a working credentials under at homeassistant/zigbee2mqtt/configuration.yaml
login: addon

This is not ok right ? I mean its a fresh install i installed MQTT and zigbee2mqtt, left everything at default besides the zigbee2mqtt adaptor configuration.
I have used the vmdk latest image, damn this is not OK
Well at least i have learned how this thing works =)

After my ticket SMLIGHT made an update of the firmware which corrected the issue:

Their support solved the problem.

I just received my SLZB-06. It had the v2.0.18 core firmware. Because I had the same problems, I did an update of core and zibgee firmware. I tried with both connections (ethernet and wifi) and using static IP and generic MDNS SLZB-06.local

Let’s see the log:

[02:10:45] setup | Starting firmware: v2.1.0.dev
[02:10:45] ConfigHelper | LittleFS mounted
[02:10:45] L_Y,L_B | status: 1
[02:10:45] ConfigHelper | load config
[02:10:45] ConfigHelper | config open: Ok
[02:10:45] setup | Config loaded
[02:10:45] setup | Coordinator mode: WIFI
[02:10:45] setup | Radio FW version: 20240315
[02:10:45] setup | Device type: SLZB-06
[02:10:45] setup | Radio mode: ZB COORD
[02:10:45] setup | Device type: SLZB-06
[02:10:54] [ZBCHK] | Wrong answer
[02:10:54] [ZBVER] | Unknown
[02:10:54] Network | init
[02:10:54] Network | [WIFI] SSID: xxxxx PASS: xxxxxx
[02:10:54] Network | EVENT: 0
[02:10:55] Network | [WIFI] manual config: IP | MASK | GW | DNS1 | DNS2
[02:10:55] Network | EVENT: 2
[02:10:55] setup | Filesystem size: 3456
[02:10:55] setup | Filesystem used: 368
[02:10:55] setup | done
[02:10:55] Network | [MDNS] Started
[02:10:55] Network | EVENT_WIFI_STA_GOT_IP
[02:10:55] Network | fireNetworkUp
[02:10:55] taskZB | Start task
[02:10:55] taskZB | Starting server on port: 6638
[02:10:55] Web | Webserver started
[02:10:55] time | time sync start
[20:10:55] time | timezone: CST6
[20:10:55] time | Sunday, April 14 2024 20:10:55
[20:10:55] taskTimeSync | Heap: 1476
[20:10:55] time | stop task
[20:10:55] zbSelfOta | start task
[20:10:55] internet | connected
[20:10:56] stats | Statistics sent
[20:10:56] stats | Heap: 2448

Here is my z2m configuration.yaml:

frontend: true
permit_join: true
  discovery_topic: homeassistant
  status_topic: homeassistant/status
  base_topic: zigbee2mqtt
  server: mqtt://
  client_id: z2m_docker2024
  keepalive: 60
  user: xxxxxxx
  password: xxxxx
  port: tcp://    # en wifi :
  # port: tcp://slzb-06.local:6638    # en wifi :, en ethernet : DHCP
  # port: tcp://    # en ethernet : DHCP, par exemple
  # baudrate: 115200
  adapter: zstack
  # disable_led: false

  transmit_power: 20

devices: {}

I tried change the zigbee chanel and others with those lines (to generate new pan-id for example):

  pan_id: GENERATE
  ext_pan_id: GENERATE  
  network_key: GENERATE

[edit: I forgot the log]

info  2024-04-14 19:45:45: Logging to console and directory: '/app/data/log/2024-04-14.19-45-45' filename: log.txt
info  2024-04-14 19:45:45: Starting Zigbee2MQTT version 1.36.1 (commit #ffc2ff1)
info  2024-04-14 19:45:45: Starting zigbee-herdsman (0.40.3)
error 2024-04-14 19:46:05: Error while starting zigbee-herdsman
error 2024-04-14 19:46:05: Failed to start zigbee
error 2024-04-14 19:46:05: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
error 2024-04-14 19:46:05: Exiting...
error 2024-04-14 19:46:05: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:103:27)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:132:29)
    at Zigbee.start (/app/lib/zigbee.ts:62:27)
    at Controller.start (/app/lib/controller.ts:109:27)
    at start (/app/index.js:107:5)

Nothing to do ! It doesn’t solve the problem.
Any idea please?

Hi everybody.
This could help the people with the same problem. I solved it doing this:

  1. downgrade zigbee firmware to Coordinador v20230922 (seems that Revision: 20240315 generates problems on mi side)
  2. for the serials parameters, I just let this:
  port: mdns://slzb-06
  disable_led: false

(according to z2m documentation)
3) I regenerate pan-id and friends by this:

  pan_id: GENERATE    
  ext_pan_id: GENERATE   
  network_key: GENERATE