Zigbee2mqtt USB stick on Windows

Tags: #<Tag:0x00007fc415f8c560> #<Tag:0x00007fc415f8c470>

I have a Windows 10 with HyperV image running, Which as all know (except me when i set it up) does not support USB pass through.
I don’t like to use the VM player to run HA (performance yada yada…bite me) so i tried to set SOCAT on the Zigbee2Mqtt.

And i am kinda confused… like who the hell wrote this level intros confused.

  1. question is do I run socat on the Windows host (where the stick is stuck in its xxx) to pass trough the port to the VM OR Do i have to run something else to open the port to the VM like TCPCOM32 and have to do smething on my VM to get the thing to accept it?
    (i tried both but got stuck how to find the port name in windows which socat would eat, and other one withTCPCOM32 does not work)
  2. What is the point of the socat setup in Zigbee2Mqtt configuration if you only specify the tcp on the port when you forward it???
socat:
  enabled: true
  master: pty,raw,echo=0,link=/dev/ttyZ2M,mode=777,end-close
  slave: tcp4:xxxx:8485,ignoreeof

OR 

serial:
  port:  tcp4:xxxx:8485

WHICH IS IT??? BOth? schrodingers cat?
  1. What part of the intros are meant for the OS where the stick is stuck in it ass, and which one for the Hassio VM?
  2. Who stole mah cookiez :smiley:

Any pointers are more then welcome :3
Love the Zigbeee and Hassio :smiley:

USB sticks will not work by default with either Hyper-V or WS:2 on Windows. My son has got a Z-Wave USB stick working by using a workaround. The stick uses the the Windows drivers and presents itself to the OS as a COM port. That port can then be mapped to your Hyper-V VM.

CAUTION: The mapping may not be totally stable. I think it needs to be torn down before the VM is shut down & re-established after the VM is back up.

Since I did not do this myself, I do not have the full details.

Thank you for the pointer :slight_smile:
Will try it if it fails with socat.

Still searching to forward the ports via socat as the addon intended. Why? because it buggs me and i want to make correct instructions later :stuck_out_tongue:

1 Like

From what I have heard over at openHAB socat can be quite finicky.

So you say, but you don’t point to the docs you are following. Please do.

I’m running CC2531 on HA using HyperV on W10…so is this of help??