Zigbee2MQTT was working and now fails to start

Not sure what’s going on here, not making a bunch of sense to me.

Start the Add-On and eventually it just stops.

Config:

socat

enabled: false
master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
options: "-d -d"
log: false

Serial

port: >-
  /dev/serial/by-id/usb-Silicon_Labs_Sonoff_Zigbee_3.0_USB_Dongle_Plus_0001-if00-port0

Log:

info  2023-06-13 22:50:43: Logging to console and directory: '/config/zigbee2mqtt/log/2023-06-13.22-50-43' filename: log.txt
info  2023-06-13 22:50:43: Starting Zigbee2MQTT version 1.31.2 (commit #unknown)
info  2023-06-13 22:50:43: Starting zigbee-herdsman (0.14.117)
error 2023-06-13 22:51:09: Error while starting zigbee-herdsman
error 2023-06-13 22:51:09: Failed to start zigbee
error 2023-06-13 22:51:09: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
error 2023-06-13 22:51:09: Exiting...
error 2023-06-13 22:51:09: Error: SRSP - SYS - getExtAddr after 6000ms
    at Timeout._onTimeout (/app/node_modules/zigbee-herdsman/src/utils/waitress.ts:64:35)
    at listOnTimeout (node:internal/timers:559:17)
    at processTimers (node:internal/timers:502:7)

Any ideas or thoughts on troubleshooting here?

Thanks in advance!!

Well, I did finally get it. Had to hard reboot the rPi 4.
Once rebooted, then cycle the Sonoff Zigbee 3.0 dongle

Is this just inherently unreliable?
Do you think this a Zigbee2MQTT bug or a fault in the Sonoff hardware?

  1. Check that you do not have the ZHA integration listed, if you do, delete it.
    Home assistant might have autodetected your dongle and added it.
    Open your Home Assistant instance and show your integrations.

  2. Ensure that you do not have the Silicon Labs Multiprotocol add-on installed, that might block the port.

If these aren’t the issues, it might be connectivity issues or something else :frowning:

Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions

None of those, thanks for the tips.

It seem to mess up as soon as any update that requires a soft restart occurs (even just a restart for a YAML update).

It boots back up and the Zigbee2 MQTT is always failed.

Cycle power on the dongle, no better. Cycle power on the rPi, let it fully boot (Zigbee2MQTT won’t start and fails), cycle power on the dongle - now it works.

Just seems more like a problem between HA and the add-on rather than a hardware issue

I just rechecked the process of getting this to work again:

The troubleshooting guide didn’t help and I’ve gone through that a few times now. I feel that is more for situations when this add-on just doesn’t work at all.


  • No changes to anything.
  • Developer tools > Restart
  • Let it fully boot
  • Zigbee2MQTT not running (set to Start on Boot)
  • Manually Start Zigbee2MQTT, give it a few minutes
  • Fails to start

  • Power cycle the Sonoff dongle
  • Manually Start Zigbee2MQTT, give it a few minutes
  • Fails to start

  • Power cycle the rPi
  • Zigbee2MQTT started on boot (or tried at least)
  • Zigbee2MQTT fails
  • Manually Start Zigbee2MQTT, give it a few minutes
  • Fails to start

  • Power cycle the Sonoff dongle
  • Manually Start Zigbee2MQTT, give it a few minutes
  • All is well and the UI loads with the devices all present

Not sure if this is helpful, but this pattern is repeatable.
Just not sure where to go from here as I do feel the issue is out of my control

You might try to re-flash the firmware on your dongle.

I did try this and I had no success. Since it functioned as-is, I gave up on that venture.
I will give this another shot though and perhaps that’s all it is

Why not post on the z2m github?

No it’s not, have that one too but I understand that after such a failure and getting your mesh back online you start to doubt.

I got this too. It is super unstable. Did some update to HA core at 10pm, it had some thing about needing a restart due to config changes in z2m.
After that, it ran until 3am, when it died. Noticed all my stuff not working at 5am. Restart everything multiple times, until w/o any config changes it worked again.

That is not helpful. Upgraded from what version to which version?

FWIW I keep my HA and Z2M religiously up to date (via the Addon for Z2M). I presently have HA 2023.6.1 and Z2M Addon v 1.31.2-1. It is working fine, and highly reliable.

From core 5.4 to 6.1
Mine is working fine too. Just takes a dozen restarts, usb resets etc.

That is the opposite of working fine.

I’m having the same issue. Started a few days ago.

[16:51:51] INFO: Preparing to start...
[16:51:52] INFO: Socat not enabled
[16:51:56] INFO: Starting Zigbee2MQTT...
Zigbee2MQTT:info  2023-06-29 16:52:06: Logging to console and directory: '/config/zigbee2mqtt/log/2023-06-29.16-52-06' filename: log.txt
Zigbee2MQTT:info  2023-06-29 16:52:06: Starting Zigbee2MQTT version 1.31.2 (commit #unknown)
Zigbee2MQTT:info  2023-06-29 16:52:06: Starting zigbee-herdsman (0.14.117)
Zigbee2MQTT:error 2023-06-29 16:52:07: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2023-06-29 16:52:07: Failed to start zigbee
Zigbee2MQTT:error 2023-06-29 16:52:07: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2023-06-29 16:52:07: Exiting...
Zigbee2MQTT:error 2023-06-29 16:52:08: Error: Error while opening serialport 'Error: Error: Resource busy, cannot open /dev/ttyACM0'
    at SerialPort.<anonymous> (/app/node_modules/zigbee-herdsman/src/adapter/deconz/driver/driver.ts:200:28)
    at SerialPort._error (/app/node_modules/@serialport/stream/dist/index.js:75:22)
    at /app/node_modules/@serialport/stream/dist/index.js:111:18

It turned out that this was because I had added “deCONZ” add-on. I disabled this and now everything is running smooth again.

Had the same problem, using a Texas Instruments CC2531 dongle on a Odroid-m1.
The TI CC2531 has a tendency of being stuck (happened to me twice in a year). There’s no magic fix, other than replacing it with a better Zigbee dongle.
Solution: disconnect/reconnect the dongle AND then reboot the whole system (not just HA).

You my friend just solved my problems. I had issues with HA not starting properly after updates and zigbee2mqtt failing for a couple of weeks now and couldn’t figure it out. Turns out for some reason HA decided to add ZHA to my integrations. I’ve been using zigbee2mqtt for years now so I didn’t even consider this to be the issue.

1 Like