ZigStar - ZigBee Coordinators and Routers

Thanks Radu, yea I am aware and I followed the guide to do it, basically to remove the backup file and repair everything, but not sure it just does not feel right, I think something just didnt go well.

Some examples of the errors I see.

error 2024-03-22 19:19:41: Publish 'set' 'brightness' to 'Kitchen Lounge Ceiling' failed: 'Error: Command 0xf082c0fffedf6e83/1 genLevelCtrl.moveToLevelWithOnOff({"level":76,"transtime":0}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null,"writeUndiv":false}) failed (Data request failed with error: 'undefined' (25))'
error 2024-03-22 19:13:21: Failed to read state of 'Nursery Frient Switch Air Purifier' after reconnect (Read 0x0015bc002f00d6da/2 genOnOff(["onOff"], {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":true,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null,"writeUndiv":false}) failed (Data request failed with error: 'undefined' (25)))
error 2024-03-22 18:42:40: EventBus error 'OTAUpdate/deviceMessage': CommandResponse 0x00178801062c589a/11 genOta.queryNextImageResponse({"status":152}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":true,"direction":1,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null,"writeUndiv":false}) failed (Data request failed with error: 'undefined' (25))

I am still researching what these could be or are they just timeouts. Let me know if anything jumps out.

@mercenaruss
Just to update, after 2 days using 20240321

  • Response is quick, I notice there is an initial wakeup if the devices is not used in a while.
  • Some devices are still dropping off the network
  • Pairing is still a pain with constant interview failed
  • Some timeouts happening but less than 20230507

Sticking with it now

@mercenaruss

After about a week, a handful of end devices and routers have dropped :frowning:

Going to try 20240318 and leave it for a couple of days

I also tried 20240315, 20240318 and 20240321. With 20240315 Z2M won’t start, same error as HarvinDhillon.
With 20240318 and 20240321 Z2M starts but I get frequent disconnects / transmission errors. Some devices just stop responding after some time (sometime directly after the update, some later, it seems to mainly affect routers, but devices seem random to me, different brands, etc.). I had to revert back to 20230507 for now, to not further undermine the WAF…

Agree was the same for me in the end. Though for me 20240318 was much much worse than 20240321.

With 20240321, the network was better in the first 2-3 days before things started to drop off.

However with 20240318, it was bad and never got better. Everything took multiple retries to work.

Back to 20230507 now, it is not great but still better than the other two.

I have 5 CC2652P2 Sonoff Dongle Plus as dedicated routers all over the house, my house is not big about 136sqm (2 Floors) with plenty of other routers. Not sure why stability is still elusive :frowning:

Waiting for my POE from Smartlight that is based on the older CC2652P2, hoping rolling back to the older firmware can finally bring some stability or maybe it is just my setup is not great with some problematic devices.

On the 20240315 version now and unfortunately still getting so many timeouts, it’s baffling. Even a light next to the coordinator takes at least 5 tries before an action is taken.

Only option I have is to delete all and start from scratch. See if that helps.

Is it just me or is everyone with this P7 chip seeing similar issues?

:cry::sob:

I keep mine in the box until your issues are resolved :slight_smile:

Rebuilt my network over the weekend with 20240315. So far so good, pairing my 145+ devices was the most painless in a while, everything just paired straight away. The only problematic were IKEA Styrbar Dimmers, took a few tried to pair.

6h later still looking good :+1:. There are still some ping timeouts but rare, everything seems to be working and no other issues seen yet.

Maybe light at end of the tunnel::sweat_smile:

Hello,
I am trying to get the Zigstar Lan Gateway going. I am using a Supervised install of Home Assistant. The most recent Zigbee2Mqtt Add-On.
I have no problems starting Zigbee2Mqtt with the Lan Gateway. If I connect one temperature, … sensor, Zigbee2Mqtt stops within 30-40 seconds. The log shows:

[20:38:30] INFO: Preparing to start...
...
Zigbee2MQTT:info  2024-04-06 20:38:40: Zigbee2MQTT started!
Zigbee2MQTT:info  2024-04-06 20:38:40: MQTT publish: topic 'zigbee2mqtt/0xa4c1380d5334d34d', payload '{"co2":362,"formaldehyd":3,"humidity":75.7,"linkquality":174,"pm25":6,"temperature":22.1,"voc":20}'
...
Zigbee2MQTT:info  2024-04-06 20:38:58: MQTT publish: topic 'zigbee2mqtt/0xa4c1380d5334d34d', payload '{"co2":362,"formaldehyd":5,"humidity":74.1,"linkquality":171,"pm25":6,"temperature":21.9,"voc":16}'
Zigbee2MQTT:error 2024-04-06 20:39:13: Adapter disconnected, stopping
Zigbee2MQTT:info  2024-04-06 20:39:13: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload '{"state":"offline"}'
Zigbee2MQTT:info  2024-04-06 20:39:13: Disconnecting from MQTT server
Zigbee2MQTT:info  2024-04-06 20:39:13: Stopping zigbee-herdsman...
Zigbee2MQTT:error 2024-04-06 20:39:13: Failed to stop Zigbee2MQTT

I tried turning RTS/CTS on but it didn’t change anything. I’ve got the Lan GW connected to a strong power supply. The ethernet cable is 50cm long. So I think the environment should be as stable as it gets.

I have no issue using the Zigstar Stick v4 with the same sensor.

Am I missing something? Any help is much appreciated :slight_smile:
Cheers,
Dennis

Do you have stable ping from your server to LAN GW?
Is the last P2 zigbee firmware installed?

Thank you for keeping me updated on this.
I will see now what other firmwares Koenkk generated for test and add them to repository: HERE