ZigStar - ZigBee Coordinators and Routers

Can you ping 192.168.1.194 ?

yep, sounds good:
MCR4

I retried again with lower case and message is different: some progress ? :wink:

EDIT: could finally make this fantastic product work (thanks to the kind help of the UZG-01 developer !) : I forgot to write the subnet mask in the Ethernet settings…

Looks like some configuration issue, check your configuration.yaml to be sure you have all the mandatory items defined

Ok installed today, I can see an increase in the overall LQI.

I noticed also increased chattiness in some tuya devices, not sure if that was there before.

I still have some failed commands once a while, but nothing has dropped offline yet. WIll wait further once the network has reconfigured itself. I still see a lot of routers connected directly to the coordinator, not sure if that is expected but when I was on ZHA with the sonoff dongle it wasnt the case.

Hi,i answered your ticket. I will help you remotely,not sure what is the issue here.

I will provide 2nd firmware for test soon.
I will update here.

1 Like

Based on picture you provide it’s not connected to your network:

|Ethernet connected: No
|Socket client connected: No
|WiFi Client enabled: No
|WiFi Client status: Not connected

Ok thanks, unfortunately woke up today morning with half of my network being offline so safe to say this firmware is not stable to say the least.

I have to revert.

Ordered a SM Light POE with P2 chip in it. I am wondering if this P7 chip is really any better, my experience has been quite bad thus far but will keep trying

1 Like

Koenkk is working hard on this.
He is making considerable progress on P7 chip,he send daily firmwares for test.
I will post all of them HERE during all progress.
Currently CC1352P7_20240315 is most stable.
Latest one is from yesterday: CC1352P7_20240321, still no reports.
You can help Z2M community.

Thanks Radu,

Ok will try it later this evening. Need to choose the correct time to ensure the Mrs doesnt get too upset with all the testing.

1 Like

What is the best way to test ? My UZG-01-POE is not unpacked yet. Create a small network with some test devices ?

Create small network,preferable with Tuya devices - they are the problem.
on main branch or dev branch of Z2M.

1 Like

OK updated to 20240321, will report my findings

1 Like

With the 20240321

Had a weird instance where one of my hue dimmers got changed to a aqara door sensor.

Even after repairing it was the same, restart z2m same… I took the battery out for 20mins and repaired, then it worked.

Weird :smiley:

1 Like

Thanks for your help: working like a charm now ! super device !!! :ok_hand:

1 Like

I’m trying to update to CC1352P7_20240321, but the update seems to be stuck:

[542378] | [ZB_FW] upload: znp_LP_CC1352P7_4_tirtos_ticlang_20240321.hex
[550578] | [ZB_FW] upload finish!
[558036] | BSL (P7 and R7 chips) pin 15 level LOW
[558037] | BSL config OK
[558037] | Zigbee FW file VALID - OK
[561288] | [ZB_FLASH] | Chip erased

How long is this supposed to take?

EDIT / UPDATE: I just tried again with the GW Multi tool and it worked at the first try. Flashing via webinterface might need to be checked again.

1 Like

Update over web interface is still in work.
Hopefully will be done soon.

2 Likes

Still unfortunately having a lot of timeouts in 20240321

I tried using 20240315 but Z2M does not start with the following error

error 2024-03-22 18:16:47: Error while starting zigbee-herdsman
error 2024-03-22 18:16:47: Failed to start zigbee
error 2024-03-22 18:16:47: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
error 2024-03-22 18:16:47: Exiting...
error 2024-03-22 18:16:47: TypeError: Cannot read properties of undefined (reading 'payload')
    at AdapterNvMemory.writeItem (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/adapter-nv-memory.ts:111:31)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at ZnpAdapterManager.clearAdapter (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/manager.ts:474:9)
    at ZnpAdapterManager.beginCommissioning (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/manager.ts:331:9)
    at ZnpAdapterManager.beginRestore (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/manager.ts:296:9)
    at ZnpAdapterManager.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/manager.ts:80:17)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:132:29)
    at Zigbee.start (/app/lib/zigbee.ts:62:27)
    at Controller.start (/app/lib/controller.ts:109:27)
    at start (/app/index.js:107:5)

Reverting back to 20240321, I am able to start Z2M

I have a pretty large network

By device type
End devices: 77
Router: 68

I recently moved to channel 25 to try and get some stability (I have no wifi on channel 10-13), not sure the way Z2M handles changing channels, It made it worse.

I might try to rebuild the network by deleting z2m and starting again on channel 11. I have Wifi channel 1 free too so maybe that is a better option to move wifi to 12 and move the zigbee to 11. Not sure if channel power for 25 is also contributing to stability issues.

Z2M still not handling well channel change,is in test now. All people reported that some devices don’t switch to new channel and they need to repair some of them.
For all decisions related to zigbee and wifi channel i use this.


Recommend to choose 1 channel and stick to it.

Try please also: 20240318