ZWave-JS - AEON Labs (Aeotec) Minimote

Tags: #<Tag:0x00007fc41c4e5038> #<Tag:0x00007fc41c4e4ef8>

Assign actions to each of the Minimote’s buttons (press and hold) in an automation.

The Minimote must be configured as a Scene controller. See the In-Depth Guide for configuration instructions, or find help in some links below or elsewhere in the community.

This blueprint is compatible with Home Assistant 2021.04 or later.

Import the AEON Labs Minimote Blueprint

blueprint:
  name: Aeon Labs Minimote
  description: Create automations for the Aeon Labs Minimote
  domain: automation

  input:
    minimote_device:
      name: Minimote Device
      description: A Minimote device.
      selector:
        device:
          integration: zwave_js
          manufacturer: AEON Labs
          model: DSA03XXX-ZW

    button_1_pressed:
      name: Button 1 Pressed
      description: Actions to run when button 1 is pressed.
      default: []
      selector:
        action:

    button_1_held:
      name: Button 1 Held Down
      description: Actions to run when button 1 is held down.
      default: []
      selector:
        action:

    button_2_pressed:
      name: Button 2 Pressed
      description: Actions to run when button 2 is pressed.
      default: []
      selector:
        action:

    button_2_held:
      name: Button 2 Held Down
      description: Actions to run when button 2 is held down.
      default: []
      selector:
        action:

    button_3_pressed:
      name: Button 3 Pressed
      description: Actions to run when button 3 is pressed.
      default: []
      selector:
        action:

    button_3_held:
      name: Button 3 Held Down
      description: Actions to run when button 3 is held down.
      default: []
      selector:
        action:

    button_4_pressed:
      name: Button 4 Pressed
      description: Actions to run when button 4 is pressed.
      default: []
      selector:
        action:

    button_4_held:
      name: Button 4 Held Down
      description: Actions to run when button 4 is held down.
      default: []
      selector:
        action:

mode: single
max_exceeded: silent

trigger:
  platform: event
  event_type: zwave_js_value_notification
  event_data:
    device_id: !input minimote_device
    command_class: 43   # Scene Activation
    property: sceneId

action:
  - variables:
      scene_id: "{{ trigger.event.data.value_raw }}"
  - choose:
    - conditions: "{{ scene_id == 1 }}"
      sequence: !input button_1_pressed
    - conditions: "{{ scene_id == 2 }}"
      sequence: !input button_1_held
    - conditions: "{{ scene_id == 3 }}"
      sequence: !input button_2_pressed
    - conditions: "{{ scene_id == 4 }}"
      sequence: !input button_2_held
    - conditions: "{{ scene_id == 5 }}"
      sequence: !input button_3_pressed
    - conditions: "{{ scene_id == 6 }}"
      sequence: !input button_3_held
    - conditions: "{{ scene_id == 7 }}"
      sequence: !input button_4_pressed
    - conditions: "{{ scene_id == 8 }}"
      sequence: !input button_4_held

Changelog:

2021-04-07:

  • Changed event_type trigger to zwave_js_value_notification for release 2021.04.
7 Likes

Thank you so much for this. I have spent hours trying to get this to work and came here and find your blueprint, which works like a charm.

This was a huge time saver…works great…thanks!!!

Awesome, thank you so much, Saved me a lot of time!

Is this blueprint just supposed to work out of the box? I added some options to it and nothing happens when I press buttons on the remote?

Yes, it generates an automation called Aeon Labs Minimote and you have to assign whatever you want to the buttons.

I have several Minimote devices in HA however the automation says “No matching devices found”.

Z-Wave Node 69
AEON Labs
DSA03202 Minimote
Z-Wave (deprecated)

Z-Wave Node 77
AEON Labs
DSA03202 Minimote
Z-Wave (deprecated)

Z-Wave Node 79
AEON Labs
DSA03202 Minimote
Z-Wave (deprecated)

Z-Wave Node 88
AEON Labs
DSA03202 Minimote
Z-Wave (deprecated)

Z-Wave Node 91
AEON Labs
DSA03202 Minimote
Z-Wave (deprecated)

hi does this blueprint also works for the aeotec wallmote Quad?

This is for the zwave-js integration.

No it does not.

Ok, Thanks

Hi, am using z-wave JS , (using zwavejs2mqtt for the zwave server portion).
when I try and use the blueprint, it doesnt show any available devices

ZWaveJS2MQTT does not show the Prodcut Code like the rest of my zwave devices, instead it shows “Aeotec NanoMote Quad” as the model, not ZWA-003-C (printed on device) (ref other Aeotec devices show here as ZW100 etc). Netiher the ZWA003-C or the “Aeotec NanoMote Quad” product namesa re referenced within your Blueprint - you have DSA03XXX-ZW instead

The NanoMote Quad is an entirely different product than the Minimote. This blueprint only works with the Minimote. Others have posted blueprints for the NanoMote.

ah, gotcha. I thought the names were inter-changeable.

Cant find a z-wavsJS based blueprint for the Nano, but I will have a go at using yours as a base to tweak it to work with the nano.

Yeah, I now see there aren’t any for zwave_js. You should be able to adapt one of the zwave/ozw ones to use zwave-js, or vice versa if that works for you. I believe the Nanomote uses Central Scene, so the event data is slightly different. Comparing the integrations, zwave_js events include device_id, so you can use the device selector instead of requiring a node id, which is much simpler.

Updated blueprint for change in zwave event to zwave_js_value_notification

blueprint:
  name: Aeon Labs Minimote
  description: Create automations for the Aeon Labs Minimote
  domain: automation

  input:
    minimote_device:
      name: Minimote Device
      description: A Minimote device.
      selector:
        device:
          integration: zwave_js
          manufacturer: AEON Labs
          model: DSA03XXX-ZW

    button_1_pressed:
      name: Button 1 Pressed
      description: Actions to run when button 1 is pressed.
      default: []
      selector:
        action:

    button_1_held:
      name: Button 1 Held Down
      description: Actions to run when button 1 is held down.
      default: []
      selector:
        action:

    button_2_pressed:
      name: Button 2 Pressed
      description: Actions to run when button 2 is pressed.
      default: []
      selector:
        action:

    button_2_held:
      name: Button 2 Held Down
      description: Actions to run when button 2 is held down.
      default: []
      selector:
        action:

    button_3_pressed:
      name: Button 3 Pressed
      description: Actions to run when button 3 is pressed.
      default: []
      selector:
        action:

    button_3_held:
      name: Button 3 Held Down
      description: Actions to run when button 3 is held down.
      default: []
      selector:
        action:

    button_4_pressed:
      name: Button 4 Pressed
      description: Actions to run when button 4 is pressed.
      default: []
      selector:
        action:

    button_4_held:
      name: Button 4 Held Down
      description: Actions to run when button 4 is held down.
      default: []
      selector:
        action:

mode: single
max_exceeded: silent

trigger:
  platform: event
  event_type: zwave_js_value_notification
  event_data:
    device_id: !input minimote_device
    command_class: 43   # Scene Activation
    property_name: sceneId

action:
  - variables:
      scene_id: "{{ trigger.event.data.value }}"
  - choose:
    - conditions: "{{ scene_id == 1 }}"
      sequence: !input button_1_pressed
    - conditions: "{{ scene_id == 2 }}"
      sequence: !input button_1_held
    - conditions: "{{ scene_id == 3 }}"
      sequence: !input button_2_pressed
    - conditions: "{{ scene_id == 4 }}"
      sequence: !input button_2_held
    - conditions: "{{ scene_id == 5 }}"
      sequence: !input button_3_pressed
    - conditions: "{{ scene_id == 6 }}"
      sequence: !input button_3_held
    - conditions: "{{ scene_id == 7 }}"
      sequence: !input button_4_pressed
    - conditions: "{{ scene_id == 8 }}"
      sequence: !input button_4_held

Did you ever get it to work as I am having the same issue you described. Minimote appears to have paired successfully and I configured button 1 in the automation to toggle a light but nothing happens when I press the button.

DId you change from controller to scene mode for buttons and minimote?

Edit: Check this link

Yes, you need to enable scene mode. I believe you should only need to change parameter 250, but I did this many years ago.

The change log in a code block seems to break importing this…