Zwave-JS delay Homekit start automation

So I made the switch from OpenZwave to Zwave-JS, I haven’t had any problems, however…

I had a binary sensor and automation with Openzwave which I would use to delay Homekit bridge starting until the ZWave network was ready. I can find anything about how to reproduce this under Zwave-JS, any ideas?

#Binary Sensor to determine if OZW Beta is running (for HomeKit delayed startup)
  - platform: mqtt
    name: openzwave_network_ready
    state_topic: OpenZWave/1/status/
    value_template: >
      {{ "ON" if value_json.Status in ["driverAwakeNodesQueried", "driverAllNodesQueriedSomeDead", "driverAllNodesQueried"] else "OFF" }}
    json_attributes_topic: OpenZWave/1/status/
    device_class: "connectivity"
# Start Homekit
- alias: 'Start HomeKit'
  - event: start
    platform: homeassistant
  - wait_template: "{{ is_state('binary_sensor.ozw_network_ready', 'on') }}"
    timeout: 00:10:00
  - choose:
      - conditions:
          - condition: template
            value_template: "{{ not wait.completed }}"
          - service: script.notify_tom
              title: "Homekit Error"
              message: >
                "The Homekit bridge has not started."
          - service: script.persistent_notify
              title: "Homekit Error"
              message: >
                "The Homekit bridge has not started."
              notification_id: homekit_bridge_error
      - service: homekit.start

Frenck mentioned since about 6 releases ago this is no longer needed.

What do you mean? Will my Z-Wave devices be added to Homekit without having to reload it?

Normally when doing a full reboot the Z-Wave network takes a while to come online. Therefore it is wise to delay the Homekit startup. The above automation started Homekit immediatly if you just restarted Home Assistant. It waited if you did a full reboot.

Here’s the link to his post, reacting to somebody that I think had the same (sort of) question

Hope it helps, otherwise ignore I ever replied :wink:

1 Like

All right!

One way to find out then, disable that part and see how it runs!

I have noted that every time I update the OS version (or possibly the Z-Wave version), my devices are lost in HomeKit. Does anyone know how this can be prevented?

I have approximately 50 Z-Wave devices, and it’s a HUGE pain to reconfigure them every other week…

For reference, I am using Z-Wave JS and since I have a camera that I need the sound on via HomeKit, I have to set up HomeKit via the configuration.yaml file.


Are you using the Z-Wave JS addon or running Z-WaveJS2MQTT?
In case of the addon ignore my message. In case of Z-WaveJS2MQTT ensure this is enabled:

I am using the Z-Wave JS add-on installed from the Integrations tab. Any other thoughts?

Do you still have this issue? About to migrate to Z-Wave JS with a lot of devices and also have a manual HomeKit configuration…