Zwave JS invert cover

I am setting up the new Zwave JS integration. Got most of my nodes working right now, but have an issue with 3 Fibaro roller shutter devices.
They work perfectly but in the lovelace UI the button states are reversed. When I click down the shutter goes up and vice versa.
Anyone has a clue where I can invert these states?

I have searched through the forum and saw this configuration invert_openclose_buttons: true but this seems to only apply to the deprecated zwave integration.

It‘s FGR-223 or FGR-222?
Because for the FGR-223 you can change the Input and Output orientation via Parameter (24 & 25)

Thanks for your answer. I have two FGR-222 and one FGR-223. I will try to change these parameters tomorrow.
However this won’t be a solution for my other shutters. No really big deal, but I hope there is some configuration setting for this regardles of the specific zwave device. Or this will be implemented in the future.

Same issue here, I just updated from the old zwave integration. I have 17 FGR-222 in my house and about 10 need to be inverted. I hope this can be done like in the old version:

    invert_openclose_buttons: true
    invert_percent: true

If someone has an idea how to do this, this would be great!

Unfortunately I can not find any way to do this in the home assistant software.
I was able to invert my FGR-223 using the Zwave configuration panel which was released in the latest home assistant version.
I am going to switch the wiring of the two FGR-222 so they move the right way.
@JoostHman this would be a hell of a job for 10 of them, hope there will be a solution for you soon to do this in software.

1 Like

I tried the Zwave JS integration but I encounter the same problem with my FGR-222.
They must be correctly wired since the UP button on the physical switch opens the cover and the DOWN button closes the cover.
However the UP/DOWN buttons in Home Assistant are inverted. I guess I also need the invert_openclose_buttons option in the Zwave JS integration

1 Like

Hi all, I thought it could be useful to create a feature request. See Zwave JS request to invert covers

Don’t forget to vote! :slight_smile:


Hi all,
Thank you the thread. I’ve already voted.
In my case, though I have 10 NeoCoolcam Roller shutters with the same problem in the new ZWave JS and the deprecated zwave integration.
It would be great to implement something common to all this kind of mechanisms.
Thank you!


I voted too hopefully it will be fixed

I had the same issue and made a work-around using covers-template.
I have Fibaro Roller Shutters for shutters with lamella position and everything works. As the module (even after calibrations) returns 2 or 3 in the up-most position I added a fix making it fully open (100) for the last 5%.

Just want to share if anyone is needing some code:

- platform: template
      device_class: shutter
      friendly_name: "Raffstore Wohnen Links"
      position_template: >
        {% if 100 - (state_attr('cover.013_rs_wohnen_l_5', 'current_position') | int) > 95 %}
          {{ 100 }}
        {% else %}
          {{ 100 - (state_attr('cover.013_rs_wohnen_l_5', 'current_position') | int) }}
        {% endif %}
      tilt_template: "{{0 + (state_attr('cover.013_rs_wohnen_l_5', 'current_tilt_position') | int) }}"
        service: cover.close_cover
          entity_id: cover.013_rs_wohnen_l_5
        service: cover.open_cover
          entity_id: cover.013_rs_wohnen_l_5
        service: cover.stop_cover
          entity_id: cover.013_rs_wohnen_l_5
        service: cover.set_cover_position
          entity_id: cover.013_rs_wohnen_l_5
          position: "{{ 100 - (position) }}"
        service: cover.set_cover_tilt_position
          entity_id: cover.013_rs_wohnen_l_5
          tilt_position: "{{tilt}}"
1 Like

You cannot say that because there is a possibility that both the motor and buttons are wired in reverse, but I agree it should not be needed to adjust the wiring to satisfy HA.

Hello, @Edwin_D you were right, I finally took the time to check the FGR-222 wiring.
I tried on a single one by inverting the wires for S1 and S2, and also for Q1 and Q2.
Capture d’écran 2022-09-25 à 18.11.08
It worked great!
Next the other 8 FGR-222 and I can finally ditch my Domoticz instance and mqtt Covers (Domoticz + zwave dongle → MQTT and Node-Red magic → Home Assistant ) to go full ZwaveJS with zwave-js-ui!

I should have done it sooner :wink:

1 Like