Zwave-js Nortek Security & Control LLC Z-Wave Garage Door Controller GD00Z-7

anybody have success of using the Zwave JS with the Go Control garage door opener

it sees it but won’t load the buttons to open or close it
I can go into the Zwave-js server itself and do a change of state and trigger the door but HA refuses to acknowledge this is a cover or switch of allow any control of it though is sees is as a sensor
my network key seems to work as my kwickset door locks are working as they should they don’t work without the matching key

It’s not supported yet, but they say it will be soon. It’s the main reason I haven’t moved over to Zwave-JS yet.

Ok thanks I haven’t moved it to production yet either just wanted to make sure what going on before I break it

who is claiming it will soon be supported?

as on the zwavejs site they are claiming it is done when I submitted a issue and refused to look at it and the server does not produce any buttons to trigger it, only way to trigger it is to change the state.

according to what I read on Home assistant they have Covers integrated already

so I am confused on who is working on it?

they mentioned it in the release notes…

where is that located?

1 Like

You are not alone. I have exactly the same problem with two Linear/GoControl garage openers. Just in case, attaching a screenshot.

yeah I have 2 as well though I have not moved my production system over yet waiting on these getting addressed

Had any luck with these? Just upgraded and they add fine to my zwave network but always show open and don’t let me control open or close.

They are working now they do need to be added with the secure method that means the hub has to be in close proximity as well

Interesting. I added mine secure and it connected and shows everything. Guess I’ll give it another go. Thanks for the response at least now I know it’s user error and not system error.

How close to the hub were you and also did you try repairing the tilt sensor to make sure it was playing nice

yup looks like closeness was the issue. Decided to rip them down and move them as close to the stick as possible and they connected with extra entities than before. Also seems the tilt sensors werent playing nice had to remove batteries to get them to resync. Thanks for the help wife will be happy garage door opens for her again lol.

1 Like

I included it non-securely but the parameters did not show up in Zwave-js.
I then followed your advice and included it securely and so far it works.

I am having trouble with my garage door opening which is a Linear (Nortek) GDOOZ-5. It worked fine with my Vera Edge but now when trying to include in ZWave JS in Home Assistant it refused to fully do so. The node adds but not all parameters show up. For example Group 1 should be automatically added, but is not, so no communication can take place between my Aeotec stick and the opener. I have tried including it every which way with security and without. I have tried including it within inches of the Aeotec stick. No joy. I would welcome any ideas.

unpair it and do the secure pairing through the zwaveJS app instead of the pairing button on the stick

also you need to have the keys generated in the Zwavejs app so it can pair securely

Thanks Trenton, I am glad you could get this device to pair for you. I have been using only the Zwave JS app to attempt to pair mine. I have not taken the Aeotec stick to the device but rather removed the device from the garage door opener motor and brought it to my Raspberry Pi 4 where my Aeotec stick is attached. There I tried both secure and unsecure pairing with no luck. I am wondering if I am just between updates to the zwave JS driver? (That was updated just before I tried to do this.)

do you have any locks that use secure pairing on this stick?

also you may have to force S0 legacy secure pairing unsecured pairing will not allow the buttons to show up so don’t even bother with that option

I don’t have any locks that use secure pairing in my system, so I cannot compare to those… (I have not really trusted them so far.) I have tried to force S0 pairing but that has not worked for me either. Now the Nortek opener version I have is GD-OOZ-5, not GD-OOZ-7 (as shown on the title of this post). I am wondering if my unit is just too old? Also my Aeotec stick is Gen5 not Gen5+. Maybe that is the issue? (I have not been able to find a Gen5+ to buy!