ZWave JS / Not able to listen to zwave_js_event

Hello,

After updating to 2021.4 today I went ahead and migrated from the depreciated Z-wave addon to ZWave JS.

Everything works as expected, except from when I try listening to zwave_js_event in order to configure some scenes coming from a Fibaro Dimmer 2. Nothing at all shows up when listening to ‘zwave_js_event’.

Does anyone know how I can troubleshoot this? I have tried rebooting the host system after configuring everything, but it did not solve the issue.

1 Like

I got the same problem as well with the new “zwave_js_value_notification” event. No output when I try to listen for my central scene activity. Also upgraded to the new version today.

Working in Node Red, listening to: zwave_js_value_notification

Tried inside NR now - same problem. Nothing outputs. I do see activity in the zwave log itself. But no events.

2021-04-08T12:46:44.142Z CNTRLR « [Node 069] received CentralScene notification {
                                      "nodeId": 69,
                                      "ccId": "Central Scene",
                                      "ccCommand": "0x03",
                                      "payload": "0x768004"

Always check the breaking changes of release notes when you upgrade. The event name has changed.

https://www.home-assistant.io/blog/2021/04/07/release-20214/#breaking-changes

1 Like

This is my response in Node Red on event type “zwave_js_value_notification” from an Fibaro Dimmer2:


{"event_type":"zwave_js_value_notification","topic":"zwave_js_value_notification","payload":{"event_type":"zwave_js_value_notification","event":{"domain":"zwave_js","node_id":3,"home_id":4165736736,"endpoint":0,"device_id":"f56a907b78632ea5406f872ef3eaf643","command_class":43,"command_class_name":"Scene Activation","label":"Scene ID","property":"sceneId","property_name":"sceneId","property_key":null,"property_key_name":null,"value":16,"value_raw":16},"origin":"LOCAL","time_fired":"2021-04-08T13:09:51.335700+00:00","context":{"id":"6225ff6a577e4636cae995496773aef4","parent_id":null,"user_id":null}},"_msgid":"b4e99de5.f5b1b"}

I only receive events on “zwave_js_notification”

{"event_type":"zwave_js_notification","topic":"zwave_js_notification","payload":{"event_type":"zwave_js_notification","event":{"domain":"zwave_js","node_id":75,"home_id":3364924264,"device_id":"8fcbfbf7c3ffc156fd533e7052962e88","command_class":113,"command_class_name":"Notification","label":"Access Control","type":6,"event":2,"event_label":"Manual unlock operation","parameters":{}},"origin":"LOCAL","time_fired":"2021-04-08T13:35:57.530971+00:00","context":{"id":"c8f7c307fa9f9374f5c1f87fd740db11","parent_id":null,"user_id":null}},"_msgid":"f9ceb936.7f7728"}

But nothing at all on “zwave_js_value_notification”.

I have no events coming through on anything! My devices are reporting, although it doesn’t seem correctly after upgrading to 2021.4

Trying a cold reboot to see if that helps.

Edit: Cold reboot did not help. Can’t listen to any events from zwave JS :frowning:

My Danalock sends events on “zwave_js_notification” and my fibaro units sends events on “zwave_js_value_notification” As listed in the documentation

And you were listening to the zwave_js_event prior to upgrading?

Yes, now I get no events when listening for zwave_js_event, zwave_js_notification and zwave_js_value_notification.

I have now tried removing the integration, uninstalling the server from the supervisor and reinstalling. Still getting nothing.

I have also tried to uninstall and install zwave.js - same problem. Everything was working OK through zwave_js_event before this upgrade.

I have also tried watching * events to no avail. Just shows me the service call and no zwave events.

As for Fibaro Dimmer 2 I got it working by listening to “zwave_js_value_notification”, but remember to set “Scene activation functionality” to yes in the new ZWave JS device configuration for the dimmer prior(Fibaro Dimmer 2 spesific).

image

1 Like

If you have that used in an automation, reload the automations. That’s what worked for me.

I too had trouble with this and had to monitor *, and I see the following events.

"event_type": "zwave_js_notification",

"event_type":  "zwave_js_value_notification",

Once I saw the event_type, I setup automations to trigger based on these, I can now go into Dev Tools > Events and filter on these event_types:

This is exactly what isn’t working. No events show in the event listener as per my post above.

1 Like

I see zwave_js_notification events like you do but my automation, which used to work, does not trigger.

- id: '1614992678575'
  alias: Back Door Unlock
  description: My comment
  trigger:
  - platform: event
    event_type: zwave_js_notification
    context: {}
    event_data:
      device_id: ca0ce3f263ada0b01763c19fe3a0e2a6
      label: Manual unlock operation
  condition: []
  action:
  - service: input_text.set_value
    data:
      value: Manual Unlock
    target:
      entity_id: input_text.lock_last_action
  mode: single

In the above I only changed zwave_js_event to zwave_js_notification. What else am I missing?

I just found my own solution. In the above automation trigger section I had to change label to event_label. Now the automation will trigger.

Updated to 2021.4.4 and still no events showing. I’m completely stuck with zwave automations if I can’t see what’s happening.

Anyone have any further suggestions?

Edit;

I have noticed that I don’t have zwave event listeners listed on the right of the events page;