Zwave polling intensity?


#1

I have been hard at work moving all my light switches over to HA (hassio on a pi3) from smartthings however some are not updating so I am trying to set the polling intensity.
I have gone to configuration > z-wave > selected the node I need to poll. In entities of node I selected the name of the node then set polling intensity to 1 and clicked save on the next line. however this setting never saves… if I close the window and go back to check its always back to 0, I have also tried restarting but still 0

am I doing something wrong?


#2

Not particularly, I don’t think so - that polling intensity does seem to get applied for me (hass 0.66.1) although it does the same “never shows an actual applied value, as if it had failed” for me as well; I just assume that panel is somehow half-broken. You should also make sure that there is a “polling_interval=60000” or similar in the z-wave section of your configuration.yaml file (under the port setting) and that your z-wave device is configured to wake up reasonably often.

You can verify the polling setting gets applied by looking into the zwave_device_config.yaml file that is supposed to be created, and also in the z-wave cache file where the value you poll should acquire a non-zero “poll_intensity” as a result (once you restart hass at least once so the file gets updated). There’s one more thing: the device config file with the poll setting in it might not actually be getting included from your configuration.yaml (see Zwave not honoring polling_intensity) therefore not do anything at all; you might need to add it yourself to the z-wave config section, using something like “device_config: !include zwave_device_config.yaml


#3

Thanks! It looks like your right it is working just not updating in the ui


#4

I just started adding zwave devices. I added to ge zwave (not plus) dimmers. They are slow to report to the UI. I’m running home assistant on umbuntu 17.10

When I click on off they the physical light dims slowly over about 4-5 seconds and turns off
the UI goes to off, but then quickly back on
the Icon changes to a darker color showing that it has dimmed (it’s already off though)
then after 10-15 seconds the light shows off in the UI

When I turn on with the UI its similar
shows dimmed, then takes 10-15 seconds to report fully on (changing the icon to yellow)

I have about 6 more dimmers that I have not moved over yet and I hope this can be “fixed”

This is my config. I’ve tried a few other variations, but had similar results

  usb_path: /dev/ttyUSB0
  polling_interval: 10000
  device_config:
    light.level_2:
      polling_intensity: 1
      refresh_value: true
    light.level_4:
      polling_intensity: 1
      refresh_value: true

#5

Hi. Did you solve this? I think I’m having similar problems.