Zwavejs2mqtt OTA firmware upgrade?

Has anyone actually done the OTA upgrade with zwavejs2mqtt? Many instructions say you have to deassociate the device from the network in order to update it. I’d rather not do that, as many of my sensors are hard to get to. Also, I downloaded the firmware for the Aeotec MultiSensor 6 and got a RAR file with an exe and a bunch of dlls. It isn’t obvious what or where the firmware file is.

The instructions that tell you to exclude the device are probably targeting users of SmartThings or Vera or a similar hub. It sounds like they’re providing a PC utility to perform the upgrade for you, which expects to talk directly to a USB dongle. Since you’re probably already using a USB dongle attached to the machine running Zwavejs2mqtt, you should be able to update directly from Zwavejs2mqtt if you can identify the firmware file. If you can’t, worst case you’ll just need to plug the USB dongle into a PC, run the update utility, let it update the device, and plug the dongle back into the machine running Zwavejs2mqtt.

I have done a firmware update OTA on iblind devices. The distance between the ZWave stick and the device mattered a lot. I had multiple failures with them 20 feet away, and first time success 3 feet away. You tend to get a lot of timeouts with longer distance, that for whatever reason do not recover. The reason you see advice to disassociate I think is because your ZWave network will become very busy in the OTA update, and the route from device to stick may be long with hops in between; using another network can remove those issues.

Did you end up trying this OTA upgrade via ZwaveJS2MQTT?

I’ve got a firmware upgrade for a few Zooz ZEN dimmers, but I really don’t want to deassociate and reassociate them since they’re such a pain to pair compared to other devices from GE/Jasco and Inovelli. Has anyone successfully done a Zooz ZEN OTA firmware upgrade via ZwaveJS2MQTT?

I do it all the time, works perfectly, and no, I don’t have to exclude/include the device. I do it for my Inovelli’s often.

Thanks. It’s been hit or miss me for to successfully update ZEN 72s via OTA from ZwaveJS2MQTT. I’m finding many of them get nearly to end of the fragments and the update times out.

Considering the problems I had pairing the ZEN 700 series switches to my controller compared to the Inovellis, I’m convinced they’re inferior quality in comparison.

Haven’t done an OTA update for an Involli yet, but I’m hopeful that it will be more reliable than these Zooz switches.

1 Like

Thought I would add my experience…I OTA upgraded firmware on an Aeotec HEM-Gen5 live on the existing network/location (no moving it close to the Z-stick, no excluding it from the network). For an Aeotec device, ZWaveJS2MQTT, supports the use of Aeotec’s .exe file (the .exe file is archived inside their .rar file). It took around 15 minutes for the upgrade. After the upgrade, the device is reinterviewed, and the previous device configuration was there so I didn’t have to reconfigure it.


If I may ask, what was your process exactly?
Doesn’t seems to be doing anything when I try the following?

  • zwaveJS2MQTT
  • control panel
  • select the device
  • advance
  • firmware update
  • begin
  • select Aeotec exe file
  • ok

    seems to be doing nothing

I don’t recall seeing anything in the GUI as the update was proceeding. I had the logger open and could see the update activity there.

I updated 5 Aeotec Recessed Door Sensor 7s tonight. Worked a charm.

1 Like

Hey, tried to update aeotec Multisensor 6. Downloaded the file - but nothing happens.

Should it work with Aeitec Z7 Stick ?

Thx for help ….

I haven’t been able to update my Multisensor 6s, I think you need to press the button on them and get the pairing light blinking in order to do so. All of mine are somewhat out of reach, so I haven’t tried this yet. They don’t do it by default, in spite of being powered by the USB port.

Hi @plasmon

Did you ever get past this procedure? I too seem to be stuck with some SmartSwitch6 ZW96 not being able to be updated past firmware 1.0.

I have the latest 1.4/1.04 Aeotec FW but it has an exe file only.

zwavejs2mqtt may be able to use the EXE to update the firmware.

Just updated two Multisensor6 through zwavejs2mqtt using Aotec’s .exe file, works.

Did you have to press the button on them? I have a number of USB powered sensors that are out of reach that don’t update. I’m not really motivated to take them down for upgrades.

Mine are both USB powered and always awake. Didnt push any button.

On my side, I ended up using the official Aotec/AEON process.

  • Downloaded the files on a windows PC
  • Plugged in the USB stick on the windows PC
  • Executed the exe (might have use the generic Aeotec tool and manually selected the firmware, don’t remember)
  • made a backup of the USB
  • Update the firmware
  • Plug back the USB stick on home assisant PC.

Since the network nodes info is stored on the USB stick itself, it’s quite easy and no risk of losing anything.

Thankyou both, and @firstof9 I am using that version. It accepts the exe, says "successful
" at the bottom of the UI, but nothing happens, including in the debug ui window.

I am trying to install new firmware on my Zooz Zen25. My ISY994i does not do OTA, so I bought a Zooz Zen ZST10 700 controller. I thought it would be. The Zooz website instructs one to get to that (link) That page instructs one to download Simplicity Studio and gives a link to instructions. Unfortunately, the instructions do not match the software that is installed. I was unable to glean the incantation.

Back at the Zooz site, was the statement “or another OTA Z-Wave firmware tool” which led me here. I attempted to put HA on my RPi 3B+ using a docker container, only to find out that I needed to have the version that had supervisor. Many attempts to do this eventually rendered my RPi unusable. Well as long as I have to reinstall the Raspberry OS, I may as well give HAOS a go.

After help from @tom_I I got HAOS running. I am of the understanding that Z-Wave JS will not do the OTA update, but Z-Wave JS to MQTT will. Here’s what I do

  1. Start up HA without any add-ons (I’ve installed and removed the aforementioned add-ons many times, so the installation is now probably corrupted)
  2. I plug in the Zen ZST10
  3. I click on Configuration – > Add-ons, Backups and Supervisor and the web page goes blank.
  4. I plug in a keyboard and monitor into the RPi and type host reboot (leaving the Zen15 plugged in)
  5. Eventually HAOS reboots (the HA prompt returns), I reload the web page and log in.
  6. This time I click on Configuration–>Devices & Services and there is my Zen ZST10
  7. I click on [CONFIGURE] of the Zen ZST10 and Z-Wave JS is installed.
  8. I submit no keys and the Z-Wave JS is started (not the “take some seconds” is quite a sum)
  9. I enter the Area and click 'FINISH]
  10. Next I add my Zooz Zen25. Configuration–>Devices and Services–>Z-Wave JS[CONFIGURE]–>(+ ADD DEVICE)
  11. I put my Zooz Zen25 into pairing mode and soon a dialog box indicates “The Device has been added”
  12. Close dialog box
  13. Click on Overview–> Double Plug(2) and I get the expected result of the second outlet turning on.

Now I need to do the update But after clicking around a bunch, (I can’t find any documentation that corresponds to this version of HAOS) I assume this is the time to load * Z-Wave JS to MQTT*

Configuration–>Add-ons, Backups & Supervisor–>(ADD-ON STORE)–(scroll down)–> [ Z-Wave JS to MQTT]---->INSTALL some seconds (tongue-in-cheek)–>START some seconds*–>OPEN WEB UI* (I respectfull decline the request for usage statistics) –>NO

Is this the page where one executes the OTA? There are no nodes showing on this page, though the Z-Wave JS page does show devices. One can get to this page via Configuration – > Add-ons, Backups and Supervisor–>Z-Wave JS to MQTT–>OPEN WEB UI

ACTIONS–v[ADVANCED ACTIONS]–>Re-interview Nodes[START] but nothing happens

How about stopping Z-Wave JS?
Configuration – > Add-ons, Backups and Supervisor–>Z-Wave JS–>STOP and for good measure disable Start on boot

Now restart Z-Wave JS to MQTT
Configuration – > Add-ons, Backups and Supervisor–>Z-Wave JS to MQTT–>RESTARTsome seconds –>OPEN WEB UI now the result is “502: Bad Gateway”

Try that again:
Configuration – > Add-ons, Backups and Supervisor–>Z-Wave JS to MQTT–>OPEN WEB UI–>ACTIONS–v[ADVANCED ACTIONS]–>Re-interview Nodes[START] but nothing happens

reboot HAOS (on RPi console enter host reboot) some seconds …ha> returns

Click on Overview

Try that again:
Configuration – > Add-ons, Backups and Supervisor–>Z-Wave JS to MQTT–>OPEN WEB UI(no devices)–>ACTIONS–v[ADVANCED ACTIONS]–>Re-interview Nodes[START] but nothing happens

Factory reset Zen25 and try to include using Z-Wave JS to MQTT
Configuration – > Add-ons, Backups and Supervisor–>Z-Wave JS to MQTT–>OPEN WEB UI(no devices)–>ACTIONS–v[MANAGE NODES]–>Inclusion[NEXT]–>(enter Name and Location)[NEXT]–>SecurityDefault[NEXT]–>factory reset device and put it into inclusion device times out.

Stop Z-Wave JS to MQTT
Configuration – > Add-ons, Backups and Supervisor–>Z-Wave JS to MQTT–>STOP

Start Z-Wave JS
Configuration – > Add-ons, Backups and Supervisor–>Z-Wave JS–>RESTART

Factory reset Z-Wave controller
Configuration – > Add-ons, Backups and Supervisor–>Z-Wave JS–>Configurationscroll down*–>RESET TO DEFAULTS*

I’ll continue to thrash In a dual effort of waiting for someone who knows how this is suppose to work responds or I stumble upon a solution