0.102: Official Android App, Almond, Scene editor

answering myself just for reference and this doesn’t get buried:

updating to 102.2 seems to have solved the issue (of Owntracks not being able to connect to the HA MQTT add-on) and things are working fine again.

I updated from 0.101.3 to 0.102.2 this morning and now my NUC CPU is getting absolutely punished. Not sure why but it’s sitting at max usage most of the time and as such HA has become very slow to use.

No config changes recently and none of the breaking changes with this release effect my setup.

Nothing in the logs.

Running HassIO with HassOS NUC image. Anyone got an idea of what to look for?

In the below you can see that it used t sit around 60% (MotionEye gives it a fair workout) but since the update it’s hovering up close to 100% most of the time

Does anyone know the reason why the scenes editor activates a scene right after going to its edit mode? To me this is ridiculous and looks like a bug rather than an intended behaviour

Why would anyone want to activate a scene when editing it? I don’t want my home to flash lights, open/close covers and go crazy whenever I edit a scene. I know no other system that does it this way. To me this makes the scene editor a bad feature only launched in emergency cases when I’ve got no access to my scenes.yaml file

Which NUC, how many cameras?

Yep … the later 0.102.1 update fixed it

Completely agree… I don’t want my skylight opening and letting the rain in to my house just because I am editing a sunny scene when it is raining!!

Same here on Synology using docker (updated at 2:00PM yesterday):

Exactly. I opened a new thread in the community forum in the development section to discuss this.
I think it’d be good if you share you view in there, so then hopefully the HA devs will notice this issue and do something with it.Normally issues are discussed on github, but for some reason this time they didn’t allow it.

Hi, I’m getting the same thing everytime I check config:

INFO:homeassistant.util.package:Attempting install of attrs==19.2.0
INFO:homeassistant.util.package:Attempting install of attrs==19.2.0

Is there any way to find which integration is still trying to use 19.2.0?

EDIT: Are you using HACS? If so what version of HACS are you using?

1 Like

That’s a weird one, no other updates to MontionEye or other plugins that have happened recently?

I just checked the CPU usage on my home unit and it’s sitting at about 10-12%, with Shinobi CCTV and all my other gear running. The one at my business (exact same i5 2400 and other hardware) has no cameras running, sitting at 2-3% usage. Both on 0.102.2.

That’s a strange one. Something to do with the NUC image itself?

It’s only a Pentium NUC, running 2x 4K cameras with MotionEye doing the motion detection and recording


I’m not sure. Today when I look at it now it’s sitting on it’s usual ~60% CPU usage.

Yes i am. 17.4

Since updating to this version my automated nightly snapshots have been generating this error:

Timeout on /snapshots/new/full request

Folowed by the unhelpful:

Error on Hass.io API:

Though on inspection of the snapshot contents they do appear to be completing successfully they are taking longer than they were on the previous version and using considerably more resources.

- id: daily_backup
  alias: Daily Backup at 1 AM
  initial_state: true
    platform: time
    at: '01:15:00'
  - service: hassio.snapshot_full
      name: Automated Backup {{ now().strftime('%Y-%m-%d') }}
  - service: notify.telegram_system
      title: '*Information*'
      message: "Creating backup named Automated Backup {{ now().strftime('%Y-%m-%d') }}"

Same here, after looking at the source code, I believe it’s a bug in HACS that is causing this, but by the looks of it it should be fixed with the next release of HACS. :slight_smile:

1 Like

With the latest update, my scenes don’t work anymore. I tried the migration option and they didn’t work. I only have a handful of them so I removed them and made them all new through the editor and they still don’t work.

They are simple scenes that just call a script. I do this so I don’t have to expose scripts for my Amazon Alexa. When I added the scene via the editor it gave them a state of ‘off’. I tried to change the state to ‘on’ and also tried ‘true’ which is what my old ons had and they still don’t work. When I manually activate the scene in my front end it doesn’t give any errors in the logs or any changes int he log book.

What is the correct why to call a script from a scene in this new scene system?

- id: '1574958360074'
  name: Goodbye
      state: 'true'

There is no correct way. You can’t. You need to use scripts.

So scenes no longer support calling scripts, even though they used to before this update?

Yes, you can’t do this anymore. An explanation for this can be found in this Github issue:

Correct. Just migrate your scenes to scripts. A bit of editing and you’re done.

Scripts can also be exposed to Google Assistant and I presume Amazon Alexa. I expose the domain and then only expose the scripts I want by using the expose flag. It takes a little work to set it up of course but once done it’s done.