0.105: Safe mode, Headers & Footers, New Zones Editor, Garmin, Sighthound

ERROR:homeassistant.util.package:Unable to install package homeassistant-pyozw==0.1.8: Failed building wheel for homeassistant-pyozw
Command "/srv/homeassistant/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-6ox9kn7b/homeassistant-pyozw/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-b84y57ip/install-record.txt --single-version-externally-managed --compile --install-headers /srv/homeassistant/include/site/python3.7/homeassistant-pyozw" failed with error code 1 in /tmp/pip-install-6ox9kn7b/homeassistant-pyozw/

Any idea why I am getting this error

Thanks! My bad, I’ve just picked it from the next branch and pushed it live. Takes a bit before it becomes visible.

The new Supervisor dashboard is pretty, but it does not easily convey when an Add-on is active or not. Are the icons supposed to be grey if inactive? I don’t actually know if the WireGuard icon should be grey or not (it is inactive).

Certainly for the colour blind - this is an impossible way of identifying inactive add-ons. There needs to be a more obvious indicator.


I presume the line along the top indicates an update? Again, conveying this by colour alone is poor UI for the visually impaired.


Perhaps splitting the page into blocks would help

  • Active
  • Inactive

and then a big star or something to indicate update required?


From the UI, what is the best way of creating a group of lights controlled by switches? I have a number of Tasmota Tuya switches controlling lights.

I have a ‘group’ which groups the switches together - I just wonder if there is a better way.

I hate to ask a stupid question but let’s suppose I’m using the hide_entity to hide all my automations from the auto-generated lovelace gui. After I remove hide_entiy I have so many extra things in the way I don’t want to see.

What is the correct way to hide entities using lovelace?

Hopefully I’m just missing something but it seems like Im supposed click through my entities, one by one, so I can edit them. Please tell me I’m wrong and there is a quicker way to do this. I really don’t have the time to spend clicking through each entity one at a time. I would like to include this directly in my configuration somehow. It’s a lot quicker for me to edit a yaml file (for things I understand) than it is to spend time clicking around in the gui make one change at a time.

I’m not trying to complain but I admit I’m still stuck in some old ways. I’m just trying to understand how to move forward.I’m still trying to avoid having my config hidden away in a folder with files I’m not supposed to manually edit. I would like (as much as possible) to keep my configuration in the established yaml files.

It can be defined at the card and entity level

That’s even better than I hoped. Thanks!

I am using it like this in the frontend;

  - entity: switch.brilliant_3
    state_color: true

Seems to work.

Automations will no longer be included in the generated UI in 106. Toggling automations can be done from the automations page in the UI.

1 Like

I see this error returning in my logging:

> Error handling message: Unknown error
> Traceback (most recent call last):
>   File "/usr/src/homeassistant/homeassistant/components/websocket_api/decorators.py", line 20, in _handle_async_response
>     await func(hass, connection, msg)
>   File "/usr/src/homeassistant/homeassistant/components/search/__init__.py", line 49, in websocket_search_related
>     msg["id"], searcher.async_search(msg["item_type"], msg["item_id"])
>   File "/usr/src/homeassistant/homeassistant/components/search/__init__.py", line 89, in async_search
>     getattr(self, f"_resolve_{search_type}")(search_id)
>   File "/usr/src/homeassistant/homeassistant/components/search/__init__.py", line 163, in _resolve_entity
>     for entity in automation.automations_with_entity(self.hass, entity_id):
>   File "/usr/src/homeassistant/homeassistant/components/automation/__init__.py", line 136, in automations_with_entity
>     if entity_id in automation_entity.referenced_entities:
>   File "/usr/src/homeassistant/homeassistant/components/automation/__init__.py", line 321, in referenced_entities
>     for entity_id in _trigger_extract_entities(conf):
>   File "/usr/src/homeassistant/homeassistant/components/automation/__init__.py", line 581, in _trigger_extract_entities
>     return [sun.ENTITY_ID]
> AttributeError: module 'homeassistant.components.automation.sun' has no attribute 'ENTITY_ID'

Any idea what might be wrong?

That’s… weird. Can you open an issue and tag me. It should not behave like this, we import the sun at the top of the file from components module.

That’s great to know! I’m excited for this :smiley:

+1 It’s a shame states is going to be removed, I’d rather it just gets depreciated. It’s not like HA doesn’t already use quite a bit of space with it’s 1000+ included components! :smiley:

I suggest the tileboard UI, it’s a bit fiddly to set up but works far better than both ‘states’ or ‘lovelace’ UI for me on older devices. :slight_smile:

Thank you @balloob, issue has been created:


I had that error as well, sudo apt-get install libudev-dev fixed it. Found the fix in this thread.

Is there documentation on the correct way to deploy this? I have it seemingly working (post above), but have an error in the frontend which I would like to correct.

Expected a value of type `{entity,name,icon} | entity-id` for `entities.0.state_color` but received `true`.

I can not seem to find any reference to it on the blog post other than what I have quoted. Am I missing something?

I’ve checked the Lovelace changelog HERE, and there is no config listed, and also the entities card page HERE, again, nothing mentioned about state_color.


Did you read the docs @balloob pointed you to? It tells you how to create a group and it is NOT via the gui.

Deprecated would mean they still have to support it. Removing it doesn’t

Plus I think there is a lovelace card out there that can add all entities if I am not mistaken

1 Like

I guess removing states UI is best in the long run, and I’m glad I’ve got a version or two to fix my config before states is gone!

Yes sir, I ultimately found the answer on discord. Two different Raspis that no longer had libudev-dev installed. Glad it worked out. Thanks

FYI zwave users, if you’re running on a Pi it’s going to take a minute for openzwave to compile.

1 Like