0.106: Light brightness stepping, better Safe Mode and person dialog

Hi.
I have same problem aswell…
If if remove and add deconz sensor is back… But if I reboot hass server is gone again… :frowning:

This is big problem… I will try to rollback!!

The problem will be fixed in 0.106.1 but who knows when…? https://github.com/home-assistant/home-assistant/milestone/288

The fix is on its way

When I upgrade to 106 I lose my main tab. It just shows up as blank. I go back to 105.4 and it is fine. Any ideas?

They are pretty good about getting point releases out. Maybe in a day or 2?

Check your custom cards and update them. I had some older custom cards that needed to update. Pretty much all custom cards need an update or replacement. Me for example I had some older monster cards around and switched to auto-entities and it fixed it.

1 Like

Hello everyone…

I’ve been having problems with Mikrotik integration since the last change (to convert it into a Hub?). My setup includes 2 mikrotik APs, both running independently (not CAPsMAN), covering the house. One of the mikrotik APs act as the router, dhcp etc.

When I boot HA, it seems to (most of the time) discover the devices where they are, within the mikrotik AP client is connected to. (I am using wireless only, not dhcp)

But, whenever the client roams into the other AP, things get crazy. HA marks the device as away, sometimes recovers after some period, sometimes it does not.

The only log I get is

homeassistant.exceptions.HomeAssistantError: Entity id already exists: device_tracker.XXXXX. Platform mikrotik does not generate unique IDs

Anyone has any ideas?

Does anyone else have trouble adding devices to a person on the “persons” page after 0.106 update? If I go to configuration>persons>any person and try to pick a device from the drop down menu nothing happens. However if I manually type the device name in I can add and update the devices.

Your gif caught my eye and yes I’m having the same problem. I’ve tried a few things to fix it but the thing that seemed to do the trick was ensuring I had the latest version of the mini-graph-card AND making sure to update the lovelace resources as the file name changed to mini-graph-card-bundle.js . (see code excerpt below) I also did a Ctrl + F5 refresh to clear the cache.

# originally in my lovelace yaml it was
#   - type: module
#     url: /community_plugin/mini-graph-card/mini-graph-card.js 
# now it requires
  - type: module
    url: /community_plugin/mini-graph-card/mini-graph-card-bundle.js 
1 Like

It took around 30seconds - 1 min for me, I don’t know exactly but far less than 1 hour!

you need to go to the top right menu in lovelace and click on take control from there.

But be aware that you will then have to maintain your lovelace config manually thru the GUI editor (or thru yaml mode if you want). It will no longer automatically add new entities to your frontend.

Unless that’s changed and I didn’t see it… :slightly_smiling_face:

I was about to write a reply on my own post :slight_smile: that was needed to get it work. I updated to the latest version before but it didn’t help. What I forgot was to clear the cache on all devices :slight_smile:

Fully agree! I’m not diminishing Safari as such… frankly speaking I prefer it to other browsers somehow and using Chrome only when really need to. Problem with ‘web page using significant memory’ was indeed one that was bugging me too, but now I see it gone, so it is getting better, but as described before not ideal. Now what is really worrying me for the future (‘Might be, it’ll be something hard to fix, and the developers move on to other things, and recommend folks use Chrome’) Companion app for iOS is also using Safari… if it would be dropped, means also iOS app will stop functioning properly… and this would be bold move…

1 Like

That’s a good point, I didn’t think of that. Given that the (semi-)official app for iOS uses WebKit / Safari under the hood, making sure things run well on Safari seems like a Must Have.

I don’t have anywhere near the number of entities that some folks have, but my install is also pretty new, and I don’t have that many automated devices. We’re actually pretty early in the whole smart devices / IOT maturity timeline. It’s not hard to look into the future, and imagine that even folks who don’t set out to build a “smart home” have dozens of smart devices, because it becomes so cheap to add the electronics to “dumb” things that basically everything is a smart device. Pages that might list all entities need to be heavily optimized.

Many thanks Robban for the heads up and thanks to all the developers for such prompt fixes! Have installed and tested 106.1 on HassOS 3.11 with deconz 5.3 on RPI4 and everything as far as I can tell is working as it should, aqara contact binary sensors are back and working. :partying_face:

Home Assistant is getting better and better!!

2 Likes

It seems like safe mode completely erased my lovelace configuration. Is there a way to recover anything? Or do I have to redo everything from scratch? It went more or less like this:

  • I edited configuration.yaml
  • restarted Home Assistant
  • big red safe mode warning
  • fixed configuration.yaml
  • restarted home assistant
  • safe mode card is still there, but it’s not red anymore and it’s the only card left

I just wanna cry…

1 Like

I made sure the custom cards were updated and still no luck. I do have the tracker-card installed and when i update to 106 this is the error i am getting on the tracker page

Cannot add property trackers, object is not extensible

Were the cards also updated with the changes for 0.106?

What im missing with the scenes is transition time, any chane that will get (re-)added?

1 Like

If safe mode overwrites everything on lovelace, it’s a pain rather than a feature… Let’s hope it’s just a glitch…

1 Like

After the update to 0.106.1 the status of my Hue lamps changes regularly for about 6 seconds from on to anavailable and back again.
With 0.105.5 I could not observe this.
Any suggestions?