0.106: Light brightness stepping, better Safe Mode and person dialog

Here I was working on my automations while upgrading to .106 and they seemed to slow down or not work at all. Very frustrating when I can’t see if the automation is receiving the triggers or I just coded it wrong. Trying to mode to Node Red now.

I was able to get it to load. I had to remove the Monster Card custom and replace it with auto entitites. Also some of my other cards won’t load now until they get updated which i am just waiting on now.

  • Suggestion:

light.increase should be called with transition enabled if transition is enabled on the light, otherwise the light will not “dim” but simply blink toward desired brightness while rotating a dimmer. Or at least it should support the proper option.

I have recently upgraded to Home Assistant 0.106.2 and now my Tado heating/hot-water devices are listed as unavailable.
I presume that this is due to the breaking change that says:
“Adding support of multiple Tado accounts has changed the unique ID generation of sensor and climate devices, and now includes the ID of the home.”

My pre-existing devices have ids like …
sensor.heating_temperature
and I see in the “unused” section of the UI entities like this
sensor.heating_temperature_2

Is that a result of the update?
Does this mean that I will lose history details if I switch to the new id?
If yes, is there a way to retain the history?

just rename them to sensor.heating_temperature

2 Likes

Well, they were fast to address it. Yet, I haven’t even seen anything for Mikrotik hub problem:

Don’t know where I should submit it to get more attention. Mikrotik integration was flawless, and now it’s a mess.

write an issue up tagging that integration on github

No, I saw a reply somewhere From one of the devs that it’s been fixed and will be in 0.107 if memory serves.

Thank you. I hadn’t seen a fix was in.

I have just upgraded to 0.106.4 and Samba share (9.0) has stopped working.
I am getting the following error in Samba Share’s logs “waiting for connections added interface eth0 ip=fd93:9035:1fbb:1:2620:b8bd:b2c3:5d52 bcast= netmask=ffff:ffff:ffff:ffff::”.

Has anyone else encountered this issue?

Hopefully it comes back in 0.107

This isn’t an error.

1 Like

The custom:tiles-card is broken now after upgrading to 0.106. I get the error message Cannot add property id, object is not extensible. This is really disappointing. I spent a ton of time creating all the buttons for my Harmony remotes to have them in HA.

There is an issue open in the tiles card repository. Unfortunately this card has not been maintained in a very long time and may be abandoned. Crossing my fingers that it finally gets some work. As I have used it extensively and to have to change over to the custom button card will be an absolute pain. It is nowhere as easy to use.

I don’t know why you are complaining here about this card… it’s a custom card and with that comes the risk of it being deserted.

Well I was letting people know if they use it and haven’t upgraded yet. Thought that was the right thing to do. Sorry for offending you.

You didn’t offend me. I just don’t see the point in complaining while informing :wink:

calendar card seems to be broken in the latest update ~?

Thankyou, not sure what the problem was then, I rebooted several times and tried accessing the shared folders from 2 computers with no luck.

I saw there was another upgrade 106.5, so I upgraded and Samba started working again.

I just updated from 0.105.5 to 0.105.6 (HA Supervised on Ubuntu 18.04 host on a NUC). I checked all the breaking changes, I updated everything in HACS, I checked my config with the Config checker add-on. All good. So I hit the update button. I now have no front end - no safe mode, no nothing, just a screen that says This site can't be reached, 192.168.0.151 refused to connect. I can SSH in and I have access to my files through WinSCP, but I have no idea what to fix. I did a config check and it completed successfully. My logs are empty. I tried downgrading to 0.105.5, and that completed successfully, but didn’t get me a front end. I tried upgrading back. No change. Here’s what I have:

➜  ~ ha core info
arch: amd64
audio_input: null
audio_output: null
boot: true
custom: false
image: homeassistant/intel-nuc-homeassistant
ip_address: 172.30.32.1
last_version: 0.106.5
machine: intel-nuc
port: 8123
ssl: false
version: 0.106.5
wait_boot: 600
watchdog: true

I tried to see if I could restore a snapshot somehow, but I can’t use hass-cli, I get the following error:

➜  ~ hass-cli info
error: HTTPError: 502 Server Error: Bad Gateway for url: http://hassio/homeassistant/api/discovery_info
Run with -x to see full exception information

I even tried rebuilding the core, but it just gives an error:

Processing... Done.

Error: Unknown Error, see logs

ha core logs shows me a blank file.

I’ve never had an issue upgrading in the two years I’ve been using HA. I would really appreciate some ideas for how to get myself back to normal!

Did you try rebooting the machine?