0.117: Quick Bar, compact header, a YAML editor, XBox and Template types

I haven’t seen it made explicit during this thread but…

Do we have to completely remove the deprecated Custom Header from HA before we update to this version? Or will other functionalities of CH still work along with the new built-in minimized header?

Ch still working fine :wink:

1 Like

Updated from 116.4 to 117.2 today. I noticed markdown works different now. There is a stylesheet variable with height: 100% that overrides card mod styling (I have height: 30px on ha-card to make it smaller. Is there a way to remove that? I tried using !important in my styling. This kinda works, but is very hacky and the UI jumps when reloading page.

Also: I noticed I can now pinch to zoom on iOS app (same as using a browser). This is pretty bad when using double tap because then it zooms in… You can now pinch to zoom/ zoom out the entire lovelace view on iOS. I hope this is a bug and not a feature…

I’ll restore my snapshop for now. I hope I can find a way to properly style the card height and the iOS zoom ‘feature’ gets patched in a future update.

Awesome! Good to hear!

Hopefully the functions I want will be put in HA core before CH completely dies.

Mainly just better control over user access to views/tabs (the current “visibility” functionality is a bit lacking and kludgy) and the ability to turn on & off view/tab visibility completely for everyone thru the back end (or in some other dynamic way like a “conditional card” for views/tabs).

I have a bunch of tabs I don’t always want to see cluttering up my dashboard but I still need them to show up occasionally as needed.

Since @mayker is officially in the HA dev team now, consider this a FR, please? :wink: :laughing:

yeah, in fact, really only the header size has been introduced into core now.
All other functionality we could simply set using an input_boolean or a template is lost on us now (well not exactly now, because it still completely works, but officially it is…). Which is a true bummer.

as a matter of fact, I’ve just posted a small thingy on the card-theme thread of card-mod. Which isnt anywhere near the functionality of CH of course, but the only thing we have for now.

Really hope we can have the Options options, the exceptions, which you are referring to here and the builtin variables back, anytime soon in a new custom add-on, or preferably core of course.

1 Like

I am on Proxmox, too with a Debian VM running Docker. I only have seen a Raspberry user @SiriusGen claiming similar issues with post 0.117.0 continual memory increase.
There is a post that ONVIF could be resonsible. Are you on ONVIF? I am.

I assume you mean 0.117.2. Trouble is, the latest seems to be 0.117.1

Not anymore https://github.com/home-assistant/core/releases/tag/0.117.2

Not visible (yet) on http://home-assistant.io, nor in my supervisor.


sorry for my late reply.
No, I only see it the issue only in the home assistant app or the safari mobile view on my iphone and ipad

Hi, since update 0.117 I have a bad thermostat card, see picture. Thanks

Hello, is the REST problem fixed with version 1.117.2?

I don’t dare reactivate my sensor …

thank you

No REST platform is still bad! :frowning: I need this fix. I have lots of rest sensor. After upgrade :ERROR (MainThread) [supervisor.homeassistant.api] Error on call

All my REST sensors are running fine without any issues. What error did you get? And please also show the code of the non-working sensor.

When running “Check Home Assistant configuration” to check 0.117.2 I get this error. This error does not show on 0.117.1.

aiohttp 3.6.2 requires multidict<5.0,>=4.5, but you'll have multidict 5.0.0 which is incompatible.
[12:36:07] INFO: Installed Home Assistant 0.117.2
[12:36:07] INFO: Making a copy of your configuration for checking...
[12:36:07] INFO: Checking your configuration against this version...
[12:36:34] ERROR: The configuration check did not pass!
[12:36:34] ERROR: See the output below for more details.
Testing configuration at /tmp/config
Fatal error while loading config: (multidict 5.0.0 (/usr/local/lib/python3.8/site-packages), Requirement.parse('multidict<5.0,>=4.5'), {'aiohttp'})
Failed config
  General Errors: 
    - (multidict 5.0.0 (/usr/local/lib/python3.8/site-packages), Requirement.parse('multidict<5.0,>=4.5'), {'aiohttp'})

Anything to be concerned about?

When does the fix for Synology DSM come? Since 0.117.0 and 0.117.1 a lot of people are reporting issues with entities that are unavailable for the Synology DSM integration.

Problem seems to be with people who have 2FA enabled on synology. Before 0.117 it was working perfectly. What changed?

Here is the code of the REST sensor which no longer works since version 1.117.

  - platform: rest
    scan_interval: '00:30:00'
    name: vacances_scolaires
    json_attributes_path: "$.records[0].fields"
      - start_date
      - end_date
      - description
    resource_template: |-
      {% set location = 'Limoges' %}
      {% set rows = '1'%}
      {% set aujourdhui = now().strftime('%Y-%m-%d')%}
      {% set dayOfYear =  now().strftime('%j') %}
      {% set year =  now().strftime('%Y') | int %}
      {% set lastYear = year - 1 %}
      {% set nextYear = year + 1 %}
      {% if dayOfYear > '244' %}
      {% set schoolYear = (year | string) + "-" + (nextYear | string) %}
      {%- else -%}
      {% set schoolYear = (lastYear | string) + "-" + (year | string) %}
      {%- endif %}
    value_template: |-
      {% set aujourdhui = now().strftime('%Y-%m-%d')%}
      {% for record in value_json.records -%}
      {% if aujourdhui >= record.fields.start_date and aujourdhui <= record.fields.end_date %} 
      {%- if record.fields.description %}{{record.fields.description}} jusqu'au {{ as_timestamp(record.fields.end_date) | timestamp_custom('%d-%m-%Y') }} {% endif %}
      {% else %} 
      {%- if record.fields.end_date > aujourdhui and record.fields.description %} prochaines : {{record.fields.description}} {{ as_timestamp(record.fields.start_date) | timestamp_custom('%d-%m-%Y') }}{% endif %}
      {% endif %}
      {%- endfor %}

The source of this code is:


There are several topics, a solution seems to be in progress but I don’t know if it was applied in version 1.117.2, I don’t dare to try …



1 Like

Tried 0.117.2 last night. But still having problems with the view on my tablets. Everything keeps to be didplayed out of screen since this update. Cards seem to e bigger as before now (changed DPI to make all fit). And need to scroll verticaly and horizontally now.

So went back to 0.116.4 again.

v0.117.2 doesn’t seem to be available on RPi3:

20-11-02 13:25:31 ERROR (SyncWorker_6) [supervisor.docker.interface] Can't install homeassistant/raspberrypi3-homeassistant:0.117.2 -> 404 Client Error: Not Found ("no such image: homeassistant/raspberrypi3-homeassistant:0.117.2: No such image: homeassistant/raspberrypi3-homeassistant:0.117.2").

Can it be added? Thank you.