0.70: Facebox, SpaceAPI, Konnected Alarm System

the IOS app may require updating to support the new frontend changes

I also receive the error;
No such file or directory: ‘/dev/serial/by-id/usb-RFXCOM_RFXtrx433_A1YUV6ZC-if00-port0’

Also for my z-wave stick i receive the error.

On my docker host i see the folder /dev/serial/by-id/…
But in my docker container there is no folder /dev/serial/by-id/

Please help!

Whats odd is I have 2 different IOS devices running the app. iPad works fine; no issues. iPhone displays empty tabs, reports script errors on the HA host.

Both are running same iOS version and app.

Not sure what is going on; perhaps screen size related as these logs seem to indicate:
Tue May 29 2018 05:07:13 GMT-0400 (EDT)

https://XXXX:8123/frontend_es5/app-1277c62fbd5787659346fe106c01cc31.js:2:15816 TypeError: undefined is not an object (evaluating 'window.hassUtil.computeDomain')

If you have the iOS app try to uninstall and reinstall. That may be the only way to clear cache/data in that app.


I was super excited to see an updated pygatt, hoping it would be substituted for the gattlib requirement for BLE. But that doesn’t appear to be the case yet. I wonder if BLE will get any attention? Seems like it hasn’t been working for more than a year.

This looks like something changed with accessing serial communications. Did I miss something in the release notes?

I’m holding off upgrading for now.

So it seems like something changed in the Docker image. It did not had the OS pinned and so got automatically upgraded from Debian Jessie to Debian Stretch. Tracking the issue here https://github.com/home-assistant/home-assistant/issues/14680

Does this only affect the plain Docker image or also hass.io?

Only the plain docker image. I’ve pinged the maintainers of the Docker image but feel free to step in and help.

Reinstalling iOS app solved the problem of ha-floorplan not working anymore, even after upgrading to latest version of ha-floorplan. @dshokouhi thanks for the tip!

1 Like

tried to update hassio…

18-05-29 21:16:18 INFO (SyncWorker_5) [hassio.docker.interface] Update docker 0.69.1 with homeassistant/raspberrypi3-homeassistant:0.70.0
18-05-29 21:16:18 INFO (SyncWorker_5) [hassio.docker.interface] Pull image homeassistant/raspberrypi3-homeassistant tag 0.70.0.
18-05-29 21:16:24 ERROR (SyncWorker_5) [hassio.docker.interface] Can’t install homeassistant/raspberrypi3-homeassistant:0.70.0 -> 404 Client Error: Not Found (“no such image: homeassistant/raspberrypi3-homeassistant:0.70.0: No such image: homeassistant/raspberrypi3-homeassistant:0.70.0”).

The error is a bit ambiguous but this is usually caused by lack of disk space.

Disk use (percent) /home
1 minute ago
25.7 %

Im getting errors everytime i load the frontend

https://hassio.local:8123/frontend_latest/app-653721033e62144d6a686dab25ef1429.js:2:12049 Uncaught TypeError: Cannot read property 'computeStateName' of undefined

also getting this

18-05-30 03:30:32 ERROR (MainThread) [hassio.api.proxy] Client error on API stream request Cannot connect to host ssl:None [Connection refused].

Perhaps it has nothing to do with it, but are you using Chrome 66? Since this version it it more strict on using ssl etc.

Yep I’m using latest version 66.0.3359.181 (just updated)

I can still acess HA all ok no problems other than the error log being created, the second SSL error seems to have gone now…

Think i found the problem

to do with custom UI

disabled this and no errors

Yup as mentioned in the blog post all Custom UI’s need to be updated :slight_smile:

I had issue with blank state cards but after I updated Custom UI - Release 20180528 everything works.

In fact, I am very impressed at how fast the front end is now particularity the logbook and history. I don’t see any delays now when previously it would be 5 secs.


Agree; it feels really snappy now!