0.84: Cloud webhooks, Wunderlist and USGS Earth Quakes


#62

Ok I did the jump now I am on 0.84.1 but in frontend I have the below. Not sure what I have to do now: wish to try the new storage method

No config found.

RELOAD UI-LOVELACE.YAML

EDIT: had to press F5 on the browser, now I have the frontend back, but not lovelace, my old (from me not updated) legacy UI. On the top right clicking on the three dots there is a menu CONFIG UI, then I clicked TAKE CONTROL OF UI, then RAW CONFIG UI, but it shows nothing. I am a bit confused …


#63

Ok, I’ll post the logs, give me a few


#64

Basically I got my old UI that I can edit with the browser editor, which is fine. But I was using Lovelace, how to use that, and edit the Lovelace configuration I had?


#65

@estevez Ok, Github issue #247, logs are posted :+1:


#66

I thought to remove my skybell_cache.pickle and restart HA and, voila, Skybell is working again… thanks!


#67

Skybell is working again… thanks!


#68

in your custom component just comment the line

from homeassistant.helpers.restore_state import async_get_last_state

and reload HA and should work fine


#69

“2018-12-13 22:07:38 ERROR (MainThread) [frontend.js.latest.201812110] http://192.168.1.155:8123/frontend_latest/b5032bfc47fcb9aa775a.chunk.js:2958:250261 TypeError: undefined is not an object (evaluating ‘this.config.name’)”

What I am missing here?


#70

Did you read the instructions in the release notes about how to migrate your old lovelace config to the new one?

For existing Lovelace testers


#71

I have the same error as @madrian
It’s happening with weather card in the classic UI.
I’m using a simple weather.darksky. It used to work great in 0.82 and 0.83.
Now (0.84.1), it doesn’t load and I have the following error in the console:

Uncaught TypeError: Cannot read property 'name' of undefined
    at HTMLElement.computeName (bf7146608f595468a214.chunk.js:3157)
    at runMethodEffect (app-0d042052.js:248)
    at Function._evaluateBinding (app-0d042052.js:248)
    at Object.runBindingEffect [as fn] (app-0d042052.js:248)
    at runEffectsForProperty (app-0d042052.js:248)
    at runEffects (app-0d042052.js:248)
    at HTMLElement._propagatePropertyChanges (app-0d042052.js:248)
    at HTMLElement._propertiesChanged (app-0d042052.js:248)
    at HTMLElement._flushProperties (app-0d042052.js:895)
    at HTMLElement._flushProperties (app-0d042052.js:248)

#72

Read the change log for lovelace:

Specifically, the the new way to config ‘name’

EDIT: Nevermind - I just saw you meant in the Classic UI…


#73

I’m getting this error repeat over and over again in the logs with 84.1. Anyone else seeing this?

2018-12-13 17:03:25 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection.139989782571608] Error handling message: {‘id’: 14606, ‘type’: ‘subscribe_events’}
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/websocket_api/connection.py”, line 66, in async_handle
handler(self.hass, self, schema(msg))
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/websocket_api/commands.py”, line 102, in handle_subscribe_events
if not connection.user.is_admin:


#74

Are you using appdaemon? Or another component that is still utilising an api password which has been depreciated?


#75

From the documentation it seems that the cloud webhooks are terminating TLS and reading all the messages, so it is quite interesting to see that you have implemented the same solution that you were criticizing yourself before :slight_smile:


#76

Edit: meant to reply above in the thread where the OwnTracks change BREAKS the front end and throws no log messages…

This is going to come off as a rant because I’ve spent the better part of an afternoon trying to figure out why my HA wasn’t even listening on 8123. I think that for most people even those that are fairly into HA, that expecting them to read all of the release notes, not just the blog post, is too much. There are so many components that reading through the entire notes every patch is a huge time sink. A simple configuration error like this should produce some sort of message in the logs. I had mine set to debug and combed through the entire thing and there is nothing at all . ARRRRRG.


#77

Thank you for the blind testing.


#78

Don’t understand the new tap_action command sintax. As Below gives error

       tap_action: 
          action: call-service
          service: cover.open_cover
          service_data: 
                entity_id: cover.car

#79

Yet you don’t show us the error. What is the point of your post?


#80

I tried this on a test system (hassio) and the process to migrate to lovelace editing in the UI worked as advertised. However when I tried to use the configure raw editor I made an error in the text I entered and now lovelace shows a blank screen. I’m able to use the ui-lovelace.yaml method by adding configuration to configuration.yaml but it appears the lovelace json file in .storage is corrupt and there doesn’t seem to be a way to reset it. Any thoughts or is this a bug/feature that’s needed?


#81

Where do you check the error? I have a red square in front end