1.5.0 Feedback

beta-testing
Tags: #<Tag:0x00007f1b9509ab48>

#187

Yep works fine in safari via the VPN and locally via app. Just won’t connect over VPN on the app. All other local resources are fine too over the VPN.

As I say, it is app specific as the VPN is fine and all resources available.

I am also aware that 192.168.x.x is a local non routable address - just paranoid I suppose and don’t like giving out my subnet :slight_smile:


#188

Interesting…

As a test, I just connected to my LAN from work via OpenVPN. In the iOS app I entered http://192.168.1.8:8123 (my server) and just like you, it did NOT work. I then copied and pasted that URL into my phone’s browser and it did connect.

So it does appear to be bug! I don’t normally use it that way - I have my HA instance exposed (behind a reverse proxy with certs), so I never saw it before…


#189

Thanks for testing it too. At least I am not going mad.

I have toyed with the reverse proxy idea, but I prefer to have all non VPN access locked out from my network. Call me paranoid :slight_smile:

I think there is a bug, as I put a local DNS entry in my Draytek router and again it is accessible by name in Safari and VPN, but not in the app. The VPN is definitely using my pihole DNS server as I have a few dummy addresses in it to test.


#190

I’ve just tested this out of curiosity while out and about and it’s working fine here?

I use OpenVPN to my router and have changed the URL connection to my LAN address. Default white theme was presented.


#191

I have used vpn with HA and the app from day 1 and never had any issue. I also only use the connection url field (not internal one).


#192

So strange!

I’ll check my VPN details on the router - there may be an obvious setting I am missing.

Thanks guys for checking :+1:

Edit: rechecked VPN and all seems good. Passing Netbios packets etc and all traffic set routed through the VPN. Definitely HA/iOS related as every other resource on my network is available with WiFi turned off and VPN turned on.


#193

I get this in the iOS app event viewer, but nothing in HA logs or on the router traffic logs. I get a feeling there is something in the app that if no WiFi is on it detects it as external.

For the guys that got it working are you using VPN through external WiFi?

EDIT: The above is true. I just set up a hotspot from my work phone and connected with my personal phone via WiFi. I then initiated the VPN and it worked fine. Basically if WiFi is not connected then the app takes it as external, regardless of the VPN.

Could this be changed?


#194

Do u have mobile data enabled on the app?


#195

OMG. OMG!

That is it. What a numpty I am :slight_smile:

Thanks @MrPappi!

Sorry everyone for wasting your time!!!


#196

Glad it worked out :slight_smile:


#197

This doesn’t explain it for me!


#198

I’m not sure if someone already mentioned it but I want to give my feedback:

For some reason the app on my iPad always asks me, if I want to turn on the location service.
When I say no, it asks me again.

When I say yes, it ask me to “Re-enable Location Access?”
Choosing “Re-enable” brings me to the privacy settings in wich everything is already turned on.
Choosing “Leave disable” it will ask me again and again and again.

Any idea what I’m doing wrong?
On the iPhone version I was able to turn on motion, since it’s available on the iPhone.

Also for some reason I’m getting “Login attempt failed” notifications from time to time.
I’m using only the new way for authentication. Looking into the tokens, I can see that my iPhone got:

https://home-assistant.io/iOS

The iPad on the other hand got

https://my-domain.duckdns.org:8123

not sure if that is related to the problem.


#199

:crossed_fingers:


#200

Well done @robbiet480 and @blackgold9 and anyone else I didn’t know about/mention.


#201

Just downloaded and wow the improvement in speed when I open it is noticeable. Just sitting here closing and opening again :smile: Great work!


#202

Have you actually gotten the iOS app to work with basic auth? I attempt to save the connection and I get prompted for the basic auth credentials, then the HASS credentials. I provide both and then get kicked back to the Settings screen with a “incorrect password” error.


#203

As others have said - you shouldn’t be using basic auth…


#204

Is anyone else seeing this in the HA log:

2019-01-15 17:00:19 WARNING (MainThread) [homeassistant.components.http.auth] You need to use a bearer token to access /api/ios/identify from 10.1.1.1
2019-01-15 17:00:26 WARNING (MainThread) [homeassistant.components.http.auth] You need to use a bearer token to access /api/services/device_tracker/see from 10.1.1.1

I am using the beta app and not using legacy auth on any of my devices.


#205

1.5 was released today…


#206

Sounded like that advice was for the people that didn’t realize basic auto was different than HA auth. I’m trying to use basic auth to add another layer of authentication at my perimeter.

My question stands; has anyone gotten the basic auth functionality to work in the newest iOS app release?