1.5.0 Feedback

beta-testing
Tags: #<Tag:0x00007f1baa8f1c50>

#166

I reverted to v30 and there the location updates (gps) are working fine and show correctly in HA. So after v31 something has changed related to this which caused the updates not to be shown in HA.


#167

Reverting back to v30 fixed it for me as well (v31 had the same problem as v32).


#168

Any plan for an update of the public version?


#170

it’s an iOS ‘feature’


#171

Sorry, I’m new in iOS, where I can find information about it? Or maybe the name of this feature?


#172

It will be released once it is ready for prime time.


#173

Apple KB probably or iOS manual.


#174

This link might help explain it.


#175

I recall reading that with iOS 12 it will be possible to have “emergency” notifications that can penetrate mute/DND, and that it was planned to implement this in the HA app. Did that happen in this version? Or is that still a future thing?

I have a problem I’m trying to solve because of the inability to pierce Apple’s mute/DND, and having this in the HA iOS app would make things much, much, easier… I’m working on some circuitous workarounds that could just be eliminated.

Thanks.


#176

The feature you’re referring to is Critical Alerts in iOS 12. I think this feature for the iOS Home-Assistant app will be released after v1.5.0.

More details here


#177

Just a quick question - I have read the thread and can’t find the answer, so apologies if I have missed it.

My HA (not hass.io) 0.84.6 is not exposed to the internet in anyway. I connect to it externally via a VPN to my router on my iPhone. The webpage works great through the VPN, but the iOS app won’t connect at all. Is this by design?

Thanks


#178

Not sure if it’s been reported or not, but the “iOS Components” show as X (not loaded) on the beta client.


#179

I have tick marks next to all three. You may have a configuration problem.


#180

Try hard exiting the app and then running it again… it will then show ticks.


#181

Thanks, that worked. Specifically the power off screen-home button holding method. Simply swiping up did not work, which I had already tried.


#182

What are you using for the connection URL? Is it the internal IP address of your HA server?

If you’re using a hostname, that might not resolve over the VPN. Try using the IP address while connected to the VPN.


#183

Tried a couple of things - IP address in external, internal and both and even put a DNS forwarder on LAN of MarkHA.co.uk that works internally and externally on the webpage in safari, but not in the app.


#184

Don’t do the “use internal URL” setting. Just use the 192.168.x.x. address of your internal server.


#185

Same :frowning:

I think there must be something in the app that ignores the VPN and uses the cellular connection?


#186

It can’t ignore the VPN :slight_smile: That would defeat the whole purpose of the VPN.

So that exact same URL works when you are on your home net? And that exact same URL works over VPN via your browser via the VPN?

Edit: You don’t need to obscure the 192.168.x.x addresses - they are private, no routable addresses usable from your LAN behind your router only.