1.5.0 Feedback

beta-testing
Tags: #<Tag:0x00007f2042ea2090>

#207

For me version 1.5 it does not work anymore with lovelace custom cards.
(FIXED… it was unpkg prstrong textoblem)

Also…i cannot access local instance because i’m using duckdns ssl. With previous version it was working fine.


#208

I’m also having the issue where it doesn’t seem to track my location unless I “fire a one shot”

As it happens…I’m on an iPhone 6s…


#209

My location is updating perfectly on an iPhone 8s, where as on an iPhone 6s the background fetch is never fired where as some other events (like significant location update) are fired. Because of this zones enter/leave doesn’t work reliability.

No idea why.

Same app version (tried with the latest beta and the current new app store release 1.5.0), same settings.


#210

Great News! So if we were running the beta, do we need to uninstall it, and then go to the apple store to get the GA code?


#211

Just go to apple store and download new one and it will overwrite the beta


#212

Thanks! That was just too easy.


#213

My iphone app also keeps swapping out my address on the login page for

https://home-assistant.io/iOS

I never get prompted for a username and passwork. It just says “please wait”.
After a few seconds I get an error message

Error: invalid client id or redirect uri


#214

Looking at the change log in the iOS App Store, it actually says “support basic authentication on the UI only”… so maybe this version just has the option there, but the code to make it work isn’t in the 1.5 release? @balloob is that accurate?


#215

Same here. Other clients (browsers on PC and phone) have no problem working, as they seem to pass a valid redirect uri. But the new iOS app won’t work, just the way you describe, and there’s no way to change anything.


#216

I thought that maybe it was an issue with me being on iOS 11 but it still doesn’t work after upgrading. I also tried using trusted networks but got the same redirect URI error.


#217

I don’t understand the problem… The app uses the new auth and you should not use the advanced settings… everything under advanced settings should be switched off. ‘Basic Auth’ is a specific thing for something like NGINX that requires a basic auth login - it is nothing to do with Home Assistant.

The ONLY thing you need to do is to use the URL of your HA including the port if you use that. Then you click validate and save and it should ask for your HA login in a normal HA screen.

If this isn’t working, try resetting the app… down the bottom of the settings screen. You also might find that you will have crosses instead of ticks on the settings screen even after auth… just force close the app and reload if that happens.


#218

Thank you, David.

I am not trying to use basic auth. I have read your previous comments and made sure to only enter the URL, https://my-site.duckdns.org:8123, and port only, leaving the advanced settings unchecked.

After clicking “Validate and Save” I never get prompted for a username and password. It simply tells me “Please Wait” and then a few seconds later give me the Error: invalid client id or redirect uri in red. I have tried force closing as well as uninstalling and reinstalling the app. I have never gotten valid credentials so I do not see the option to “reset the app”.

My home assistant info is as follows:

boot: true
custom: false
image: homeassistant/raspberrypi3-homeassistant
last_version: 0.85.1
machine: raspberrypi3
port: 8123
ssl: true
version: 0.85.1
wait_boot: 600
watchdog: true

Here are screenshots of the app authorization page after hitting “Validate and Save Connection Settings”

I originally did not have any authentication types set in my config. I added the Trusted Networks and HomeAssistant types as another method to test but that gave me the same error. I think the issue comes from the https://home-assistant.io/iOS that somehow gets appended to the url. I don’t know if the is something with 0.85.1 or with the updated app. I can login just fine if I manually type the url and port into safari. But if I click the open in safari button the bottom of the authentication page, the login will fail.

Thank you for your help.


#219

Yeah the info we’re about to give https://home-assistant.io/iOS access is totally wrong…

What does it auto-detect as your home assistant instance in the config screen?
You deleted the app and redownloaded it? The official one, not a beta?


#220

Like gnomesoup, I am also not using any advanced settings. I have the same problem that presents the same way.

I’m wondering if it’s got anything to do with my HA instance running in a Docker container behind the Docker bridge network. Does the iOD app’s discovery of the HA server require more than just port 8123 to be opened? Is there something else about a Docker install or that networking configuration that might cause this issue?


#221

I figured out the issue and it has nothing to do with the app. Sorry for all the trouble.

I had the Hassio DNSmasq addon up and running. This apparently was keeping home assistant from being able to resolve addresses. I believe this explains the error related to https://home-assistant.io/iOS. Once I stopped the addon and setup a dnsmasq on an a different computer, things are working as advertised.

I did have to manually turn on “Home Assistant iOS” in integrations to get the check boxes to show up. My session did not auto discover the iOS component automatically even though I have discovery turned on.

Thank you for all your help!


#222

@Kazakaz @milosm are you still having problems with your iPhone 6s and location tracking? I am. No response here regards the issue as far as I can see unless I’m looking in the wrong place?


#223

With the 6s I’ve noticed it still never says that a location update was from a background fetch, but I have also noticed that actions triggered from zone changes (enter/leave) do get triggered for the most part, but not as accurately as on my iPhone 8.


#224

@robbiet480 , i think there was an iBeacon bug introduced between 32 -> 34, which is also showing up in the 1.5 release. There are a few more details in this thread.

What are your thoughts?


#225

It specifically says beacon exit was removed


#226

I suspect the issue is with the enter events. From what i can see … the 1.5 app is detecting the ibeacon and start to trigger an update … but then checks against the DB and determines that the status is correct and doesn’t need to send one. Some part of the checking logic is not right because the status is ‘not_home’ and if it sees a beacon it should flip. v32 worked fine.