2021.8.0: Feel the energy ⚡️

copying in @Danielhiversen for any insights. Much appreciated, and thank you!

that’s a very cool setup. Can you share your settings (hardware/software)

For solar forecasts, it appears Solcast has data that covers Australia (didn’t check NZ…). There is no built in integration for them yet, but you could roll your own if you’re feeling adventurous. It looks like they have a free tier that can do ~10 queries per day, which could be enough to be helpful

1 Like

Hi Markus, I am facing the same issue. Unfortunately the custom integration isn’t supported anymore. Anyways I wanted to switch to modbus integration of the Kostal Plenticore inverter. For now I started testing how the setup would look like, so I still need this custom integration.
Meanwhile there is official support for kostal build into HA Kostal Plenticore Solar Inverter - Home Assistant. But my guess it will have other entity names and this would require to rework my Grafana dashboard based on the entities.
I had a quick check and already saw that in HAs const.py e.g. ELECTRICAL_CURRENT_AMPERE has been changed to ELECTRIC_CURRENT_AMPERE. Maybe it’s possible to fiy it in the custom integration.


Why did you reply on my message? I was stating that the release notes had a wrong link :stuck_out_tongue:

Either since updating to 2021.8.2 (and adding the template: to my packages) or since adding the cost and compensation entities to recorder I see the processor ram go above 85. I’ve never seen alerts for this in the 4 years using Ha… and the instance locks and needs rebooting daily.

Anyone else seeing this?

Markus, please have a look at Integration not working anymore after HA update to 2021.8.4 · Issue #26 · ITTV-tools/homeassistant-kostalplenticore · GitHub where I described the required changes in the const.py file of the homeassistant-kostalplenticore integration. It worked fine for me, the entities are available again.

My Shelly’s are timing out i add unicast to see if solved but they keep lossing connection

Logger: homeassistant.components.shelly.entity
Source: components/shelly/entity.py:255
Integration: Shelly
First occurred: 4:07:25 AM (19 occurrences)
Last logged: 4:19:48 AM

Setting state for entity Casa - Luz Cocina failed, state: {'turn': 'off'}, error: TimeoutError()
Setting state for entity Casa - Luz Cocina 2 failed, state: {'turn': 'off'}, error: TimeoutError()

Also TP-Link
i do had my HS300 as strips with IP address on config

Logger: homeassistant.components.tplink
Source: helpers/update_coordinator.py:219
Integration: TP-Link Kasa Smart (documentation, issues)
First occurred: 4:07:21 AM (9 occurrences)
Last logged: 4:19:32 AM

Error fetching Alita 2 Finnex data: Communication error
Error fetching Alita Nano Led data: Communication error
Error fetching Alita Air Pump data: Communication error
Error fetching Alita 2 Plug 2 data: Communication error
Error fetching Alita 2 Heater data: Communication error

Also Supervisor is suddenly looks like it lose the network

Source: components/hassio/websocket_api.py:109
Integration: Home Assistant Supervisor (documentation, issues)
First occurred: 4:10:48 AM (9 occurrences)
Last logged: 4:10:48 AM

Failed to to call /network/info -
Failed to to call /resolution/info -
Failed to to call /os/info -
Failed to to call /addons -
Failed to to call /store -`

Something seems broken on logbook card. Custom entries created with logbook.log service no longer appear in this card.

So first, is the Energy Meter Energy entity kWh value increasing hourly (~15mins after the hour)?

If it is, the cost for that hour should be calculated and added to total so far. So in your case it should calculate 25cNZ x energy used in the last hour and add it to $0 (in your case).

Not knowing how/where your Energy Meter Energy entity data is coming from… can’t help much more.

Very neat but as that is a smart meter do you not have access to the data ? Not sure where you are but in the UK I have one of these 3rd party IHD’s and you can get your data via MQTT from them straight into HA


1 Like

I’m with PurePlanet and I’m not sure they have even heard of IHD’s :grin:
I’ve reached out to them, but I don’t hold out much hope. Also wanted it working NOW so went for the easy route of doing it myself :rofl::rofl:

Been running an emonPi Energy Monitor from openenergy.org for a few years now.
Using eMonCMS input process steps, I create grid import (peak and off-peak) feeds, and export feeds. It also logs data feed for my solar generation.
From HA I just bring in all these feeds using The Emoncms integration.

If you have a smart meter you usually get an In House Display (IHD) that connects direct to your meters via Zigbee. This locked IHD only gives you the data on the supplied display whereas the one I listed is a 3rd party one that has API access to the data via their free MQTT feed.

They don’t have any in stock at the moment but are expecting some soon. You will need a Smets2 version as your meter is Smets2.

1 Like

Thanks will have a look, though not sure we can get that device here.

Just curious as to whether anyone else has had the issue with the 2021.8.X versions that I am having. The issue is as follows. I receive an error message indicating that HomeKit is unable to create an accessory for my SimpliSafe alarm control panel. Everything worked fine with the 2021.7.4 version. Here is the exact message:

Logger: homeassistant.components.homekit
Source: components/homekit/accessories.py:249
Integration: HomeKit (documentation, issues)
First occurred: 10:50:38 AM (1 occurrences)
Last logged: 10:50:38 AM

Failed to create a HomeKit accessory for alarm_control_panel.[REDACTED]_alarm_control_panel
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/homekit/__init__.py", line 628, in add_bridge_accessory
    acc = get_accessory(self.hass, self.driver, state, aid, conf)
  File "/usr/src/homeassistant/homeassistant/components/homekit/accessories.py", line 206, in get_accessory
    return TYPES[a_type](hass, driver, name, state.entity_id, aid, config)
  File "/usr/src/homeassistant/homeassistant/components/homekit/type_security_systems.py", line 87, in __init__
    super().__init__(*args, category=CATEGORY_ALARM_SYSTEM)
  File "/usr/src/homeassistant/homeassistant/components/homekit/accessories.py", line 249, in __init__
TypeError: 'int' object is not subscriptable

I’m getting a catastrophic error when I attempt to update.
Pre-Update Core: core-2021.7.3
Supervisor: supervisor-2021.06.8
Hosted in an Oracle VirtualBox VM

After attempting to update to core-2021.8.4, my home-assistant.log starts filling with entries like this:

2021-08-09 07:41:17 ERROR (MainThread) [zigpy.appdb] SQLite database file is corrupted!
*** in database main ***
On tree page 91702 cell 46: Rowid 4447004 out of order
On tree page 91702 cell 42: Rowid 4447000 out of order
{{ Many more of these types of errors }}

2021-08-09 07:41:17 WARNING (MainThread) [zigpy.appdb] Failed to migrate row attributes(00:0d:6f:00:04:a8:87:a3, 1, 2820, 1291, 14): UNIQUE constraint failed: attributes_cache_v5.ieee, attributes_cache_v5.endpoint_id, attributes_cache_v5.cluster, attributes_cache_v5.attrid
2021-08-09 07:41:17 WARNING (MainThread) [zigpy.appdb] Failed to migrate row attributes(f0:d1:b8:00:00:05:e4:e1, 1, 8, 0, 9): UNIQUE constraint failed: attributes_cache_v5.ieee, attributes_cache_v5.endpoint_id, attributes_cache_v5.cluster, attributes_cache_v5.attrid
{{ Many more of these types of errors }}

The log grows to more than 100 MB in the first couple of minutes and never fully loads properly - it seems to hang on the Zigby startup. Just to be clear, this does not occur in core-2021.7.3. I am able to restart the VM / Supervisor without any issues. This only happens when I attempt to update to the latest and greatest. I’m open to any suggestions to get around this for the latest update. Thanks!

The breaking changes mention that attributes will now be separate sensors.

There haven’t been any noteworthy changes in that integration, a few translation changes and 1 line of code that changed a list to a tuple on a for loop. Last noteworthy change I see is an update to the dependencies delivered in version 2021.6.

Yes. Saw that. And was able to finde all the entities (former attributes, beside the two. The question was and is, where these attributes are now.


There are no corresponding entities and the port switches are gone as well