2022.10: All over the place

One thing I am having issues with is getting devices moved from the bluetooth plugged into my home assistant server to a bluetooth proxy. I tried deleting it and bringing it back online but no dice. I am not sure if that is because my ESPHome hasn’t updated to 2022.10 or if I am doing it wrong. One of my locks is on the other side of the house so using a WiFi proxy should give it a better connection? I guess I wish it was easier to tell what proxy is adopting it?

O I have re-designed my dashboards around Buttons and Subviews now… It is a real game changer on mobile.

Funny thing is that even with the extra taps everything seems faster and more responsive as there are fewer data driven widgets per view, my initial dashboard is mostly buttons and loads MUCH faster now.

Now if we only had some more customization options for the headers like auto hide etc… Still take up too much space on mobile.

Regarding headers. I use this HACS frontend part. Works perfectly for removeing the top header.


camera.record broken after update to 2022.10.3

After Updating the recording isn’t working anymore.
Start to record →
TEST.mp4.tmp gets created with a filesize > 0KB →
after a while TEST.mp4 gets created with a filesize of 0KB

The .tmp file has the video, which I can play.
The.mp4 file is empty.

The log gives the follwing error:

2022-10-13 19:05:33.422 ERROR (MainThread) [homeassistant.core] Error executing service: <ServiceCall camera.record (c:01GF94XGE0DC1480XYGS9MRPG3): duration=10, filename=Template("/config/www/TEST.mp4"), entity_id=['camera.dafang_1_generic'], lookback=0>
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/core.py", line 1756, in catch_exceptions
    await coro_or_task
  File "/usr/src/homeassistant/homeassistant/core.py", line 1775, in _execute_service
    await cast(Callable[[ServiceCall], Awaitable[None]], handler.job.target)(
  File "/usr/src/homeassistant/homeassistant/helpers/entity_component.py", line 207, in handle_service
    await service.entity_service_call(
  File "/usr/src/homeassistant/homeassistant/helpers/service.py", line 678, in entity_service_call
    future.result()  # pop exception if have
  File "/usr/src/homeassistant/homeassistant/helpers/entity.py", line 931, in async_request_call
    await coro
  File "/usr/src/homeassistant/homeassistant/helpers/service.py", line 715, in _handle_entity_call
    await result
  File "/usr/src/homeassistant/homeassistant/components/camera/__init__.py", line 981, in async_handle_record_service
    await stream.async_record(
  File "/usr/src/homeassistant/homeassistant/components/stream/__init__.py", line 528, in async_record
    await recorder.async_record()
  File "/usr/src/homeassistant/homeassistant/components/stream/recorder.py", line 199, in async_record
    await self._hass.async_add_executor_job(
  File "/usr/local/lib/python3.10/concurrent/futures/thread.py", line 58, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/stream/recorder.py", line 177, in finish_writing
  File "/usr/src/homeassistant/homeassistant/components/stream/recorder.py", line 157, in write_transform_matrix_and_rename
    read_init(in_file), self.stream_settings.orientation
  File "/usr/src/homeassistant/homeassistant/components/stream/fmp4utils.py", line 149, in read_init
    return bytes_io.read(24 + moov_len)

It worked before updating to 2022.10.3 & OS 9.2

My system:
Home Assistant 2022.10.3
Supervisor 2022.10.0
Operating System 9.2

Kindly create a github issue for it :slight_smile:


Try this.

or this (this is simplier, and it worked for me)

I see similar behavior for a Tesla Model 3 being detected as an iBeacon, very nice! But not so nice i have a lot of entries now which are similar but keep changing

i am having a strange issue, under the integrations tab, any zha config turns out to “Error while loading page dashboard”. other config tabs do nothing…I cleared the cache … but to no avail.

Ooooh must try putting a bluetooth proxy in my garage.

Without sharing details about yours, how do you recognize it as a tesla, or yours? I’m still trying to find my M3

Mainly the timing of the away/home status is my way of identifiying. But I’ve also seen a similar identifier before when scanning for bluetooth. This is the format I see: S60x0x0x0x0x0x0x0x 0x0x

1 Like

If you’re in the UK, the standard and the plus versions are on sale at Amazon at ~£13 with a voucher. I have one of these (paid £19.99 from Switchbot) and they were discovered as soon as I put the batteries in


having played with the new sub-views, I am a bit confused whether I have the correct approach. Using yaml mode, I want my sub-views in a dedicated folder and link to them from variuous dashboards.

Apparently, since they are actually Views, they need to be in a dashboard (of their own, in my wish to have them all together). Config for that:

# need this 'fake' view to be able to list them in a 'repository of subviews, and link to
# them from other subviews in YAML mode
      mode: yaml
      filename: dashboard/dashboards/ui-sub-views.yaml
      title: Sub views
      icon: mdi:subtitles
      require_admin: true
      show_in_sidebar: false

and the lovelace dashboard:

views: #!include_dir_merge_list ui-sub-views

  - !include ui-sub-views/subview_Marijn.yaml
  - !include ui-sub-views/subview_energieprijzen.yaml
  - etcetc

the dir_merge_list didnt work. had to verbosely list them as posted above.

It would be much better if we could simply include those subviews like any other linkable yaml Frontend config. And have them in a folder of or liking, at least not requiring it to be a ui- folder, and configure it like that.

Is this the only way, or am I missing out on something. The docs are awfully lacking info on this, and before I suggest a better text, need to understand better.
thanks for having a look

I just ordered 2 before seeing your post, so very pleased to see your post and know that they are P&P. :slightly_smiling_face:

I have the same problem as you and for now I solved it by installing in Node-red node-red-contrib-netatmo, still the lag remains, but at least the presets work

with 2022.10.1 appear error “Component error: mqtt - No module named ‘numpy’” but i can’t see any breaking changes about mqtt.
Why it happens?
Thank you

Does it still work?

Did you ever get a response on this? I’m not a fan of the rounded corners either, to be honest.

Honestly, I’d rather be able to edit the automations where they are, instead of migrating them to the automations.yaml file.

Anyone finding the switchbot going unavailable every day?

I have to reload the switchbot Intergration daily.

Using Bluetooth proxy