2022.3: Select and play media

Last release, there was a note about changes to Zones, where the state of the zone would be the number of device trackers in that Zone. That change seems to have been pulled, though. Is that still in the roadmap somewhere? That would really simplify my presence automations.

2 Likes

No me neither… gonna check it out tomorrow… but if you have a solution / fix… please share :stuck_out_tongue:

When using the RSTPtoWebRTC integration and RTSPtoWebRTC Add-On in version 2022.3
my cameras not show up in “Media>Camera Folder” but gives message incompatible items hidden instead.

UPDATE: it gives the same message if I disable RTSPto WebRTC, so looks like it just not recognize Google NEST cameras

1 Like

New theme variables for input selects:

/* input components */
      --input-idle-line-color: rgba(0, 0, 0, 0.42);
      --input-hover-line-color: rgba(0, 0, 0, 0.87);
      --input-disabled-line-color: rgba(0, 0, 0, 0.06);
      --input-outlined-idle-border-color: rgba(0, 0, 0, 0.38);
      --input-outlined-hover-border-color: rgba(0, 0, 0, 0.87);
      --input-outlined-disabled-border-color: rgba(0, 0, 0, 0.06);
      --input-fill-color: rgb(245, 245, 245);
      --input-disabled-fill-color: rgb(250, 250, 250);
      --input-ink-color: rgba(0, 0, 0, 0.87);
      --input-label-ink-color: rgba(0, 0, 0, 0.6);
      --input-disabled-ink-color: rgba(0, 0, 0, 0.37);
      --input-dropdown-icon-color: rgba(0, 0, 0, 0.54);
10 Likes

After upgrade to 2022.3.0 I get these in my log every time I restart HA

Setup of cover platform mqtt is taking over 10 seconds.

00:06:52 – (WARNING) Cover

Setup of light platform mqtt is taking over 10 seconds.

00:06:51 – (WARNING) Light

Setup of switch platform mqtt is taking over 10 seconds.

00:06:49 – (WARNING) Switch

And I can see in the info that MQTT integration takes 90 seconds to start. That makes no sense. MQTT is normally up quickly. I run a Mosquitto on a different server and I have checked that it runs normal and fast and the server has a low load. There is something rotten during init.

Once started there is no lag or other problems with anything related to my MQTT devices. I have the feeling the timer for the MQTT starts and then HA does other things with other integrations and then comes back to MQTT. I doubt it is really MQTT that hangs for 90 seconds.

Update: The issue seemed to be fixed in the first 2022.3.1 update. Thanks for that

Where should I report an issue with the update. All of my media player displays are now “broken” it looks like the source drop down selector is “leaking” out of the bottom of the display. It’s a Sonos Play 5 speaker.

There is a beta release for the mini-media-player that fixes this. You can enable beta downloads for the card in HACS, install it manually or wait a day or so for a new release.

I’m running the mini-media-player beta, it’s stable and fixes the issue.

Untitled

2 Likes

Ah, the lists and pickers FINALLY work well on iOS… For me the biggest deal of this release. It was a buggy mess since the beginning.

And the inline entity autocomplete, OMG!!
Thank you!

Do I have to enable Beta Versions somewhere else first, because I looked a few places and didn’t see it

Never mind I found it, that fixed the problem thanks.

1 Like

EDIT: New topic created:

Ok - liked the idea of this one until I loaded my main Lovelace page:

Screen Shot 2022-03-03 at 12.26.10

If a switch was defined as a light For MQTT lights - instead of the toggle button I now get a “power” selector which doesn’t even reflect the current state. Rolling back until I sort this out.

2 Likes

The same happens on my system. Mac mini Home assistant running under VirtualBox.

The old WIZ Integration from GitHub (still) works fine after the latest HA 2022.3 update. The new integrated WIZ Integration gives me this error:

Config flow could not be loaded: [object Object]

What now?

can someone confirm if the AdvantageAir integration is still broken in this update?

@frenck thank you

2 things:

  1. It looks like TTS was removed from media cards from lovelace overview (I used to use this to communicate with family members - worked great - now directs me to use the media tool). Hopefully we can bring back at some point.

  2. In the media tool I can input text but the speaker in bottom right only exposes “web browser” vs my HomeKit media players or Denon media players. So because of #1 I have lost ability to use text to speech adhoc. I was directed to file an issue/feature request.

1 Like

This appears to be a UI feature associated with MQTT Lights (I am not sure if affects switches - I don’t have any handy).

The lightning bolt symbol displays on startup and I think is because the state is “unknown” - similar to the binary sensor change last update.

Changing state by clicking on the lightning bolt will then change it to the toggle button.

I will have to go through and see if all my retain flags are set appropriately.

Please open an issue here:

The important parts are your Denon and Homekit media players not showing up as media sources.

same here but for frigate and media that I uploaded through VScode. There’s no errors in my log which is weird

EDIT: It filters out pictures for something like a google home mini which has no screen so this incompatible warning makes sense.

1 Like

The new MWC looks awful. My input_select entities now have large visible light gray boxes around them and aren’t styled by the theme. I used to have two input_select entities side by side in using a type: glance, but now those boxes are too wide to sit next to each other. Similarly, the text fields for the filters on the “Current entities” page are now black (on a dark theme, so nearly unreadable). The “x” box that used to let you clear a filter is gone.

1 Like
1 Like

Since update 2022.3 the sensibo component is broken. In the thermostat card if I want to increase or reduce setpoint, the increment is by 6 oC. Before update it was by 1 oC

To put it another way, some media devices show TTS via the media page, some don’t.

Does: Kodi, Chromecast

Does not: Squeezebox (LMS)