2022.8: You can fix it!

Anyone else with LIFX out there ? My bulbs are being discovered under HomeKit Controller integration, not something I have.

Any ideas? Is it safe to click IGNORE?

1 Like

Yes it’s safe but you may not want to. The Home Assistant Homekit connection to your Lifx bulbs will be local push. The Lifx integration is local polling. Push is better than polling.

One reason to keep the Lifx integration connection is that it supports the lifx.set_state service which works even when the light is off. If you don’t use this, go with Homekit.

Edit: also Homekit does not support the lifx effects services though these can be replaced with scripts that have variables passed to them (entity_id, cycles, colour, etc). However there is no way to set the infra-red intensity of security lights using Homekit.

1 Like

See the section HomeKit Accessory Protocol

1 Like

Thanks - makes sense now.

I assume if you do this:

It is possible to set up control of the device in Home Assistant using both protocols simultaneously by configuring both the LIFX integration and the HomeKit Controller integration for the same device.

Then you don’t get the “significantly less network traffic.”

Thanks Tom - I’ll ignore until another day. I have 12 foot ceilings and the last thing I want to do is start unscrewing all my LIFX bulbs to read the HK number on them. I just did a floor lamp and the advantages make it seem worthwhile - but not right now :slight_smile:

Yeah likewise. I also have made extensive use of the lifx.set_state service which I would have to workaround somehow.

Same here, custom switches don’t work after the upgrade.

Ok, thanks for sharing the info. I’ll think I’ll revert also. Damn!

Edit: it seems to be already reported

The new Bluetooth integration has rekindled a discussion in my head…

I have a few Xiaomi BLE devices; e.g. temp and humidity sensors I’m currently using via “BLE to MQTT gateways” running on ESP32 devices throughout the house. It works like this:

Xiaomi sensor ------> BLE ------> ESP32 ------> MQTT ------> HA

With the new integration and a long range BT adapter would I be able to directly discover/setup tthese sensors directly in HA; i.e.?

Xiaomi sensor ------> BLE ------> HA

Regarding range, most of the long range BT adapters advertise 100m in open space. With the size of the house I get to any device within 50m between HA and the sensor. However I’d assume most BT devices still work within the 10m range. Could this work or am I restricted to the 10m range of the device? I’m only considering this if I can remove the various ESP32s around the house which don’t do anything else

Thanks for the help. Now I’ve gotten an eve motion, 2 eve energy outlets, and an eve room sensor to pair, but there are 2 eve weather sensors and 1 eve energy that still wont pair and keep giving me the same two errors in my logs. I noticed that the devices I’m still having trouble with have a black house on their homekit code stickers, whereas all the eve devices I’ve paired so far have a white house. Could there be a problem with the older generation devices (I think the black house is the older one anyway)?

I have 3 of the eve energy devices. One is older and two are newer that both pair. These devices take the longest to pair out of all of them so it might just be taking too longer. I’m working on a PR to speed it up here: https://github.com/Jc2k/aiohomekit/pull/130

I don’t have an eve weather, but I ordered one and will see if I can get it to pair.

The new map colours are far better than before but as I use dark mode for the UI and always used the dark_mode: false tag to display the map card in light mode, this is no longer working. Had a look around but found no answer, am I missing something?

type: map
entities:
  - entity: person.xx
  - entity: person.xxx
title: Where are We
hours_to_show: 12
default_zoom: 16
dark_mode: false

There is smth strange about “dark_mode” option.

so woke up this morning after doing the update last night to icloud intergration showing no devices, removed it and rebooted ha os and added again, no auth pop up and no devices added log reads

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 281, in _async_setup_platform
    await asyncio.shield(task)
  File "/usr/src/homeassistant/homeassistant/components/icloud/sensor.py", line 31, in async_setup_entry
    account.listeners.append(
AttributeError: 'IcloudAccount' object has no attribute 'listeners'

I just realized I have an ipad and an apple tv that might be interfering somehow. I’m going to try again tomorrow with those devices powered down. If you’re located in the US, I can just send you one of my eve weather’s

Hi,

Is it just me or is the icloud integration broken in this update? The location of the devices is unavailable since this update is installed.

For the rest: great update again! Thanks for all the hard work.

Hello! As i have installed the new update, the broadlink integration was broken. I have tried to roll back, but the backup page is just empty. Any ideas?

Any one else having trouble starting Node-Red since the update?

Yes, I noticed it was stopped and I had to uninstall and re-install the add-on as pressing start would not do anything.

I also had to do the same with Adguard add-on