2022.9: Home Assistant Birthday Release!

Hm ok it sounds like something isn’t working correctly then. Can you make a bug here with your details? It’s not actually related to core so better to dig in over there.

Love it that there is a schedule assistant! However it would be nice to have a short example in the schedule documentation on how to use the schedule entity as a trigger to start and to stop or change a heater for example. For most of the 500,000 people that are not daily programming HA that would be really useful.


The schedule entity changes to true when the schedule starts, and to false when it ends. So a really normal automation based on state.

I don’t know why this crap of disable automation instead of slider has been introduced. It’s just like Google Pixel update of Internet selection as two step process assuming everyone would have Wifi on by default.

Why some developers think what they think is what everyones need is.
Honestly, I hate the removal of slider.


Out of curiosity, what sort of automations do you have that trigger so frequently?


Which slider are you referring to?


Thanks Robert,

I had a quick chat with Chipolo support and they confirmed the tags and the cards have fixed BLE MAC address - thanks for the pointer, much appreciated.

So that means you could use the new BLE device tracker to know if the tag was within range of the HA instance.

I guess your usercase is to know if the tag/card is actually within range of your phone? Not just to track the tag.

Of course if you were just wanting to know if your phone was within range of your HA instance, and as you already use the HA Companion app, you could just use its in built BLE beacon.

And yes, I already use WiFi to track my phone, I use the PING integration as my tracked phones are configured to have a fixed IP address.
In fact the ping returns a “home” state far quicker than the old bluetooth tracker does.

Again thanks for your input.

For me, Switchbot Curtain has not been working ever since Home Assistant released their Bluetooth integration and official Switchbot integration with 2022.8? Before that, with unofficial (HACS?) integration, everything has been working just fine. I guess that integration is not anymore available? Because I would gladly switch back, as although we have received upgrades to Bluetooth and Switchbot, it still doesn’t work but randomly. And I guess it’s because my Switchbot curtains are very often unavailable. They are maybe 4 meters away from my Raspberry, so there should not be any connection issues, but there is:

See all those grey lines? That’s when my Switchbot Curtain has been unavailable. I have an automation that opens my curtain at sunrise, and closes them at sunset, and usually opening at sunrise works, but closing at sunset does not, and it’s maybe because my devices are more often unavailable during evening.

And like I said, the unofficial switchbot integration worked like a charm, every time. And I haven’t moved my raspberry (where my HA is installed) OR Switchbots.

This is fixed in ShellyForHass 1.0.2

Same here. There is an error in de log for each attempt to load a dashbord:

https://…my nabucasa FQDN here…nabu.casa/frontend_latest/08219b6a.js:362:5549 Uncaught TypeError:Cannot read properties of undefined (reading ‘1’)

GUI->Settings->System->Hardware … I have this working. Nice!

Perhaps off topic, I just happen to notice that GUI->Settings->System->Storage is missing from a venv HA Core version I’m running. I’m not using default_config but I can’t seem to figure out that that’s the cause or if it is something else. Any ideas?


I am replying to my earlier post, to update my understanding of the bluetooth_tracker and whether it is likely to be fixed soon as many people hope.

Short answer - don’t hold your breath!

I wish I had researched this earlier because I wouldn’t have been patiently stuck on 2022.6.7 and waiting with blind faith that this would be fixed.

We were informed, in the 2022.7.x release notes’ breaking changes that bluetooth_tracker would break, and the suggested solution was to use Bleak as the bluetooth stack.
This was also reiterated by Frenck in the open issue raised on Github.


And in particular this:
Where Bleak is stated as being the solution.

However as Kevdliu pointed out in the same open issue, Bleak does not support Classic Bluetooth.
In fact, if you look at the Bleak webpage
bleak — bleak 0.17.0a1 documentation
it says that BLEAK is an acronym for Bluetooth Low Energy Active Klients.

So this means that Bleak is not a solution even though we are told that it is!!
Therefore all those who have added their voices to requesting a quick fix should maybe lower their expectations. As I have done.
I wish I had looked into this earlier and not wasted 2 months.
Hopefully we can we get a realistic timeframe on a new working integration or an update on any work being done. Or just any response! :slight_smile:


From an above post, you can check the status of the build on Github:

EDIT: And I just successfully pulled the image and am running 2022.9.2.

Also wondering what adopt was for. I adopted all 3 of mine but I don’t know if I should have don’t that. It’s not picking up any of my 3 SwitchBot bots unless I bring them close to my actual raspberry pi even if there are next to one of my new Esp32 devices.

Why are you disabling automations so often? Seems odd.

Regardless if there are particular automations you disable and re-enable manually a lot you can just put those in a dashboard. If you include automations in the UI in an entities card they still show up with a toggle.

1 Like

Got it working with the v3.8 update for my LYWSD03MMC. Thanks @solyxius and @Edwin_D.

I had these installed more than a year ago (no idea what version of ATC). Connected to them via the telelink flasher, installed v3.8 and set the advertising protocol to BTHome and they started to appear in the devices & services section :slight_smile:

Haven’t tried the plant sensors yet but this is a good start.

However I would still like to know how I can connect to the device for the log. At the moment I can only see the log when the ESP32 is connected to the laptop (via the Bluetooth proxy page - ESPHome Bluetooth Proxy). I see that the ESPs are “discovered” in ESPHome and can be adopted but not sure what this does…

Mentioning this because I didn’t see it searching the thread, but there is a pretty bad bug in the required version of zwavejs that prevents communication with certain devices (all of my Zooz brand devices in my case). The bug is documented here: META Issue: Communication problems on v10.x · Issue #4994 · zwave-js/node-zwave-js · GitHub

If you haven’t already, I recommend not updating until this is fixed if you have any Zooz devices. I wish I could safely go back and wait this out, but the next best thing is warning anyone else to avoid my fate.

Not intending to say there’s no issue… but for context, my zwave controller is a Zooz ZST10 stick, and I have ZEN15 and ZEN22 devices that have had no issues since upgrading to 2022.9.


Wow, I found myself in the same position. Would really love for Bluetooth_tracker to work again soon.