2023.2: How can I Assist?

I am still using 2022.5.3.
All of these updates never fix Amcrest Camera issues.
Being a retired Software Engineer, my guess is the “frequency” that the camera’s are accessed is less than adequate (trying to keep all the new add on’s up to date?).

How about an update to keep Amcrest camera’s issue free?

something that was added 3 months ago see home assistant instance crashes on db statistic entry · Issue #88188 · home-assistant/core · GitHub

this is new. where was that speficied as a breaking change?

ahh, well i’ve never “transferred” over to maria-db, so im luckily and peaceful kept my db/recorder to a minimum

By the look of the docs the requirement has been stated for a couple of years at least.

UTF16 has never been supported. The only character set that has been supported is utf8mb4 for at least a year or two, likely much longer.

My voice and commands are being recognized. It even says the action has been done. But nothing actually happened.

As you can see the outdoor lights are stubbornly OFF

1 Like

this wasnt a requirement then until recently. ive gone back and set everything to utf8mb4 but still crashes

As i say, the docs have specified it for at least 2 years.

1 Like

That’s quite dismissive of the points made that included disclaimers.

The message and questions were about the large emphasis put onto this, when this is a platform for automation. Automation solves problems for people without having to worry about age or ability (once it works; setting it up when you are challenged in some way is another matter).

Assistive features are great and necessary, but if you want to have that chat, let’s then also chat about colour blindness and the poor choices of colours or options in many software, including HA (in other words, I have great empathy for that and more).

That was not the point though. It’s about making this the “year of the voice”. Goodness, that’s a strong statement. Does this mean this whole year will mostly be about manual controls by voice? I’d much rather see some development of this, but with a large, core focus still on automation, device support, integrations and fixing bugs.


Or maybe you should just cool down and keep a civil tone.

OK, this esphome “update warning” is becoming pretty f**ing annoying - sorry for my bad words, but i’m a bit pis*ed off (and “a bit” is a small word to be said)… i just spent two+ hours updating my 30+ devices yesterday, today voila - new update and do it again… why? We were quite happy without these warnings. “Don’t fix if it aint broken” is a golden rule, right? most of my esp’s work quite happily with older version, there’s absolutely no need to update each time and i certainly won’t do it every few days over and over again.
OK, i can ignore them, but then my problem is “sensor.updates_available” which i use on my main lovelace to be notified of new updates. If i ignore updates this sensor still shows 30+ updates available. Is there any sensor that shows only non-ignored updates?

ESPHome Addon: option to skip “auto-update” a device - Feature Requests - Home Assistant Community (home-assistant.io)

1 Like

Wow, thanks, it’s a solution, updates counter decreases and warnings are gone. Honestly, i’d never think of that…

I’m totally with guys on your esp link - i already voted. But, as we all know this usually means same as talking to a brick wall… just look votes for folders in automation… :sob: (but i recently found alternative solution for this, works great).

Just disable the update entities. That’s what I do. Works like a charm.

1 Like

Running HAOS on a Beelink U59 mini computer, 16gb RAM, 500gb SSD (3% used).
I do use external USB bluetooth stick and SkyConnect (only with ZHA at the moment).
In the log I saved, just the “waiting on integrations to complete setup” kept repeating. Maybe some other logs might have had more info.

2023-02-08 08:26:59.920 WARNING (MainThread) [homeassistant.bootstrap] Waiting on integrations to complete setup: panasonic_cc, pushover
2023-02-08 08:27:03.349 WARNING (MainThread) [homeassistant.bootstrap] Setup timed out for stage 2 - moving forward
2023-02-08 08:27:59.991 WARNING (MainThread) [homeassistant.bootstrap] Waiting on integrations to complete setup: panasonic_cc

Restore started working after reboot of the whole system, not just HA. Hint for others if you encounter problems.

Decided to try the update 2023.2.5, which went totally fine now.

I could ping them and was able to use them via Broadlink’s cloud just as usual. HA just wasn’t talking to them. Tried restarting HA to no effect either. Could have been a bad update on my end. I’ll try updating again over the weekend and see.

Just installes 2023.2.5 and homekit integration stopped working. On my iphone all devices offline in home app. Anyone else the same?

Broadlink has a cloud? I never knew that. I just use it through Home Assistant Developer Tools, remote.learn_command and remote.send_command.

I also have an issue with SONOS and Nabu Casa Cloud TTS integration since the 2023.2.0 update, but I get a different error message in my log file:

 Logger: frontend.js.latest.202302020
Source: components/system_log/__init__.py:254
First occurred: 17:12:55 (3 occurrences)
Last logged: 17:19:08

    http://homeassistant.local:8123/frontend_latest/app.98f1a6e8.js:851:0 Error: Failed to execute 'define' on 'CustomElementRegistry': the name "mmp-checkbox" has already been used with this registry
    :0:0 ResizeObserver loop completed with undelivered notifications.
    https://936oyxygvdzq7cj6yxpvojmsxpuy0qpt.ui.nabu.casa/frontend_latest/app.98f1a6e8.js:851:0 Error: Failed to execute 'define' on 'CustomElementRegistry': the name "mmp-checkbox" has already been used with this registry

This happens when I make any TTS call like this one:

service: tts.cloud_say
  cache: false
  entity_id: media_player.living_room_2
  message: testing bla bla

This worked fine in all previous releases.

I changed my configuration.yaml to exclude the base_url parameter.

Playing a CHIME or using the same Sonos player via Music Assistant works fine. I just can’t send any TTS commands any more.