2023.6: Network storage, favorite light colors, new integrations dashboard

Samsung TV Remote -
From the release notes: " The Samsung TV now has a remote entity, allowing you to send remote key presses directly to your TV!"

Thought I would give it a try. The samsung doc has an example:

service: remote.send_command
  device_id: 72953f9b4c9863e28ddd52c87dcebe05
    - KEY_MENU

So my first problem was trying to determine what the device id should be in my case.
I found it in .storage/core.device_registry

          "id": "9da6e65f04777cf3468579811960d198",
          "identifiers": [
          "manufacturer": "Samsung",

the device_id is: 9da6e65f04777cf3468579811960d198.
With that, the service call worked!!

If there is a better way to find out what the device_id is, I would be happy to know :slight_smile:

I’m lost with network storage.

I want to mount the external drive i already have exposed as a SAMBA share through the official addon (which works fine). I want to use this extra space to store frigate recoardings.

Ive been able mout it as a media folder but…now what? Does this mean it becomes ‘the’ media storage? Or additional storage that can be used for media? No folders or files have been created in the share, and HA is working as normal.

It create a new folder under /media with the same name as you gave the mount.

For frigate, you have to name it “frigate”.

1 Like

Yeah ive just seen you can browse the share under ‘local storage’.

If I name it frigate does that mean it can be only used for frigate? Is the idea to have one share dedicated to frigate in addition to ones for other media?

I do not use frigate, but as I understand it, it has a strict path requirement of /media/frigate.

You can however add multiple mounts with different names to the same share.


Ok, everything seemed fine. But it is very quiet in house.
That is a major problem with this update!

VLC-TELNET quit on me. No TTS announcements. No sound from the server anymore…

investigating now, somehow i feel, this will be a tough one…
Created own topic for this…

I can use some assist with this, please :wink:


Looks very similar to this:

So I’m not the only one…

1 Like

Dear all

snipping from release notes 2023.6

The following integrations are now available via the Home Assistant UI:

This doesn’t work.
If i integrate it via UI a message told me, it must be done via configuration.yaml

Best regards


Seems like you are running it as a custom integration:

CleanShot 2023-06-08 at 21.31.37

And not using the one Home Assistant provides.


1 Like

I had the same issue, and a reboot solved it. (May as well update the agent before you reboot)

Has anyone that was having the issues with ZHA / Aqara Devices / HUSBZB-1 tried out 2023.6 yet?

I have been sitting back on 2023.4.6 because any version in 2023.5.X has made my Aqara devices completely unreliable. They just stop responding, but don’t even report that they’re unavailable. Re-pairing makes it work for a couple hours but then they stop again.

Everything is completely rock solid in 2023.4.6.

I’m very interested in the new NFS stuff but I spent so much time during 2023.5’s run updating and rolling back and re-pairing devices that I just want to wait until I see more discussion and confirmation of this issue. It doesn’t seem like it has much attention.

1 Like

As the Network storage option has been added, is there any way to create a Backup to a USB connected external drive? Not to the Data drive, not to move the Data drive, but to directly to an external USB connected drive. (HDD/SSD/Pendrive)


A full restart fixed for me

Just set the service up in the UI and the device id is filled in automatically. Otherwise you should be using the service with the entity instead

1 Like

Yeah, it is a breaking change as noted by Frenck in the issue I linked although he seems to infer it may affect custom components only, when the reality is bluetooth_tracker is core.
I also note that in this link bdraco knew about it and commented on it on March 24th as waiting for pybluez to be updated to work with Python 3.11.x.

So, as this is a deliberate breaking change, why does it appear to have been hidden when it should have been highlighted, especially when, as reported, it causes long restart times if bluetooth_tracker is configured?

On a positive note, when bluetooth was, again, deliberately broken just under a year ago ( I am not certain but I suspect it was because of Python), it suddenly started to work about 5 months later without any acknowledgement in the release notes (unless I missed it). I hope this will be solved again with a pybluez update but this time with some form of notification!

This is a show stopper for me, as it was last year, so no update for my production system until we have a working bluetooth_tracker core integration!


Does this update support matter thermostats (like the nest thermostat 2020)? I saw in a reddit thread that it’d be ready in time for this release, but I don’t see anything about it in the release notes.

MQTT is dead after this update.

After the update it states “Restart(s) required” under Repairs.

Once you click Submit, MQTT is dead.

I had to restore from backup to fix it. It bricked my entire install.

The issue would be multiple notifications, we really need a way to get them to automatically +1 on the entity so when multiple notifications go off, they can all be easily referenced. Difficult to do that cleanly with everything having custom Ids

Here’s how I do the persistent notifications via once the event that’s holding them up has ended. alias: "Notification: Persistent Notification Alerts"description: Alerts me if - Pastebin.com

1 Like

Anyway, registered an issue for a weird yaml structure for command_line:


Thank you for the update.

It would be nice if new layouts like devices & entites were optional.
I find the new layout to be quite unfortunate on mobile android devices (i.e. in companion app).