About the Home Assistant Companion for Android category

I have a similar issue.
Access to HA instance is available via the browser and i can login.
on the app side, after entering the correct server address and correct log in credentials the app returns an error with connecting. if i enter wrong credentials, the app replies correctly with wrong user name or password error.
noticed this on android 7

In fact this happens. I did research on the net and I realized that the problem lies in google not updating, for this version (or for some phones or tablets ???) the file system "AndroidSystem WebView. I was hoping that the builders of the Home assistant app could solve the problem. Unfortunately no one commented. It seems absurd that an app like Home Assistant is not able to work on android 7.

Android system webview is intended to be installed as a system app and unfortunately not all manufacturers do this. They instead opt for Chrome so both of those need to remain updated. The android app does indeed work on Android 5+ as I have a tablet on Android 5.

Unfortunately my huawei phone and my Asus tablet do not allow the update. Two producers that should definitely be avoided in the future.

is the app installed as a system app? If not then what about chrome? Android will default to chrome if android system webview is missing or disabled by default.

If its a custom ROM then you should be able to install it as a system app and force the device to use it. Unfortunately nothing we can do when manufacturers decide to go against Android documentation.

The app is visible but not active and cannot be activated. I currently use the wallpanel app on huawei and firefox focus on tablets. Isn’t there a list where the HA app doesn’t work?

then this means chrome is going to be used

The app works on devices running Android 5+

Thanks for the clarifications. It means that I have been out of luck with my devices. I don’t like using chrome, firefox etcc to log in. As long as it is supported I will use “Wallpanel”. I don’t change devices: it’s a useless waste.

Huawei don’t even run android do they?

Yes, Everything is a version of Android
Samsung, OxygenOS, AOSP

Everything else is an iPhone :grin:

I can’t setup this app on my Galaxy Tab S2 (Android 7.0) - version 2021.12.3-full
The first onboarding steps work : detection of the home assistant instance, entering credentials, device name and enable the location. However, right after this step, a spinning wheel appears and the app crashes a few seconds later. The username and password are correct, otherwise I can’t go to the device name/location page.
The app worked perfectly in September (not sure what the last working version was), but then I moved abroad and haven’t checked that until very recently. As anyone seen it ?

Check the logs in settings and make sure to try some of the troubleshooting mentioned in the docs.

Hi Dshokouhi,
Thanks for your reply,
I can’t access the setting from the onboarding pages. However, if I uninstall/reinstall the app, it somehow reinstalls my previous config and I can access the logs.
Here is an excerpt of the logs, but I don’t know what to search for.
I checked the troubleshooting section. I tried the solutions from these two paragraphs, but neither worked (App crashes on set up and ‘Starting fresh with the Android app’)

you have an SSL issue to solve

01-02 19:54:11.451 19525 19559 E WebSocketRepository: Unable to get config response
01-02 19:54:11.451 19525 19559 E WebSocketRepository: javax.net.ssl.SSLHandshakeException: Connection closed by peer

Thank you for spotting this. I have Duckdns with LetEncrypt running. The SSL certificate seems to be OK for my other devices which don’t have any issue connecting to my Home Assistant instance.
I search quite a lot yesterday on the forum but I haven’t found an solution. Any advice ?

Other devices using the app? SSL errors are not ones the app can solve, those are for the user to solve.

Yes, I have two other Android devices using the app (same version) - I have no issue with these devices.
Strangely, I can connect to HA from my Samsung tablet via the browser, but not the app…
Has there been a breaking change with Duckdns or LetsEncrypt addons recently ?

do you get any SSL errors in the browser? Some of these tips from Google may be of help

some android devices can be more strict than others. For the app we require a valid SSL certificate without errors.

No, I don’t have any SSL error in the tablet’s browser, the issue is only with the app.
I deleted the mobile_app file as recommended here Beta testing: cleaning between builds | Home Assistant Companion Docs , and I was able to setup the android app on my tablet again. At the same time, there was a new version of the mobile app (2022-1), so I don’t know if that played a role.

you probably had some bad data to clean up, this is why we have troubleshooting steps.