Add-on request: nextcloud

yes, you have to enable SSL on NGINX Proxy Manager and disable it in Nextcloud since NGINX is handling it.

Thanks for your answer. I looked for it but it seems that there is no confident way to disable the http redirect. I am new to nextcloud especially the ha-addon version. Can you give me a hint in which way I can disable the nextcloud ssl handling / https redirect. Atm. I am running the eightyguy add-on version of the nextcloud addon.

I am using this version of the addon and also could not find a way to disable the unsigned ssl: hassio_addons/nextcloud at master · haberda/hassio_addons (github.com)

However, in caddy I can tell it to ignore the self-signed certificate and still use caddy to do the outward facing SSL. So, I think it double SSLs, but it does work. In caddy, you do this, perhaps there is something like it in nginx:

nextcloud.yourdomain.com {
import header
reverse_proxy * {
to 192.168.1.XX:XXX
transport http {
tls
tls_insecure_skip_verify
read_buffer 8192
}
}

all I did was to only define a port mapping for port 80 (not 443) in the add-on configuration and then pointed the proxy host of nginxproxymanager to the IP of my HA device and port I have configured in the add-on settings. Done. I ofc enabled and forced SSL in Nginx. That’s all I did.

edit: I also use the add-on from haberda, which jaaem just linked above

This is exactly what i’m trying. I’ve created a new duckdns subdomain which links in the nginx proxy manage to the nextcloud http port. But when I open the domain in the browser I get an unsecure connection warning.

//EDIT: Get certificate error. So when connecting to nextcoud the browser gets the certificate of home assistant.

grafik

sorry, no idea then - works for me.

thank you anyways. It must be a problem with the nextcloud installation. I even cant get http access in my local network only unsecure https network. maybe i try a fresh installation of the addon including a new database.

//EDIT: I found the issue. I used duckdns before and in the configiration file ha was forced to use ther certs of duckdns addon. After deleting the entries it works. But I mapped nextclouds https protocol and port. Now it works fine!

@DendelX did you ever figure out how to do this? I was able to get the Nextcloud addon working, but not able to mount an SMB reliably. I tried using the External Drives APP - but for whatever reason, it would only sync half the files.

Maybe something like this might work to allow the SMB to appear local in HASSIO?

https://community.home-assistant.io/t/mount-remote-smb-share-on-hassio/116734/122

I need to change the max. upload file size (client_max_body_size) , any idea how to change that?

Hi,

I implemented that in my own nextcloud addon here (set to 10gb), with several other options: GitHub - alexbelgium/hassio-addons: My home assistant addons

Otherwise, here is the relevant code if you use linuxserver’s image (bas for haberda and myself).

sed -i \
	-e 's/upload_max_filesize=1024M/upload_max_filesize=10240M/g' \
	-e 's/post_max_size=1024M/post_max_size=10240M/g' \
    	/etc/php7/php.ini
sed -i "s|client_max_body_size 512M;|client_max_body_size 10240M;|g" /defaults/default

If you are running those commands from inside a running container, the second change should be made in /config/nginx/site-confs/default. You then need to run nginx -s reload for it to take the new config in account

1 Like

Hi all has anyone tried using the mariadb addon for one of the nextcloud addons and got it to work? if not what db are you using?

yes, use nextcloud from this repo: GitHub - haberda/hassio_addons: hopefully useful hassio addons
works fine with mariadb addon.

thanks, what config settings did you put into your mariadb addon?

This is my config

databases:
  - nextcloud
  - homeassistant
logins:
  - username: nextcloud
    password: xxxxxxx
  - username: homeassistant
    password: xxxxxxx
rights:
  - username: nextcloud
    database: nextcloud
  - username: homeassistant
    database: homeassistant

Thanks! thats what I had, but nextcloud wasn’t able to connect. Will keep digging. Cheers

Had this issue, too. It doesnt work with localhost or 127.0.0.1. I had to connect to the actual network ip.

Yep all working now. :slight_smile:

I get this Message: Composer autoloader not found, unable to continue. Check the folder “3rdparty”. Running “git submodule update --init” will initialize the git submodule that handles the subfolder “3rdparty”.
Is there a step that I’m missing?

Installed this on my supervised HA running on a Pi4 4GB and it runs out of memory.
Fatal Error Insufficient shared memory!
Any settings I can adjust? TIA.