Aeon Labs Aeotec home energy metre / monitor UK / EU


I’m new to Z-Wave and home assistant, I have been trying to set up the aeotec home energy monitor but having some difficulty.

I have followed:


But looks like these are US and there is no EU / UK firmware.

Has any one been able to get this to work and if so could you advise on how to configure it please.


What is the problem you’re having?

Thanks for the quick response.

None of the reading are updating. When I restart Haas there is an out put for watts IE 538.89w 3 times but that then doesn’t update. The kWh is at 0 and the interval is 65535 seconds. The energy monitor it’s self just says sleeping.

I’ll see if I can add a screenshot

Is this one of the ones you monitor the blinking light/LED with or did you connect CTs to your mains bus/power lines?

It’s the gen 1 of this:

It’s battery powered but has a 1 clamp that goes around the live wire.


Sorry I have yet to touch a battery powered zwave device. What does the manual say?

It basically says it’s plug and play,
The device can be powered via mains or battery.

I think it’s a config issue.

Just not sure how to correct it.


I think you should look into the manual and set it up to report its data every hour or so. I think it reports after being powered on because this is the time frame in which you can send new configuration. Afterwards it probably goes to sleep.

See in the manual which is the appropriate parameter and its setting for periodically sending data and configure it via HASS’ zwave panel.

Thank you for the response. I checked the manual last night and only states to consult the zwave controller in connecting the device. I updated to the latest version of hass last night and now hass doesn’t work at all lol. Guess that fixed that problem.

I’ll start from the beginning again when I get chance.

Maybe a fresh install of everything will fix the issue…


You should validate your config, maybe you’re using a component that had a breaking change since the last update. More information on how to check your config:

On the automatic reporting, here’s the relevant info from Aeotec’s website:

Scroll down to Setting automatic report flags.

There you’ll see that you should configure parameters 101 to 104, and there are helpful links on how to calculate the desired values using an excel spreadsheet. You can configure these settings using HASS’ Z-wave control panel, if you’ve added the config: option in your configuration.yaml

Scroll down to Z-Wave Node Management, select your Meter and then scroll down to “Node config options”, where you should select the relevant parameter (it’s most probably 101). There you’ll see this window where you can configure what reports should be sent automatically:

This is a screenshot from Aeotec Smart Switch with built-in E-meter.

I’d be very grateful if you can share your experience with this e-meter as I’m considering getting one too :slight_smile: I’ve read negative reviews that it’s readings are off, and that it stops reporting if you’re using a 3-phase meter, but you’re not having any load on one of the phases.

I’ll I did try to change 101 and 111 I think the second one was made no difference. I’ll give it another try this weekend. IV just ordered a sonoff WiFi switch, a neo coolcam door sensor and pir sensor so will be good to try configure them aswell.

I will let you know the outcome once I have tried over the weekend.



Just providing info for other guys running to problems with this device.

“Node config options” did not work for me (nothing to select there). Instead I used “Services” tab and “zwave.set_config_parameter” from there.
Enabling all reportings:

{ "node_id": 21,
  "parameter": 101,  
  "value": 2147483647,
  "size":4 }

Note that it did not work without size.

Additionally you have to associate the group 1 of this device. I did it with ozwcp (turn off homeassistant and start that instead). This should be doable form ha too, but I was very much lost at that time…

Automatic update interval is changed form parameter 111. Smaller than 10s interval may not work properly, as sending the data takes some time…

{ "node_id": 21,
  "parameter": 111,
  "value": 30 }

I am not sure which generation i have - bought it used and now it is installed already, so checking would be difficult. At least parameter 101 has different settings depending on version…

Works for me :slight_smile:

1 Like

Thanks, I never got it to work correctly, it just ended up being used as a z-wave extender haha, Ill try the settings above but had a ZigBee smart metre installed (in UK) so that be the future.


I had a success after upgrading the firmware of the HEM -device (3 phase, 60A, EU version). The key to success in firmware upgrade was secure inclusion (double click the button). Other things that may have contributed in the fw upgrade were power-off-on, and restore to factory defaults.

With new firmware I just set the parameter 101 to contain only the most needed features (in my case that is total kWH and all three phase currents). I found some posts regarding this device, that it may not work if it is sending too much data…

i know this is a very old thread, but I am trying to make this device work with OpenZWave. I have it connected but the values don’t make sense and are not getting updated. anyone who can share some experience?