Aeotec wallmote quad zw130

zwave
Tags: #<Tag:0x00007f1b9c39ba20>

#1

i just bought a aeotec wallmote quad zw130 and was crossing my fingers it would work in HA. I see four values, but none of them changes if I press anything on the wallmote. Is it possible to make it work or doesn’t HA support it? I was hoping to make four lightswitches each with dimming possibility…


#2

I have just bought it and when I add it I only get one switch but a few sensors, are you getting the same?

The switch I am getting is:
switch.__switch_2_0 off battery_level: 100
friendly_name: Aeotec ZW130 WallMote Quad Switch
node_id: 2


#3

The WallMote Quad uses the Central Scene Command Class to send button notifications to the controller through the 1st association group (Lifeline).

The Central Scene Command Class is currently not fully implemented in OpenZWavet, which makes use of remotes solely based on the command class hard to get fully working. Another recent topic on the forums can be seen for Remotec ZRC-90, which is also solely based on scene activation using Central Scene.

The WallMote Quad does however offer the alternative of using association for switch and dimmer control. Using direct associations should be fully possible, using the correct group for the purpose.

Group 2 - Basic Set [On/Off control via Button 1]
Group 3 - Multilevel Switch Set [Dimmer control (slide) via Button 1]
Group 4 - Basic Set [On/Off control via Button 2]
Group 5 - Multilevel Switch Set [Dimmer control (slide) via Button 2]
Group 6 - Basic Set [On/Off control via Button 3]
Group 7 - Multilevel Switch Set [Dimmer control (slide) via Button 3]
Group 8 - Basic Set [On/Off control via Button 4]
Group 9 - Multilevel Switch Set [Dimmer control (slide) via Button 4]

For reference, see the official Engineering Specification from Aeotec.

Since the WallMote Quad is a battery operated device, remember waking the device after setting the appropriate association. Associations are stored in the internal memory of the device. In associations the Z-Wave controller is not the activating node. The controller will only receives status updates from the activated nodes.

/fuse


#4

So Central Scene is now supported by OZW? https://github.com/OpenZWave/open-zwave/pull/1125

but I am unable to get my ZW130 talking to HASS.

I’ve attempted a workaround in Support to Scene modes using Remotec ZRC-90 to no avail. The scripts are working as intended in HASS, but my button presses on the wallmote are not triggering the scripts.

Has anyone else gotten this wallmote to work with HASS yet?


#5

That’s not yet been merged, so no, there’s no support in any release of OZW for Central Scenes.


#6

So there is no way to get the button 1-4 values from the included entitiy?
I just see the following values.
If I would see the buttons as a parameter of a listed value, I could use a template.


Can anybody help me for a detailled instruction how to turn on a light with pressing a button?
The slider function is not important at the moment.


#7

When i start OZW an log the pressed button, I will get this error:

2017-04-05 13:19:47.004 Detail, Node011, Received: 0x01, 0x0f, 0x00, 0x04, 0x00, 0x0b, 0x09, 0x60, 0x0d, 0x00, 0x01, 0x5b, 0x03, 0x6c, 0x00, 0x01, 0xaf
2017-04-05 13:19:47.005 Detail,
2017-04-05 13:19:47.005 Error, Node011, Cannot find endpoint map to instance for Command Class COMMAND_CLASS_CENTRAL_SCENE endpoint 0
2017-04-05 13:19:47.025 Detail, Node011, Received: 0x01, 0x0f, 0x00, 0x04, 0x00, 0x0b, 0x09, 0x60, 0x0d, 0x00, 0x01, 0x5b, 0x03, 0x6d, 0x00, 0x02, 0xad
2017-04-05 13:19:47.025 Detail,
2017-04-05 13:19:47.025 Error, Node011, Cannot find endpoint map to instance for Command Class COMMAND_CLASS_CENTRAL_SCENE endpoint 0
2017-04-05 13:19:47.048 Detail, Node011, Received: 0x01, 0x0f, 0x00, 0x04, 0x10, 0x0b, 0x09, 0x60, 0x0d, 0x00, 0x01, 0x5b, 0x03, 0x6b, 0x00, 0x02, 0xbb
2017-04-05 13:19:47.048 Detail,
2017-04-05 13:19:47.049 Error, Node011, Cannot find endpoint map to instance for Command Class COMMAND_CLASS_CENTRAL_SCENE endpoint 0
2017-04-05 13:19:47.057 Detail, Node011, Received: 0x01, 0x0f, 0x00, 0x04, 0x00, 0x0b, 0x09, 0x60, 0x0d, 0x00, 0x01, 0x5b, 0x03, 0x6e, 0x00, 0x04, 0xa8
2017-04-05 13:19:47.057 Detail,
2017-04-05 13:19:47.058 Error, Node011, Cannot find endpoint map to instance for Command Class COMMAND_CLASS_CENTRAL_SCENE endpoint 0

I have OpenZwave Version 1.4.2293 with HA Version 0.41.0


#8

Any updates on this? Do it work?


#9

Not until the Central Scene support is part of Open Z-Wave, which it still isn’t. See this open issue for details.


#10

Anything new here? Does it support Central Scenes yet? I’m new to HA but I just got a quad today. I’ll play with it over the weekend. I’m hoping I can get both the button pushing and dimming features to work.


#11

See here for details on setting it up.

There’s still no official Central Scene support, but there is that work around.


#12

Thanks, that was really helpful. I’ve only gotten single-presses working so far. I’d like to get holding and sliding working too, but one step at a time. :slight_smile:


#13

The Z-Wave log (OZW_Log.txt) should contain the details of what it sends when you do that, to help you build the file.

If you do, can you please update us on what you end up with either here, or submitting a PR to update the docs.


#14

i’ve looked at the ozw_log and can provide a bit furter information.
a single press returns

2017-12-29 15:38:26.458 Detail, Node006, Received: 0x01, 0x0b, 0x00, 0x04, 0x00, 0x06, 0x05, 0x5b, 0x03, 0x4c, 0x00, 0x03, 0xe4
2017-12-29 15:38:26.458 Detail,
2017-12-29 15:38:26.463 Info, Node006, Received Central Scene set from node 6: scene id=3 in 0 seconds. Sending event notification.
2017-12-29 15:38:26.463 Detail, Node006, Refreshed Value: old value=0, new value=0, type=int
2017-12-29 15:38:26.463 Detail, Node006, Changes to this value are not verified
2017-12-29 15:38:26.463 Detail, Node006, Notification: ValueChanged

“scene id=3” is button 3 and I can register that in ha.
“value 0” is single press, i guess

a long press returns:

2017-12-29 15:38:50.325 Detail, Node006, Received: 0x01, 0x0b, 0x00, 0x04, 0x00, 0x06, 0x05, 0x5b, 0x03, 0x4d, 0x02, 0x03, 0xe7
2017-12-29 15:38:50.325 Detail,
2017-12-29 15:38:50.326 Info, Node006, Received Central Scene set from node 6: scene id=3 in 2 seconds. Sending event notification.
2017-12-29 15:38:50.326 Detail, Node006, Refreshed Value: old value=0, new value=2, type=int
2017-12-29 15:38:50.326 Detail, Node006, Changes to this value are not verified
2017-12-29 15:38:50.326 Detail, Node006, Notification: ValueChanged

2017-12-29 15:38:50.388 Detail, Node006, Received: 0x01, 0x0b, 0x00, 0x04, 0x00, 0x06, 0x05, 0x5b, 0x03, 0x4e, 0x02, 0x03, 0xe4
2017-12-29 15:38:50.388 Detail,
2017-12-29 15:38:50.388 Info, Node006, Received Central Scene set from node 6: scene id=3 in 2 seconds. Sending event notification.
2017-12-29 15:38:50.388 Detail, Node006, Refreshed Value: old value=2, new value=2, type=int
2017-12-29 15:38:50.389 Detail, Node006, Changes to this value are not verified
2017-12-29 15:38:50.389 Detail, Node006, Notification: ValueChanged

2017-12-29 15:38:50.797 Detail, Node006, Received: 0x01, 0x0b, 0x00, 0x04, 0x00, 0x06, 0x05, 0x5b, 0x03, 0x51, 0x01, 0x03, 0xf8
2017-12-29 15:38:50.798 Detail,
2017-12-29 15:38:50.798 Info, Node006, Received Central Scene set from node 6: scene id=3 in 1 seconds. Sending event notification.
2017-12-29 15:38:50.798 Detail, Node006, Refreshed Value: old value=2, new value=1, type=int
2017-12-29 15:38:50.798 Detail, Node006, Changes to this value are not verified
2017-12-29 15:38:50.798 Detail, Node006, Notification: ValueChanged

again “scene id=3” is button 3.
I guess that value=2 is button pressed, since it will keep firing (the middle section of the log example will appear multiple times) as long as i press down on the button.
and “value=1” is button released, since it always ends with that.

does anybody have an idea how that can be registered in HA?
i can trigger an automation by registering the event “zwave.scene_activated” on the scene id.
but what about the value changed?
how do i trigger on that, or can i use a condition template or something


#15

Have a look at the documentation (previously linked to in this thread) that documents some of the config for the Minimote, and shows how to use the events in an automation.


#16

the minimote is using the scene id to trigger. I can use that and it works perfectly.
but if i want to trigger only on a button hold down, i need to include the value, since the scene id is the same ie. 3.
So far i haven’t figured out how to do that


#17

It’s documented here.


#18

Thank you Tinkerer, that did it11!
if anyone else is trying to figure out how to use the wallmote.
you should just edit the zwcfg_xxxx.xml as mentioned previously
and ad a bit of automation like this:

- id: '15033356445646'
  alias: wallmote all off
  trigger:
  - event_data:
      entity_id: zwave.wallmote
      scene_id: 4
      scene_data: 2
    event_type: zwave.scene_activated
    platform: event
  condition: []
  action:
  - data:
      entity_id: group.audio
    service: media_player.turn_off
  - data:
      entity_id: group.video
    service: media_player.turn_off
  - data:
      entity_id: group.lys
    service: light.turn_off

this scene_id is the button number, and scene_data is

  • 0 = single press
  • 1 = button release
  • 2 = button press (note it will keep firing as long as you press the button)

the last thing is the slide up/down function, which i haven’t look at too much. just noticed that the log shows this when activated

2018-01-01 11:39:03.298 Detail, Node006, Received: 0x01, 0x0e, 0x00, 0x04, 0x00, 0x06, 0x08, 0x70, 0x06, 0x09, 0x04, 0x03, 0x01, 0x42, 0x87, 0x47
2018-01-01 11:39:03.298 Detail,
2018-01-01 11:39:03.298 Detail, Node006, Refreshed Value: old value=50405509, new value=50414215, type=int
2018-01-01 11:39:03.298 Detail, Node006, Changes to this value are not verified
2018-01-01 11:39:03.298 Info, Node006, Received Configuration report: Parameter=9, Value=50414215
2018-01-01 11:39:03.298 Detail, Node006, Notification: ValueChanged
2018-01-01 11:39:04.540 Detail, Node006, Received: 0x01, 0x0e, 0x00, 0x04, 0x00, 0x06, 0x08, 0x70, 0x06, 0x0a, 0x04, 0x03, 0x01, 0xc7, 0x88, 0xce
2018-01-01 11:39:04.540 Detail,
2018-01-01 11:39:04.540 Detail, Node006, Refreshed Value: old value=50414214, new value=50448264, type=int
2018-01-01 11:39:04.540 Detail, Node006, Changes to this value are not verified
2018-01-01 11:39:04.540 Info, Node006, Received Configuration report: Parameter=10, Value=50448264
2018-01-01 11:39:04.540 Detail, Node006, Notification: ValueChanged


Multilevel command class not supported for Wallmote Quad
#19

Hi fuglphoenix,

I am trying to replicate your work for the fibaro button. That is

  • Turn off zwave network
  • Edit zwcfg_xxx.xml as suggested by the link above
  • Turn on zwave
  • Edit the automation as you did (with the scene_id and scence_data suggested by the link above)
  • Wait for something to happen when you press the button

However in my case, nothing happens. I played now with serveral variations for quite some while with no luck. Did you do anthing else? Am I missing something here?

I mean I get some warning that tells me that something is not right on OZW level:

2018-01-03 22:11:05.804 Info, Node005, Received Central Scene set from node 5: scene id=1 in 7680 seconds. Sending event notification.
2018-01-03 22:11:05.804 Warning, Node005, No ValueID created for Scene 1

Yet there is little I can to about this at my level of understanding. So I would be inclined to send back the button and get the mote instead.


Z-Wave Fibaro Button (FGPB-101)
#20

Did you manage to get the swipe function working?