After update Home Assistant, Error connecting to deCONZ gateway

I understand how to change the ip, but after changing it, reboot the host it changes back again.
Any suggestions or tips.

Is it the configuration file that is changing? Or the ip address of Deconz?
And if it is the config file, is it a fallback to old configuration because something is broken In the file? A typo or miss alignment

1 Like

I have this issue, too. Changing the IP between boots thus breaking the connection from the add-on to the integration is not an expected behaviour.
Worse, I can’t make the de-conz integration use the System IP and Port (which is fix), which would circumvent that for good.

I’ve set the value in the add-on for “deCONZ API backend” explicitly to 40850.
I would assume now the extension is able to connect via public ip and port.
But its not :frowning:

For anyone having the same Issue: I had the same Problem and asked for a more permanent Solution (editing the config file rather isn’t, as the IP always can change again) - and it seems is quite simple to solve:

"host": "core-deconz"

What i can confirm so for: I had a static IP under host, which changed from time to time. I just replaced it by “core-deconz”. It survived a reboot, and i still can use all Zigbee-Devices by now.
Just wanted to let you know :slight_smile:


Great! That is something I wanted to try that for a long time. To point to the DNS name. Is that container name universal for all types of setups?

Can’t tell. Im runnning on HomeassistantOS RP4 64Bit. michaelblight who had the Solution by looking at his config is using Hassos as well, but in a VM.

I’d think it is worth a try. Worst case should be, that after a reboot you can’t control Deconz with HA. Then you just do what you already did - entering the static IP again and reboot again :wink: I would give it a shot :slight_smile:

Unfortunately It dit not work for me.
I tried both “core_deconz” and “addon_core_deconz” in /config/.storage/core.config_entries. Neither worked and had to go back to the IP address.

I uses Glances to see the container name
If anyone has a suggestion what else to try?

Sorry I used underscore and it should be minus -

Well, like i wrote, thats the Setting that worked for me :wink:

Oh… Shoot I used underscore.
Thanks. Now it works fine

Had the same issue
Found this post and learnd about the location of the core.config_entries.

As my primary system which is a system running for multiple years didn’t had this issue I compaired the core.config_enties files and noticed that the older system had core-deconz defined instead of the ip-address so I replaced it in the newer system and restarted it and all started working like it should.

Wanted to post my solution to help but smartin beat me to it by 41 days :smiley:


I’d just like to add that there’s an easier way to do this with the simple file editor add on (ie Home Assistants own addon) instead of a Home Assistant Community Visual Code Studio Addon. Just go to the Simple File Editor addon’s configuration GUI and remove “.storage” from the ignore patterns section there.

Then you can just browse (from the GUI) to the core.config_entries file, edit and save (after backing up, of course!)

1 Like

You are a life saviour!
Editing the config file worked for me!



Excellent solution.
It worked for me too.
Thank you

Thanks everyone, your advice ("host": "core-deconz") worked for me but it took a few attempts for the change to work.

grep "deconz" -A5 /config/.storage/core.config_entries
grep "" /config/.storage/core.config_entries
cp /config/.storage/core.config_entries /config/.storage/core.config_entries.bak
sed -i 's/' /config/.storage/core.config_entries
diff /config/.storage/core.config_entries /config/.storage/core.config_entries.bak

After a while when I did the diff I would see unrelated access token is refreshed, no need to be alarmed by a difference like that.

Restarting HASS allowed the host address change to kick in and fix the issue. Going to the addons menu > Deconz choosing Restart and integrations menu > Deconz choosing Reload didn’t help. One seemed to revert the core.config_entries change.

This morning I woke up because of two-second power outage, because that caused my TV to turn on. Although a power outage that short should not reboot my Raspberry where my HASS is, seems like the battery in my UPS is dead then. Anyway, this power outage broke (for some reason) my whole zigbee network with this same error “Error connecting to deCONZ gateway”.

Thanks to this thread, I managed to get it fixed again by changing that IP address in core.config_entries to “core-deconz”. Hopefully when the next power outage comes (at least when I replace that battery in the UPS, unless I shut down the HASS properly), this does not change again :slight_smile:

This right here worked for me!!.. Still have absolutely no idea why IP is strange. Been running the HA for 2 years without any problems.
RP4 with deconz

Thank you!
It worked for me too.
After about one year without problem the deconz IP began to change again.
I have used “core-deconz” and it work well, also after reboot

Thanks, I had the same issue after updating to the latest HA Version. Installed the VSC Server Plugin and changed the IP in config_entries to the new one.

This is the way. Worked for me after using core-deconz instead of the new IP.

Hi There, just have the same issue right now. Could you RP4 with HA and Deconz AddOn.
What exactly have you done to solve the issue??