Airtouch 5 Integration (Aus)

I didn’t read this before updating - rookie mistake I know. Can you explain / link on how to delete / re-add ‘config entries’ please?

You can do that from the integration settings page, Settings → Devices & services → Polyaire AirTouch.
Or just click this link to go there directly: Link to Integration – My Home Assistant

Then click the three dots next to the AirTouch entry (which will be highlighted with a migration error) and choose “Delete”. After deleting, you can press the"Add Hub" button to add your AirTouch back in again.

1 Like

Hi, I am newbie and trying to configure the AT5 with the Home Assistant running on Win11/hyper-v. I have downloaded your custom repo through HACS and while trying to add the integration I am getting the below error. I have given the correct IP address, but still getting the same error. Could you please help? Thanks a lot!

If you have a firewall, you need to make sure that traffic on UDP port 49005 and TCP port 9005 is allowed. The easiest way to configure the integration is if you have a network configuration that supports UDP broadcast, then you won’t need to manually enter the address.

If it’s not a firewall, check to confirm that you can ping the AirTouch tablet from your Home Assistant VM and if possible also ping the VM from the tablet.

you mentioned that you can control the compressors, do you do this within Home assistant?

Hey Guys,

I have a Toshiba VRF system installed in my new home with two Airtouch 5 controllers (one upstairs and one downstairs). It is set up as 6 unique AC units in Airtouch, and both controllers can manage all 6 units. There are no zones, bypass, spill or dampers. Simply 6 internal units that can be turned on or off seperately with their own unique temperatures in each room. I think (VRF?) I can even cool one room whilst heating another room, but doubt that will ever be required.

When I try to connect to the Airtouch 5 using this plugin, it auto discovers the upstairs controller, but fails to fully initialise. When I put in the IP address of the downstairs controller I get the failed to connect error (even though I can ping it from HA). I’m running a unifi network (UDM-SE) with basic network settings (no custom firewall rules and no customisation to the airtouch5 controllers)

Looking at the logs, it looks like the upstairs controller get stuck when this plugin polls for all zone numbers (see attached). Appreciate any advice how I can:

  • get the upstairs controller to fully sync (perhaps the plugin needs an update for houses with no zones/bypass/spill and multiple AC units?)
  • get the downstairs controller to connect

Sounds like it doesn’t accept something with no zones to me.

You could try just making 6 zones which are fake but would be assigned to each system, at least this would confirm the theory.

Even though these are single systems you would probably find the temp is controlled better on them by doing this and adding Airtouch sensors for each.

It’s what I normally do in this setup.

No, I have a device that I have made to control the compressor motor, it’s not something someone should be doing through home assistant and automations as not doing it properly can damage the system and it’s probably a little too complex to be doing with just automations honestly. I can expose it to home assistant for data logging purposes.

I have been using it for nearly two years and works really well and have been looking into producing it. It reduces the energy consumption and makes the cold and hot air less aggressive.

I had passed the idea into Airtouch

Yes, this is a very unusual use case. The AirTouch API doesn’t really support no zones, a zone status message with no zones is treated as a request for zone status so that response is ignored by the integration.

I can look at adding a special case for systems with no zones later in the week, but creating at least one zone in the AirTouch settings as suggested by @smitcoracing would probably get you past the set-up as a workaround.

Yeah I m pretty disappointed that it leaves the modulation of the compressor up to the AC unit that doesn’t really know what i is trying to achieve. Is the setup you have specific to a certain OEM?

@marco.rolo thanks for attaching the debug logs.
I’ve just published a beta release v1.1.0-rc1 which I think should get this working.
You can install this from HACS by choosing “Redownload” from the three dots overflow menu on the integration’s detail page and making sure the “Show beta versions” option is selected.

If it still doesn’t work send me through the debug logs and we can go from there.

Thank you! I added a zone to the upstairs controllers and the plugin connected successfully. Its now working beautifully, allowing me to expose to Homekit which was my goal.

I then removed the zone and it continues to work. I’ll try downloading this update on the weekend, but I suspect it is all good!

My air touch controller says it has no internet connection but it does I can load google fine but when I visit the airtouch website it says 403 forbidden why is that?

when i visit the airtouch Wi-Fi on a different network it lets me but why not on my network were my AIRTouch console belongs to

If your console is switching off the wifi randomly you will need to have the SD card update done to it to install an android patch and it resolves the issue.
That’s if that is what you’re talking about.

Otherwise it sounds like you have setup restrictions on different home networks

no my Wi-Fi on the AIRTouch isn’t randomly turning off it’s just that i can’t access the AIRTouch website and the console

Here’s what I’m seeing right now

The globe with the line through it means it’s not connected to the internet.

Go into the android settings, about tablet, then click on android version and See what the security version is.

Mine, others I’ve updated and new version have October 5 2023 and this can only be done with the SD card.

If yours doesn’t have that it could be causing issues or I have seen some of the first generation ones do wierd things due to the previous style of tablet connection.

If it’s not any of those it’s your home network, I had one the other day doing wierd stuff and it was his home network setup. Worked perfectly fine when connected direct to his Telstra modems wifi.

i dont think so that its the AirTouch tablet itself
if my ipad cant connect to the AirTouch website that means its their side