Alexa Media Player Integration not working?

Same problem here. Reinstalling the integration brought back the devices without issues but they don‘t work for any TTS or announce. Any help?

Same for me. Uninstalled and re-installed, worked for a day, then stopped working again. Now it won’t configure (no error message, just doesn’t save)

I´m having the same issue. I´m currently trying to uninstall and install again but so far no luck

Same for me.

are you reentering the captcha? Every few days/weeks you have to enter this information if the authentication(Not sure if this is the correct word) is old. Check your notifications and enter the proper information to the captcha.

Thanks Petro. I have fixed it by following these steps:

1 Like

I struggled quite a while too. made it work by making sure that the Alexa-domain you logon to in Home Assistant is the same as the domain you see when logging in to alexa from a browser.
In my case I had in HA and in browser.
Putting it to in HA did the trick. Now it works.

To make it work for me, I found:

  • you need the 2FA turned on your amazon account
  • text message based 2FA didn’t work for me, added an Authenticator App to my Amazon account and it sailed through

Every so often you have to re-authenticate. So far using an Authenticator app its not failed me…

I wasn’t sure what value those entities offered me and I couldn’t find a reason to use them, so the fact they weren’t available wasn’t something I worried about. Disabled them to clean the view up and still had access to push TTS message to the Alexa device etc.

Would be interested to hear if you have a use case for them, perhaps its something I should investigate (one day!)

I successfully did the 2FA authentication and it works but when i restart the Home Assistant the Alexa media players are not available. Then I need to uninstall it and then reinstall it. I don’t think that’s normal.
How could I do this without always having to reinstall it?


I have the same problem: I’m running hassio on rpi4. Every time it restarts I have to reconfigure Alexa Media Player.

It has been working well for me since a few updates. (knock on wood)

Ok … I will try to reinstall the whole system.

I upgraded to the latest version today and now i can’t configure it. :worried: (2021.3.3 + 3.8.3)

I am able to configure it, but every time I restart hassio, I get the error. Now I have seen that I can deactivate and reactivate the integration, instead of reconfiguring everything.
It’s a workaroud, a bit annoying, but it works.

Mine is doing the same - keep being asked to re-authenticate/reconfigure. I’ve responded to the Amazon authentication requests, but still the same.

Doing the same here

Mine is also doing the same thing. Every time I make a change to a .yaml file and have to reboot HA, my Alexa Media Players are all Unavailable and get an error in my Logs with no useful information. Have to reset it up every time, which involves an additional reboot. Will try the Disable and Enable next time.

Any news on this? I’ve just setup Alexa Media Player but all my entities show up as unavailable.

Long story short - Add 2FA KEY

After 2 hours of try/error, all devices(except the mi band ones) were seen as Standby and not Unavailable.
I was suspicious about the success of my first installation of the integration so I made it again.
The issue was the 2FA step
It seems that I made a mistake somewhere before.
Now I did check the checkbox that says " Do not request new codes for this device" (not sure if that fixed the issue)