All USB Ports died on HomeAssistant Blue (ODROID-N2+)

Hi, yesterday all USB ports died on my HomeAssistant Blue (ODROID-N2+) device. USB was used for my Z-Wave integration. Since I assume that the board is defective I ordered a replacement one.

Any suggestion if it is ok to just replace the eMMC with OS and config and get up and running directly ?
OK, I’ll also change the DHCP settings to get the correct IP.

Any other idea what happened after running this hardware for about 17 months without problems ?

This also happened to me about 1 week ago. There is a supposed fix (I haven’t tried it yet, but will be). See these threads:

[N2+] All 4 USB ports not working after reboot - ODROID – Others experiencing the problem and Odroid saying “it’s not our fault” (not really, but…)
fixed blown 5v regulator on my Odriod N2 - ODROID – This has the fix I am going to try.

1 Like

Actually Hardkernel IS NOT standing behind their product (see [N2+] All 4 USB ports not working after reboot - ODROID) and is not acknowledging it’s a problem they should address.

Yeah it is a known problem, but hardkernel are disinterested.

Update: Replacement worked smoothly. I just had to update DHCP and swap eMMC and “bang” I was ready to go. Two things left: get old N2+ working again and find something to avoid the quick death of the new N2+ in 18 months. While there is a picture with a replaced voltage regulator, this isn’t sufficient for me to to the soldering.

Not related with the issues that occur with HA OS 8.x that are being reported and not working USB ports?

An update of my own: I finally got around to soldering up a volt regulator (as described in the prior article) and was going to install it. But before I did, I tried another idea I had; I swapped the 12v power supply with a new one and guess what; The USB ports were working again.

I don’t know if this “fix” will fail later since I already replaced the HA Blue with another computer (Qotom Mini PC j1900, so the HA Blue is now my backup. But I will keep playing with it.

@Nick4 Do you have additional details on this? Link?

Hi Steven, no I don’t have any links at hand but I came across a thread about this.

This just happened to me as well. I purchased a Blue right when they were announced ~18 months ago and last week the USB ports died (taking down my Zigbee and RT-SDR USB sticks.)

I ordered a replacement from HardKernel and it arrived pretty quickly from South Korea. I first tried a new power adapter with the original Blue, but the USB ports still did not function.

I shutdown the Blue, swapped the motherboard and memory chip, re-assembled, updated my DHCP lease to accept the new MAC address, plugged it in and it started right up again.

It made me think about having replacement hardware around for situations such as this. I’m going to get a Home Assistant Yellow box and see how that performs. I’m not sure how much of an upgrade it will be (other than ssd support and a new zigbee chip) over the Blue. It’s not clear if the Pi CM4 performs better than the Odroid chip or not. Whatever I end up using longer term, I think I will order a backup set of hardware to have on site… just in case.

ok, I updated my HA Blue to HA OS 9.0.rc1 today, and something must have went wrong, as it would not boot anymore.

I connected to the HDMI and I get the message that HA CLI not starting.

So I tried to connect a USB Keyboard to do something, but I get no response.
Is it a valid assumption that I’m also a victim of the N2+ USB Issue?

I have a HA Blue since they were launched and been working fine. A couple of days ago, all 4 USB ports stopped working completely. I use a Z-wave dongle via USB, so now the Blue is close to useless. More e-waste which is a shame, as it had been very reliable until this week.

Oh man. I just updated my Home Assistant OS and mine died. This is really disappointing not that I have moved to using so much bluetooth…

Spoke too soon. 2 more hardware resets fixed it. Still makes me weary of the product now though.

1 Like

did anyone try to use the microUSB on the back to plug in a active USB hub?

Yes, that works. I connected my USB-ZWave Dongle to the microUSB port on the back. Fingers crossed it will continue to work.

I found this article about how to reset the USB ports and control their power supply: The ODROID-N2+ seems to be able to control USB power in software. It needs root access to the host’s OS though. Will try to gain access to the host’s OS and test if I can revive my USB ports.

I do not see it, is it on the blue (ODROID-N2+)?

Today it happened to my Home Assistant Blue as well after a reboot.
The Blue is only 20 months old.

I had to move my Zigbee-stick to a raspberry pi and then configure zigbee2mqtt with socat and ser2net.

Can it be fixed?

You can try replacing the 7805CT - see above. Also there are some wiki refs above you can try.

It is hidden underneath the case, just like the ir diode