Home Assistant Community

Announcement: HADashboard v2 Beta!

#209

rpitera, thanks, guess the variables.yaml file can’t be empty. I’m good now (for a while at least…)

1 Like
#210

Did you at least get a sensible error in the logs? If not I’ll fix that.

1 Like
#211

I got the error page in the browser and this in the logs when I tried it.

2017-03-05 12:52:05.600028 INFO Loading custom skin 'test'
2017-03-05 12:52:05.600802 INFO Compiling dashboard 'MainPanel'
2017-03-05 12:52:05.602194 WARNING ------------------------------------------------------------
2017-03-05 12:52:05.602711 WARNING Unexpected error in CSS file
2017-03-05 12:52:05.603102 WARNING ------------------------------------------------------------
2017-03-05 12:52:05.607549 WARNING Traceback (most recent call last):
  File "/home/pi/appdaemon_dashboard/appdaemon/appdaemon/appdash.py", line 82, in load_dash
    dash = dashboard.compile_dash(name, skin, skindir, request.rel_url.query)
  File "/home/pi/appdaemon_dashboard/appdaemon/appdaemon/dashboard.py", line 27, in profiled_fn
    dash = fn(*args, **kwargs)
  File "/home/pi/appdaemon_dashboard/appdaemon/appdaemon/dashboard.py", line 44, in newfunc
    result = func(*args, **kwargs)
  File "/home/pi/appdaemon_dashboard/appdaemon/appdaemon/dashboard.py", line 451, in compile_dash
    dash = get_dash(name, skin, skindir)
  File "/home/pi/appdaemon_dashboard/appdaemon/appdaemon/dashboard.py", line 486, in get_dash
    css_vars = load_css_params(skin, skindir)
  File "/home/pi/appdaemon_dashboard/appdaemon/appdaemon/dashboard.py", line 70, in load_css_params
    return expand_vars(css, css)
  File "/home/pi/appdaemon_dashboard/appdaemon/appdaemon/dashboard.py", line 83, in expand_vars
    for varline in fields:
TypeError: 'NoneType' object is not iterable

2017-03-05 12:52:05.608192 WARNING ------------------------------------------------------------
2017-03-05 12:52:05.619687 INFO Dashboard disconnected
#212

Error page was “No Dashboard could be found”

#213

OK we can clean that up a bit.

#214

Works great in portrait mode too, I promise this will be the last image for while :wink:

Sorry for the grainy quality image!

If anyone’s interested in doing this with a Raspberry Pi touchscreen, don’t forget:

  • edit the/boot/config.txt file and include at the bottom display_rotate=1

  • install xinput in you haven’t yet, sudo apt-get install xinput

  • finally, as part of start-up run the following command to line up the touch-screen to the rotated display:

xinput --set-prop 'FT5406 memory based driver' 'Coordinate Transformation Matrix' 0 1 0 -1 0 1 0 0 1

edit:

And for tidiness also: sudo apt-get install unclutter to stop the cursor ruining things.

3 Likes
Replacing light switches with 3.5" pi screens
Announcement - HADashboard v2 Beta 2!
#215

What do you mean last image - keep em coming! I love seeing them in use…

2 Likes
#216

Cool that you got it. Yeah, maybe it was that you need to nuke the image and not the container. Not sure. I know it’s a bit obtuse to understand when you’re following someone else’s instructions and then have new instructions out of order.

#217

So I think the issue right now is…

Your browser is being fed ws://dash_host:dash_port , which is derived from the Dash_url when it loads. so when you connect from http://100.6.200.xx externally, the HTTP side renders fine, but then it goes to hit that ws:// url, but it’s getting 192.168.2.xx, which obviously doesnt work externally.

That’s going to take a deeper code change to make the ws:// match the situation, eg, not be “hard coded” against dash_url.

#218

That is essentially correct - the ws:// url is what gets the streaming updates so you won’t see any updates, but you also get blank values at page load because the widgets attempt to connect back to AppDaemon to grab their initial state.

1 Like
#219

Thanks, sorry in and out of the office today. That is the error I got as well.

#220

@aimc this is the correct way to include images in the custom css correct?

background: #ffffff url('/custom_css/template_name/img/background_1.jpg') no-repeat 0 0 fixed;  

Getting a 404 error in chrome at http://172.30.1.xx:5050/custom_css/template_name/img/background_1.jpg

Thanks!

#221

That should be correct, yes - obviously make sure your pic is an the img subdirectory but the path is correct.

#222

hmm, file is definately in custom_css/tempate_name/img

#223

@aimc nevermind, docker is killing me today. Have to destroy the container and recreate for new files to show, i’ve run into this issue before with the -v on docker run. Sorry to bother.

1 Like
#224

No worries - looking forward to what you come up with :slight_smile:

#225

you just activated a warning light for me lol. That’s not behavior I’d expect from docker :frowning:

You rm’d and recreated the container using the same image and it worked the second time?

#226

yep, stop, rm, docker run … -v /local/dashboard:/conf appdaemon:latest

further info, thats the process that made the newly added .jpg to the local/dashboard/custom_css/template_name/img folder work and not give 404 errors.

#227

That’s… unexpected. If it happens again maybe we can think about it. Never experienced that behavior myself, so I don’t even know what to check (ala, you learn the most when things are broken!)

Maybe as a thought if you do see it, try stop/start so the process is basically starting over. See if that’s enough first.

#228

Great work.

I have it up and running but the input_slider do not show the current value from HA. It works fin in increasing or decreasing the value in HA.