Any Support for Midea A/C?

Unfortunately I’m not an advanced user :sweat_smile: I’m still confused about HA and I don’t know how to do that dongle :rofl:

I’m using OSK103 in every A/C that I have but I don’t know why one of these doesn’t work. It’s quite strange…
I’ve also tried using @andersonshatch’s component that connect through Midea cloud but 1 out 3 still doesn’t work

I’ve also some problem installing msmart…

what do you mean? How can I achieve that?

Not a problem, but not being an advanced user is especially with this kind of component tricky… :wink: It needs a few things worked out behind the scenes and that makes it difficult to debug. In your case you’d need to get logs from all three of your dongles and debug them accordingly. In short words, this is something an experienced user could/should do. :slight_smile: I’m sorry, but I don’t use this component any more, as the ESPHome version is much more local and stable, easy to maintain and it is very inexpensive.

What I could offer you is: I’m writing on a tutorial for the new ESPHome based component, should be ready in a few days, and it will guide you step-by-step through the process of getting the parts, setting it up and use it. I’d strongly suggest to make the change to this component, as it will be actively maintained and is way easier in the end, than the one from this thread. :slight_smile:


Thank you. You’re my hero :smiley: I’ll wait patiently the tutorial :upside_down_face:

I have the custom component setup following the instructions on the github page, including adding the lines to configuration.yaml with the device ID and IP address, but I’m not seeing anything in my Integrations and the device/entities don’t appear. Am I missing something?

The only thing I do see in the logs is that it’s complaining about no versioning in the manifest but I don’t think that’s the issue is it?

2021-04-06 09:53:30 WARNING (MainThread) [homeassistant.loader] No ‘version’ key in the manifest file for custom integration ‘midea_ac’. This will not be allowed in a future version of Home Assistant. Please report this to the maintainer of ‘midea_ac’

I had the same problem. I installed the integration again and right now I see the device but it says it is unavailable. I installed it again and even reseted HA. It didn’t help and still idk what happened. I am sure that I have correct data put in the configuration.yaml

Can someone help?

@byronbrewer and @Raensl

Guys, come on, a little more information would be really useful to help… :wink: Something, no, anything will help. :slight_smile:

Your config looks like? What dongle are you using, what model/manufacturer is your A/C? Does the log say something? If not, have you enabled debug for this component (or don’t know how to do that)?

Come on, this shouldn’t be a guessing game. :slight_smile: :slight_smile: :slight_smile: So go, collect as many information that you might think could be useful and present it to us. :wink:

Yes, you are, otherwise it would work. What exactly? I have no idea… :wink:

If you are sure, everything is correct, than we are as well. :slight_smile:

You get the idea: Help us to help you! See here, especially points 8 to 14. :wink: How to help us help you - or How to ask a good question

so can u help me where can I get specified log/data about my integration. maybe then I could ask a good question. Right now in the log there is nothing about Midea so I may do something wrong :smiley:

We are talking about Anderson/MacShou’s solution with OSK-103 here right??

I’m not even sure that is still developed.
Fair change the OSK-103 got updates that are not in the repository of Anderson…
I can see there are still updates, but they all concern HA…
Makes sense, as his OSK won’t received any updates…

I too recommend to dump the OSK and get ESP :wink:
(if you manage to sell it for a recent price, you can buy may ESP for it :P)

This thread is about Midea A/C units so I didn’t feel it was necessary to specify that level of detail but if it’s helpful I have no problems doing so. I installed the integration from HACS and then plugged the information into configuration.yaml and restarted HA. Not sure how to enabe debug for the midea integration.

Make: Midea
Model: MAW08V1QWT
Add’l Info: It has a built dongle that’s concealed behind the front panel. It’s just a USB dongle that with a sticker that says “smart kit intelligent” on the sticker and has a MAC address. I would imagine it’s just a WiFi dongle but no idea beyond that

This is the section I added to my configuration.yaml. I pulled the device ID by doing a Share from within the Midea app, pulled the data out of the QR code and then converted the string to text.

  - platform: midea_ac
    id: 012345678901234

After adding this to my config and restarting HA I do see an entity was created but it says it’s unavailable.

Pretty sure the integrated wifi stick in your unit is the newer, hereby often referred 103 one, which is not supported by the HACS Midea AC integration.

Bummer. Is there a way to buy a different dongle that would allow me to control it from HA?

There are three options:

  1. as @aceindy suggested, try the ESPHome solution linked above

  2. there’s a fake cloud method described in detail here:

  3. (untested): in theory if you can get a 102 dongle, it could work. But that’s something I never tried :smiley:

  1. One more rather cheap and elegant option: Tasmota MQTT IRHVAC - works great and I use it as a backup local control for Midea Mission (and other IR tasks).
    Best, JR
1 Like

one could argue with the elegant word :smiley: :smiley: :smiley: But yes, it’s a viable 4th option.

Elegant was used referring to much more usage cases in same room, not only HVAC :slight_smile:
But it is OK to correct my wording- hehee…
Best, JR

Thanks for the help @Lukacs_Attila & @Foxxy. I think all 4 of those options will likely exceed my current HA abilities.

Maybe I’ll revisit when I’ve gotten a bit better on the platform.

problem with ‘elegant’ IR is that it only 1 way communication.
In other words, you can order it to go on, but can’t verify if it is really on.
Also operating it with original remote will seriously confuse HA

@aceindy No, it would not confuse HA if you use the original remote, because in my cheme I’ve put IR receiving diode, which updates the state of the air conditioner to the right state. :slight_smile: So if you use the original remote, HA will know what to do. :slight_smile:

Nope, HA has to assume that everything worked. Without a back channel, that is directly connected to the sensor, it will always be an assumption. :wink:
But nonetheless, why not using the simpler and possibly cheaper way to get to a biderectional solution. The ESPs and the parts for an ESP dongle are not even worth mentioning. In theory and using all ways to save money you will be under 10.-€ / $10 for a known working and actively developed dongle, that gives you the whole experience. :slight_smile:

Sure, first thing is to enable the debug log especially for this component. You do that by adding this to your configuration.yaml:

  default: WARNING  # or DEBUG or INFO
    custom_components.midea_ac: debug

I hope this is the correct spelling for the component. Can’t test it, as I don’t have it running anymore (that’s why I recommend the ESPHome-based approach).

Other necessary infos would be the label of the A/C (Media is always the manufacturer, but labels the A/Cs with a lot different brands like OlimpiaSplendid, Mr.Cool, …) and the dongle you are using. All original dongles are either OSK-102 or OSK-103.

I just need to take a few pics to publish a small guide about how the ESPHome based approach is working (including buying instructions). As I said, it is the better approach towards your A/C as this component here in this thread will be discontinued rather sooner than later. :slight_smile: My recommendation for you: wait for the guide and decide after you read it. I’m quite sure you will end up with the ESPHome based approach. :wink:

I was wondering what the status is on the Tutorial you said you were writing?