Any Support for Midea A/C?

There are three options:

  1. as @aceindy suggested, try the ESPHome solution linked above

  2. there’s a fake cloud method described in detail here: https://github.com/WMP/midea-ac-py/tree/support-8370#install-fake-cloud-only-if-you-have-protocol-version-3

  3. (untested): in theory if you can get a 102 dongle, it could work. But that’s something I never tried :smiley:

  1. One more rather cheap and elegant option: Tasmota MQTT IRHVAC - works great and I use it as a backup local control for Midea Mission (and other IR tasks).
    Best, JR
1 Like

one could argue with the elegant word :smiley: :smiley: :smiley: But yes, it’s a viable 4th option.

Elegant was used referring to much more usage cases in same room, not only HVAC :slight_smile:
But it is OK to correct my wording- hehee…
Best, JR

Thanks for the help @Lukacs_Attila & @Foxxy. I think all 4 of those options will likely exceed my current HA abilities.

Maybe I’ll revisit when I’ve gotten a bit better on the platform.

problem with ‘elegant’ IR is that it only 1 way communication.
In other words, you can order it to go on, but can’t verify if it is really on.
Also operating it with original remote will seriously confuse HA

@aceindy No, it would not confuse HA if you use the original remote, because in my cheme I’ve put IR receiving diode, which updates the state of the air conditioner to the right state. :slight_smile: So if you use the original remote, HA will know what to do. :slight_smile:

Nope, HA has to assume that everything worked. Without a back channel, that is directly connected to the sensor, it will always be an assumption. :wink:
But nonetheless, why not using the simpler and possibly cheaper way to get to a biderectional solution. The ESPs and the parts for an ESP dongle are not even worth mentioning. In theory and using all ways to save money you will be under 10.-€ / $10 for a known working and actively developed dongle, that gives you the whole experience. :slight_smile:

Sure, first thing is to enable the debug log especially for this component. You do that by adding this to your configuration.yaml:

logger:
  default: WARNING  # or DEBUG or INFO
  logs:
    custom_components.midea_ac: debug

I hope this is the correct spelling for the component. Can’t test it, as I don’t have it running anymore (that’s why I recommend the ESPHome-based approach).

Other necessary infos would be the label of the A/C (Media is always the manufacturer, but labels the A/Cs with a lot different brands like OlimpiaSplendid, Mr.Cool, …) and the dongle you are using. All original dongles are either OSK-102 or OSK-103.

I just need to take a few pics to publish a small guide about how the ESPHome based approach is working (including buying instructions). As I said, it is the better approach towards your A/C as this component here in this thread will be discontinued rather sooner than later. :slight_smile: My recommendation for you: wait for the guide and decide after you read it. I’m quite sure you will end up with the ESPHome based approach. :wink:

I was wondering what the status is on the Tutorial you said you were writing?

Thanks.

My soldering skill are limited to say the least, but I took a deep breath, ordered everything and I was able to make the thing work, so I can confirm: even with basic soldering skills (i.e. it’s ugly like hell :D) you can do the same.

:smiley: Text is done, but pictures aren’t… But I’d say in the next three days it will be ready. :slight_smile:

1 Like

I’ve tested this option. I have 2 AC with OSK102 and the component work great. I also have 1 AC with OSK103 dongle and is unavailable in HA.

I have tried to switch one OSK102 with the OSK103 dongle and the AC started to work with HA.

My question is: what differences have the two dongle?

@paddy0174 can’t wait to read the guide :wink:

They use different protocols. That makes it necessary, that with the OSK-103 you need to setup a fake server in your LAN. :slight_smile:

So when the guide will be released then I could easily connect my Midea AC with OSK103? Or I will have to but something? I don’t really know what is ESPHome? I read on the Internet but still my brain does not work hah. If it comes to the programming im good but I really fight with connecting accessories to HA :smiley:

HI All,

Have anyone experienced such behaviour - i have OSK103 (version 3 protocol). Running HA in Docker. Trying to add the integration with fake midea cloud. Did everything as mentioned here - GitHub - WMP/midea-ac-py at support-8370, but i get this error:

2021-04-21 10:14:48 ERROR (MainThread) [homeassistant.components.climate] Error while setting up midea_ac platform for climate
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 199, in _async_setup_platform
    await asyncio.shield(task)
  File "/config/custom_components/midea_ac/climate.py", line 73, in async_setup_platform
    device.authenticate(device_8370_only_ac_mac, device_8370_only_wifi_ssid, device_8370_only_wifi_pw)
  File "/usr/local/lib/python3.8/site-packages/msmart/device.py", line 43, in authenticate
    self._authenticate()
  File "/usr/local/lib/python3.8/site-packages/msmart/device.py", line 46, in _authenticate
    self._lan_service.authenticate(self._mac, self._wifi_ssid, self._wifi_pw)
  File "/usr/local/lib/python3.8/site-packages/msmart/lan.py", line 68, in authenticate
    self._authenticate()
  File "/usr/local/lib/python3.8/site-packages/msmart/lan.py", line 80, in _authenticate
    raise error
  File "/usr/local/lib/python3.8/site-packages/msmart/lan.py", line 76, in _authenticate
    tcp_key = self.security.tcp_key(response, self._key)
  File "/usr/local/lib/python3.8/site-packages/msmart/security.py", line 90, in tcp_key
    raise Exception('authentication failed')
Exception: authentication failed

My config is:

climate:
  - platform: midea_ac
    host: 192.168.0.43  (IP of AC)
    id: **************** (id od AC)
    8370_only_ac_mac: **********  (MAC of AC)
    8370_only_wifi_ssid: *********** (SSID which AC is connected to)
    8370_only_wifi_pw: ********** (password of SSID which AC is connected to)

Installed pip3.7 install git+https://github.com/kueblc/[email protected] inside the docker container.

Created a Fake Midea Service on 192.168.0.44

Made an entry in local DNS server pointing module.appsmb.com to the ip Fake Midea Clud Service (192.168.0.44)

Changed the DNS entry on HA Docker Host pointing to local DNS Server.

1 Like

I have exactly the same issue. Could it have something to do with the Python version? I’m using 3.9.4.
Just setup a Python 3.7.10 venv > same issue. So not the python version

I’d have the same issue.
It happens because version of msmart haven’t “support-8370” fix.
Try uninstall msmart and install msmart support-8370 version again.
It helped me.

I did it a lot of times already in HA venv on docker.

pip3.8 uninstall msmart

then

pip3.8 install git+https://github.com/kueblc/[email protected]

the problem persist.

According to the msmart tool the new U-shaped window AC units aren’t supported :frowning:

hello, community members. have a few Midea dongles for sale. Made two for myself, and some other as a rest. have a look on this WiFi dongle for air conditioner Midea Idea Neoclima Electrolux AC for Home Assis | eBay. Can pre-flash with required settings, if any. No LEDs = no annoying blinking at night).